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Prologue
Welcome

Welcome to Getting Started with Ubuntu, an introductory guide written to
help new users get started with Ubuntu.
Our goal is to cover the basics of Ubuntu (such as installation and working with the desktop) as well as hardware and software management, working with the command line, and security. We designed this guide to be
simple to follow, with step-by-step instructions and plenty of screenshots,
allowing you to discover the potential of your new Ubuntu system.
Canonical releases new versions of Ubuntu every six months; every
fourth release is a so-called long-term support (lts) version. Each Ubuntu
release has a version number that consists of the year and month number
of the release, and an alliterative code name using an adjective and an animal. Code names are in consecutive alphabetic order, allowing a quick
determination of which release is newer. Ubuntu 16.04 (code-named Xenial
Xerus) is considered a so-called lts version and is supported by Canonical with patches and upgrades for five years. The previous lts version
is Ubuntu 14.04 (Trusty Tahr), and has support for five years (until April
2019). Whenever a new LTS version of Ubuntu is released, we will incorporate updates and changes into our guide, and make a new version available
at http://www.ubuntu-manual.org.
Getting Started with Ubuntu 16.04 is not intended to be a comprehensive
Ubuntu instruction manual. It is a quick-start guide that will get you doing the things you need to do with your computer easily, without getting
bogged down with technical details. With the help of this guide, it should
not take long before new users get used to the Unity desktop environment.
Unity includes the Launcher, the Dash, the hud, indicators, and an onscreen display notification system (osd). All these features will be explained
in this guide.
For more detailed information on any aspect of the Ubuntu desktop, see
the “Ubuntu Desktop Guide,” which can be obtained in any of the following
ways:
‣ in the Dash, type help.
‣ in the indicator area, click Session indicator ‣ Ubuntu Help.
‣ go to https://help.ubuntu.com, Ubuntu 16.04 LTS ‣ Desktop HTML.
There are also many excellent resources available on the Internet. For
example, on https://help.ubuntu.com you will find documentation on installing and using Ubuntu. At the Ubuntu Forums (http://ubuntuforums.org)
and Ask Ubuntu (http://askubuntu.com), you will find answers to many
Ubuntu-related questions.
If something isn’t covered in this manual, chances are you will find the
information you are looking for in one of those locations. We will try our
best to include links to more detailed help wherever we can.

You can find more information about Ubuntu’s
online and system documentation in Chapter 8:
Learning More.

Ubuntu Philosophy

The term “Ubuntu” is a traditional African concept originating from the
Bantu languages of southern Africa. It can be described as a way of con-

People sometimes wonder how to pronounce
Ubuntu. Each u is pronounced the same as in
the word put except for the last u which is
pronounced the same as in the word due.
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necting with others—living in a global community where your actions
affect all of humanity. Ubuntu is more than just an operating system: it is
a community of people coming together voluntarily to collaborate on an
international software project that aims to deliver the best possible user
experience.
The Ubuntu Promise

‣ Ubuntu will always be free of charge, along with its regular enterprise
releases and security updates.
‣ Ubuntu comes with full commercial support from Canonical and hundreds of companies from across the world.
‣ Ubuntu provides the best translations and accessibility features that the
free software community has to offer.
‣ Ubuntu’s core applications are all free and open source. We want you to
use free and open source software, improve it, and pass it on.
A brief history of Ubuntu

Ubuntu was conceived in 2004 by Mark Shuttleworth, a successful South
African entrepreneur, and his company Canonical. Shuttleworth recognized
the power of Linux and open source, but was also aware of weaknesses that
prevented mainstream use.
Shuttleworth set out with clear intentions to address these weaknesses
and create a system that was easy to use, completely free (see Chapter 8:
Learning More for the complete definition of “free”), and could compete
with other mainstream operating systems. With the Debian system as a
base, Shuttleworth began to build Ubuntu. Using his own funds at first,
installation cds were pressed and shipped worldwide at no cost to the
recipients. Ubuntu spread quickly, its community grew rapidly, and soon
Ubuntu became the most popular Linux distribution available.
With more people working on the project than ever before, its core
features and hardware support continue to improve, and Ubuntu has gained
the attention of large organizations worldwide.
While large organizations often find it useful to pay for support services,
Shuttleworth has promised that the Ubuntu desktop operating system
will always be free. Ubuntu is installed on an estimated 2% of the world’s
computers. This equates to tens of millions of users worldwide, and is
growing each year. As there is no compulsory registration, the percentage
of Ubuntu users should be treated as an estimate.
What is Linux?

Ubuntu is built on the foundation of Linux, which is a member of the Unix
family. Unix is one of the oldest types of operating systems, and together
with Linux has provided reliability and security for professional applications for almost half a century. Many servers around the world that store
data for popular websites (such as YouTube and Google) run some variant
of Linux or Unix. The popular Android system for smartphones is a Linux
variant; modern in-car computers usually run on Linux. Even OS X is based
on Unix. The Linux kernel is best described as the core—almost the brain
—of the Ubuntu operating system.
The Linux kernel is the controller of the operating system; it is responsi-

To learn more about Canonical, go to http://
www.canonical.com.

Debian is the Linux operating system that
Ubuntu is based upon. For more information
visit http://www.debian.org/.

For information on Ubuntu Server Edition,
and how you can use it in your company, visit
http://www.ubuntu.com/server.
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ble for allocating memory and processor time. It can also be thought of as
the program which manages any and all applications on the computer itself.
While modern graphical desktop environments have generally replaced
early command line interfaces, the command line can still be a quick and
efficient way of performing many tasks. See Chapter 6: Advanced Topics
for more information, and Chapter 2: The Ubuntu Desktop to learn more
about gnome and other desktop environments.
Linux was designed from the ground up with security and hardware
compatibility in mind, and is currently one of the most popular Unix-based
operating systems. One of the benefits of Linux is that it is incredibly flexible and can be configured to run on almost any device—from the smallest
micro-computers and cellphones to the largest super-computers. Unix was
entirely command line-based until graphical user interfaces (guis) emerged
in 1973 (in comparison, Apple came out with Mac os ten years later, and
Microsoft released Windows 1.0 in 1985).
The early guis were difficult to configure, clunky, and generally only
used by seasoned computer programmers. In the past decade, however,
graphical user interfaces have grown in usability, reliability, and appearance. Ubuntu is one of many different Linux distributions.

To learn more about Linux distributions, see
Chapter 8: Learning More.

Is Ubuntu right for you?

New users to Ubuntu may find that it takes some time to feel comfortable
when trying a new operating system. You will no doubt notice many similarities to both Microsoft Windows and OS X as well as some differences.
Users coming from OS X are more likely to notice similarities due to the fact
that both OS X and Ubuntu originated from Unix. The Unity shell, which
is the default in Ubuntu, is a completely new concept, which needs some
exploring to get used to it. See Chapter 2: The Ubuntu Desktop for more
information about the Unity shell.
Before you decide whether or not Ubuntu is right for you, we suggest
giving yourself some time to grow accustomed to the way things are done
in Ubuntu. You should expect to find that some things are different from
what you are used to. We also suggest taking the following into account:
Ubuntu is community based. That is, Ubuntu is developed, written, and
maintained by the community. Because of this, support is probably
not available at your local computer store. Fortunately, the Ubuntu
community is here to help. There are many articles, guides, and manuals
available, as well as users on various Internet forums and Internet Relay
Chat (irc) rooms that are willing to assist beginners. Additionally, near
the end of this guide, we include a troubleshooting chapter: Chapter 7:
Troubleshooting.
Many applications designed for Microsoft Windows or OS X will not run on
Ubuntu. For the vast majority of everyday computing tasks, you will
find suitable alternative applications available in Ubuntu. However,
many professional applications (such as the Adobe Creative Suite) are
not developed to work with Ubuntu. If you rely on commercial software
that is not compatible with Ubuntu, yet still want to give Ubuntu a try,
you may want to consider dual-booting. Alternatively, some applications
developed for Windows will work in Ubuntu with a program called
Wine. For more information on Wine, see Chapter 6: Advanced Topics.
Many commercial games will not run on Ubuntu. If you are a heavy gamer,
then Ubuntu may not be for you. Game developers usually design games

To learn more about dual-booting (running
Ubuntu side-by-side with another operating
system), see Chapter 1: Installation.
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for the largest market. Since Ubuntu’s market share is not as substantial
as Microsoft’s Windows or Apple’s OS X, fewer game developers allocate
resources towards making their games compatible with Linux. If you just
enjoy a game every now and then, there are many high quality games
that can be easily installed through the Ubuntu Software application.
There are also a lot of games available at http://store.steampowered.com/
browse/linux/.
Contact details

Many people have contributed their time to this project. If you notice any
errors or think we have left something out, feel free to contact us. We do
everything we can to make sure that this manual is up to date, informative,
and professional. Our contact details are as follows:
‣
‣
‣
‣
‣

Website: http://www.ubuntu-manual.org/
Reader feedback: feedback@ubuntu-manual.org
irc: #ubuntu-manual on irc.freenode.net
Bug Reports: https://bugs.launchpad.net/ubuntu-manual/+filebug
Mailing list: ubuntu-manual@lists.launchpad.net

About the team

Our project is an open-source, volunteer effort to create and maintain quality documentation for Ubuntu and its derivatives.
Want to help?

We are always looking for talented people to work with, and due to the size
of the project we are fortunate to be able to cater to a wide range of skill
sets:
‣
‣
‣
‣
‣
‣
‣
‣
‣

Authors and editors
Programmers (Python or TEX)
User interface designers
Icon and title page designers
Event organizers and ideas people
Testers
Web designers and developers
Translators and screenshotters
Bug reporters and triagers

To find out how you can get started helping, please visit http://ubuntumanual.org/getinvolved.
Conventions used in this book

The following typographic conventions are used in this book:
‣ Button names, menu items, and other gui elements are set in boldfaced
type.
‣ Menu sequences are sometimes typeset as File ‣ Save As…, which means,
“Choose the File menu, then choose the Save As….”
‣ Monospaced type is used for text that you type into the computer, text
that the computer outputs (as in a terminal), and keyboard shortcuts.

See Chapter 5: Software Management to learn
more about Ubuntu Software.

1 Installation
Getting Ubuntu

Before you can get started with Ubuntu, you will need to obtain a copy of
the Ubuntu installation image for dvd or usb. Some options for doing this
are outlined below.

Many companies (such as Dell and System76)
sell computers with Ubuntu preinstalled. If
you already have Ubuntu installed on your
computer, feel free to skip to Chapter 2: The
Ubuntu Desktop.

Minimum system requirements

If you are unsure whether it will work on your computer, the Live dvd is a
great way to test things out first. Below is a list of hardware specifications
that your computer should meet as a minimum requirement.
‣
‣
‣
‣
‣
‣

1 GHz x86 processor (Pentium 4 or better)
1 gb of system memory (ram)
8.6 gb of disk space (at least 15 gb is recommended)
Video support capable of 1024×768 resolution
Audio support (recommended, but not required)
An Internet connection (highly recommended, but not required)

Downloading Ubuntu

The easiest and most common method for getting Ubuntu is to download
the Ubuntu dvd image directly from http://www.ubuntu.com/download.
Choose how you will install Ubuntu:
‣ Download and install
‣ Try it from a dvd or usb stick
Download and Install / Try it from a DVD or USB stick

For the Download and install, or Try it from a dvd or usb stick options, select
whether you require the 32-bit or 64-bit version (see the following section if
you are unsure), then click “Start download.”
32-bit versus 64-bit

Ubuntu and its derivatives are available in two versions: 32-bit and 64-bit.
This difference refers to the way computers process information. Computers capable of running 64-bit software are able to process more information
than computers running 32-bit software; however, 64-bit systems require
more memory in order to do this. Nevertheless, these computers gain performance enhancements by running 64-bit software.
‣ If your computer has a 64-bit processor, install the 64-bit version.
‣ If your computer is older, a netbook, or you do not know the type of
processor in the computer, install the 32-bit version.
If your computer has a 64-bit processor, select the “64-bit” option before
you click “Start download.”

32-bit and 64-bit are types of processor
architectures. Most new desktop computers
have a 64-bit capable processor.
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Downloading Ubuntu as a torrent

When a new version of Ubuntu is released, the download servers can get
“clogged” as large numbers of people try to download Ubuntu at the same
time. If you are familiar with using torrents, you can download the torrent
file by clicking “Alternative downloads,” and then “BitTorrent download.”
Downloading via torrent may improve your download speed, and will also
help to spread Ubuntu to other users worldwide.

Torrents are a way of sharing files and information around the Internet via peer-to-peer file
sharing. A file with the .torrent extension is
made available to users, which is then opened
with a compatible program such as uTorrent,
Deluge, or Transmission. These programs
download parts of the file from other people all
around the world.

Burning the DVD image

Once your download is complete, you will be left with a file called ubuntu16.04-desktop-i386.iso or similar (i386 here in the filename refers to the 32-bit
version. If you downloaded the 64-bit version, the filename contains amd64
instead). This file is a dvd image—a snapshot of the contents of a dvd—
which you will need to burn to a dvd.

While the 64-bit version of Ubuntu is referred
to as the “AMD64” version, it will work on Intel,
AMD, and other compatible 64-bit processors.

Creating a bootable USB drive

If your pc is able to boot from a usb stick, you may prefer to use a usb
memory stick instead of burning a dvd. Scroll down on the download
webpage to the “Easy ways to switch to Ubuntu” section and you will find
a link to instructions on how to create a bootable usb stick in your current
operating system. If you select this option, your installation will be running
from the usb memory stick. In this case, references to Live dvd, will refer to
the usb memory stick.
Trying out Ubuntu

The Ubuntu dvd and usb stick function not only as installation media, but
also allow you to test Ubuntu without making any permanent changes to
your computer by running the entire operating system from the dvd or usb
stick.
Your computer reads information from a dvd at a much slower speed
than it can read information off of a hard drive. Running Ubuntu from
the Live dvd also occupies a large portion of your computer’s memory,
which would usually be available for applications to access when Ubuntu is
running from your hard drive. The Live dvd/usb experience will therefore
feel slightly slower than it does when Ubuntu is actually installed on your
computer. Running Ubuntu from the dvd/usb is a great way to test things
out and allows you to try the default applications, browse the Internet, and
get a general feel for the operating system. It’s also useful for checking that
your computer hardware works properly in Ubuntu and that there are no
major compatibility issues.
To try out Ubuntu using the Live dvd/usb stick, insert the Ubuntu dvd
into your dvd drive, or connect the usb drive and restart your computer.
After your computer finds the Live dvd/usb stick, and a quick loading screen, you will be presented with the “Welcome” screen. Using your
mouse, select your language from the list on the left, then click the button
labelled Try Ubuntu. Ubuntu will then start up, running directly from the
Live dvd/usb drive.
Once Ubuntu is up and running, you will see the default desktop. We
will talk more about how to actually use Ubuntu in Chapter 2: The Ubuntu
Desktop, but for now, feel free to test things out. Open some applications,

In some cases, your computer will not recognize
that the Ubuntu DVD or USB is present as it
starts up and will start your existing operating
system instead. To run Ubuntu from the Live
DVD or USB, we want the computer to look
for information from the Live DVD or USB
first. Changing your boot priority is usually
handled by BIOS settings; this is beyond the
scope of this guide. If you need assistance with
changing the boot priority, see your computer
manufacturer’s documentation for more
information.
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Figure 1.1: The “Welcome” screen allows you to
choose your language.

change settings and generally explore—any changes you make will not be
saved once you exit, so you don’t need to worry about accidentally breaking
anything.
When you are finished exploring, restart your computer by clicking
the “Power” button in the top right corner of your screen (a circle with
a line through the top) and then select Restart. Follow the prompts that
appear on screen, including removing the Live dvd and pressing Enter
when instructed, and then your computer will restart. As long as the Live
dvd is no longer in the drive, your computer will return to its original state
as though nothing ever happened!

Alternatively, you can also use your mouse to
double-click the “Install Ubuntu 16.04” icon that
is visible on the desktop when using the Live
DVD. This will start the Ubuntu installer.

Installing Ubuntu—Getting started

At least 8.6 gb of free space on your hard drive is required in order to install
Ubuntu. We recommend 15 gb or more. This will ensure that you will
have plenty of room to install extra applications later on, as well as store
your own documents, music, and photos. To get started, place the Ubuntu
dvd in your dvd drive and restart your computer. Your computer should
load Ubuntu from the dvd. When you first start from the dvd, you will
be presented with a screen asking you whether you want to first try out
Ubuntu or install it. Select the language you want to view the installer
in and click on the Install Ubuntu button. This will start the installation
process.
If you have an Internet connection, the installer will ask you if you
would like to “Download updates while installing Ubuntu.” We recommend
you do so. The second option, “Install third-party software for graphics
and Wi-Fi hardware, Flash, MP3, and other media” includes the Fluendo
mp3 codec, and software required for some wireless hardware. If you are
not connected to the Internet, the installer will help you set up a wireless
connection.
The “Preparing to install Ubuntu” screen will also let you know if you
have enough disk space and if you are connected to a power source (in case
you are installing Ubuntu on a laptop running on battery). Once you have
selected your choices, click Continue.

Clicking on the underlined “release notes” link
will open a web page containing any important
information regarding the current version of
Ubuntu.
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Figure 1.2: Preparing to install.

Internet connection

If you are not connected to the Internet, the installer will ask you to choose
a wireless network (if available).
1. Select Connect to this network, and then select your network from the
list.
2. If the list does not appear immediately, wait until a triangle/arrow appears next to the network adapter, and then click the arrow to see the
available networks.
3. In the Password field, enter the network wep or wpa key (if necessary).
4. Click Connect to continue.

We recommend that you connect to the
Internet during install, although updates and
third-party software can be installed after
installation completes.

Figure 1.3: Set up wireless.

Allocate drive space

The Ubuntu installer will automatically detect any existing operating system installed on your machine, and present installation options suitable for
your system. The options listed below depend on your specific system and
may not all be available:
‣ Install alongside other operating systems
‣ Upgrade Ubuntu … to 16.04

If you are installing on a new machine with no
operating system, you will not get the first
option. The upgrade option is only available if
you are upgrading from a previous version of
Ubuntu.
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‣ Erase … and install Ubuntu
‣ Something else
Install alongside other operating systems.

For more complicated dual-booting setups, you will need to configure the partitions manually.

Figure 1.4: Choose where you would like to
install Ubuntu.

Upgrade Ubuntu … to 16.04

This option will keep all of your documents, music, pictures, and other
personal files. Installed software will be kept when possible (not all of your
currently installed software may be supported on the new version). Systemwide settings will be cleared.
Erase disk and install Ubuntu

Use this option if you want to erase your entire disk. This will delete any
existing operating systems that are installed on that disk, such as Microsoft
Windows, and install Ubuntu in its place. This option is also useful if you
have an empty hard drive, as Ubuntu will automatically create the necessary partitions for you.
Formatting a partition will destroy any data currently on the partition.
Be sure to back up any data you want to save before formatting. More
information and detailed instructions on partitioning are available at:
https://help.ubuntu.com/community/HowtoPartition.

After you have chosen the installation type, click Continue, or Install
Now.
Confirm Partition choices and start install

If you chose Something else, configure the partitions as you need. Once
you are happy with the way the partitions are going to be set up, click the
Install Now button at the bottom right to move on.
To reduce the time required for installation, Ubuntu will continue the
installation process in the background while you configure important user
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details—like your username, password, keyboard settings and default timezone.
Where are you?

Figure 1.5: Tell Ubuntu your location.

The next screen will display a world map. Using your mouse, click your
geographic location on the map to tell Ubuntu where you are. Alternatively,
you can type your location in the field below the map. This allows Ubuntu
to configure your system clock and other location-based features. Click
Continue when you are ready to move on.
Keyboard layout

Figure 1.6: Verify that your keyboard layout is
correct.

Next, you need to tell Ubuntu what kind of keyboard you are using.
In most cases, you will find the suggested option satisfactory. If you are
unsure which keyboard option to select, you can click the Detect Keyboard
Layout button to have Ubuntu determine the correct choice by asking you
to press a series of keys. You can also manually choose your keyboard
layout from the list of options. If you like, enter text into the box at the
bottom of the window to ensure you are happy with your selection, then
click Continue.
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Who are you?

Ubuntu needs to know some information about you so it can set up the
primary user account on your computer. When configured, your name will
appear on the login screen as well as the user menu, which we discuss in
Chapter 2: The Ubuntu Desktop.
On this screen you will need to tell Ubuntu:
‣
‣
‣
‣
‣

your name
what you want to call your computer
your desired username
your desired password
how you want Ubuntu to log you in
Figure 1.7: Setup your user account.

Enter your full name under Your name. The next text field is the name
your computer uses, for terminals and networks. You can change this to
what you want, or keep the predetermined name. Next is your username,
the name that is used for the user menu, your home folder, and behind the
scenes. You will see this is automatically filled in for you with your first
name. Most people find it easiest to stick with this. However, it can be
changed if you prefer.
Next, choose a password and enter it into both password fields. When
both passwords match, a strength rating will appear to the right that will
show you whether your password is “short,” “weak,” “fair,” or “good.” You
will be able to continue the installation process regardless of your password
strength, but for security reasons it is best to choose a strong one. This is
best achieved by having a password that is at least nine characters long,
with a mixture of uppercase and lowercase letters, as well as numbers
and symbols. Avoid words that can be found in a dictionary and obvious
passwords such as your birth date, spouse’s name, or the name of your pet.
Login Options

Finally, at the bottom of this screen you have two options regarding how
you wish to log in to Ubuntu. You may also choose to have Ubuntu encrypt
your home folder.
‣ Log in automatically
‣ Require my password to log in
– Encrypt my home folder

16
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Log in automatically

Ubuntu will log in to your primary account automatically when you start
up the computer so you won’t have to enter your username and password.
This makes your login experience quicker and more convenient, but if
privacy or security are important to you, we don’t recommend this option.
Anyone who can physically access your computer will be able to turn it on
and also access your files.
Require my password to login

This option is selected by default, as it will prevent unauthorized people
from accessing your computer without knowing the password you created earlier. This is a good option for those who, for example, share their
computer with other family members. Once the installation process has
been completed, an additional login account can be created for each family
member. Each person will then have their own login name and password,
account preferences, Internet bookmarks, and personal storage space.
Encrypt my home folder

This option provides you with an added layer of security. Your home folder
is where your personal files are stored. By selecting this option, Ubuntu
will automatically enable encryption on your home folder, meaning that
files and folders must be decrypted using your password before they can
be accessed. Therefore if someone had physical access to your hard drive
(for example, if your computer was stolen and the hard drive removed), they
would not be able to see your files without knowing your password.
If you choose this option, be careful not to enable automatic login at a later date.
It will cause complications with your encrypted home folder, and will potentially
lock you out of important files.

Finishing Installation

Ubuntu will now finish installing on your hard drive. As the installation
progresses, a slideshow will give you an introduction to some of the default
applications included with Ubuntu. These applications are covered in more
detail in Chapter 3: Working with Ubuntu. The slideshow will also highlight
the Ubuntu support options.
After approximately twenty minutes, the installation will complete and
you will be able to click Restart Now to restart your computer and start
Ubuntu. The dvd will be ejected, so remove it from your dvd drive and
press Enter to continue.
Wait while your computer restarts, and you will then see the login window (unless you selected automatic login).
Login Screen

After the installation has finished and your computer is restarted, you will
be greeted by the login screen of Ubuntu. The login screen will present you
with your username and you will have to enter the password to get past it.
Click your username and enter your password. Once done, you may click
the arrow or press Enter to get into the Ubuntu desktop. Ubuntu’s login
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Figure 1.8: Ubuntu community support options.
Where to get help for Ubuntu.

Figure 1.9: You are now ready to restart your
computer.

screen supports multiple users and also supports custom backgrounds for
each user. In fact, Ubuntu automatically will pick up your current desktop
wallpaper and set it as your login background.
The login screen allows you to update your keyboard language, volume
intensity and enable/disable accessibility settings before you log in to your
desktop. It also displays date/time and battery power for laptops. You can
also shut down or restart your system from the login screen.
Figure 1.10: Login Screen.

2 The Ubuntu Desktop
Understanding the Ubuntu desktop

Initially, you may notice many similarities between Ubuntu and other operating systems, such as Microsoft Windows or Apple OS X. This is because
they are all based on the concept of a graphical user interface (gui)—i.e.,
you use your mouse to navigate the desktop, open applications, move files,
and perform most other tasks. In short, things are visually oriented. This
chapter is designed to help you become familiar with various applications
and menus in Ubuntu so that you become confident in using the Ubuntu
gui.
Figure 2.1: The Ubuntu 16.04 default desktop.

Unity

All gui-based operating systems use a desktop environment. Desktop environments contain many features, including (but not limited to):
‣ The look and feel of the system
‣ The organization of the desktop
‣ How the user navigates the desktop
Ubuntu uses Unity as the default desktop environment. The Unity desktop is comprised of the desktop background and two bars—a horizontal
one located at the top of your desktop called the menu bar and a vertically
oriented bar at the far left called the Launcher.

To read more about other variants of Ubuntu,
refer to Chapter 8: Learning More.
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The desktop background

Below the menu bar at the top of the screen is an image covering the entire
desktop. This is the default desktop background, or wallpaper, belonging to
the default Ubuntu 16.04 theme known as Ambiance. To learn more about
customizing your desktop (including changing your desktop background),
see the section on Customizing your desktop below.
The menu bar

The menu bar incorporates common functions used in Ubuntu. The icons on
the far right of the menu bar are located in an area of the menu bar called
the indicator area, or notification area. Each installation of Ubuntu may
contain slightly different types and quantities of icons based on a number of
factors, including the type of hardware and available on-board peripherals
upon which the Ubuntu installation is based. Some programs add an icon
to the indicator area automatically during installation. The most common
indicators are:
Network indicator ( or ) manages network connections, allowing you to
connect quickly and easily to a wired or wireless network.
Text entry settings ( ) shows the current keyboard layout (such as En, Fr,
Ku, and so on) and, if more than one keyboard layout is chosen, allows
you to select a keyboard layout. The keyboard indicator menu contains
the following menu items: Character Map, Keyboard Layout Chart, and
Text Entry Settings.
Messaging indicator ( ) incorporates your social applications. From here,
among others, you can access instant messenger and email clients.
Sound indicator ( ) provides an easy way to adjust the sound volume as
well as access your music player and sound settings.
Clock displays the current time and provides a link to your calendar and
time and date settings.
Session indicator ( ) is a link to the system settings, Ubuntu Help, and
session options (like locking your computer, user/guest session, logging
out of a session, restarting the computer, or shutting down completely).
Every application has a menuing system where different actions can be
executed in an application (like File, Edit, View, etc.); the menuing system
for an application is appropriately called the application menu. It is located
in the left area of the menu bar. By default in Unity, the application menu
isn’t on the title bar of the application as is commonly the case in other gui
environments.
To show an application’s menu, just move your mouse to the desktop’s
menu bar (at the top of the screen). While your mouse is positioned here,
the active application’s menu options will appear in the desktop’s menu bar,
allowing you to use the application’s menuing options. When clicking on
the desktop, the desktop’s menu bar reappears. This capability in Unity to
display the application’s menu only when needed is especially beneficial
for netbook and laptop users with limited viewable screen space. You can
disable this feature via Session Indicator ‣ System Settings ‣ Appearance.
In the Behavior tab, under Show the menus for a window, select In the
window’s title bar.

For more about:

‣ the Messaging indicator see Using instant
messaging on page 59;

‣ the Network indicator see Getting online on
page 39;

‣ the Session indicator see Session options on
page 33.

Figure 2.2: The indicators of the menu bar.
Note that some older applications may still
display their menu within the application
window.

Figure 2.3: To show an application’s menu, just
move your mouse to the desktop’s menu bar (at
the top of the screen).
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The Launcher

The vertical bar of icons on the left side of the desktop is called the Launcher.
The Launcher provides easy access to applications, mounted devices, and
the Trash. All running applications on your system will place an icon in the
Launcher while the application is running. To change the Launcher icon
size, go to Session Indicator ‣ System Settings ‣ Appearance, tab Look.
The first icon at the top of the Launcher is the Dash, a component of
Unity. We will explore the Dash in a later section of this chapter. By default,
other applications appear in the Launcher, including the Files file manager,
LibreOffice, Firefox, any mounted devices, and the Trash, which contains
deleted folders and files, at the bottom of the Launcher.
Holding the Super key, also known as the Windows key (Win key),
located between the left Ctrl key and Alt key, will cause Ubuntu to superimpose a number onto the first ten applications in the Launcher and also
display a screen full of useful shortcuts. You can launch an application with
a number n on it by typing Super+n.
If you open more applications than can be shown in the Launcher, the
Launcher will “fold” the application icons at the bottom of the Launcher.
Simply move your mouse to the bottom of the Launcher, and you’ll see
the Launcher icons “slide” and the folded application icons unfold for easy
access.

Figure 2.4: The Ubuntu Launcher on the left
with a sample of applications on it.

Running applications

To run an application from the Launcher (or cause an already-running
application to appear), just click on the application’s icon.
Applications that are currently running will have one or more triangles
on the left side of the icon indicating the number of application windows
open for this application. Running applications also have a back-lit icon on
the Launcher.
The application in the foreground (i.e., the application that is on top of all
other open application windows) is indicated by a single white triangle on
the right side of its icon.
You can also run an application through the Dash which will be explored
in the upcoming The Dash section.
Adding and removing applications from the Launcher

Some also refer to an application in the
foreground as being in focus.

Figure 2.5: The triangles on each side of the
Firefox icon indicate Firefox is in the foreground
and only one window is associated with Firefox
at this time.

There are two ways to add an application to the Launcher:
‣ Open the Dash, find the application you wish to add to the Launcher, and
drag its icon to the Launcher.
‣ Run the application you want to add to the Launcher, right-click on the
application’s icon on the Launcher, and select Lock to Launcher.
To remove an application from the Launcher, right-click on the application’s icon, then select Unlock from Launcher.
The Dash

The Dash helps you quickly find applications and files on your computer.
If you’ve used Windows in the past, you’ll find the Dash to be similar to
the Windows Start menu or the Start Screen in Windows 8. OS X users will
find the Dash similar to Launchpad in the dock. If you’ve used a previous

For more information about the Dash and its
lenses, see https://wiki.ubuntu.com/Unity.
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version of Ubuntu or another gnome Linux distribution, the Dash serves
as a replacement for the various gnome 2 menus. The Dash allows you
to search for information both locally (installed applications, recent files,
bookmarks, etc.) and remotely (Twitter, Google Docs, etc.).
Figure 2.6: The Dash.

To explore the Dash, click on the topmost icon on the Launcher; the icon
contains the Ubuntu logo on it. After clicking the Dash icon, the desktop
will be overlaid by a translucent window with a search bar on top as well as
a grouping of recently accessed applications, files, and downloads. Ubuntu
also includes results from popular web services. The search bar provides
dynamic results as you enter your search terms.
Lenses

Lenses act as specialized search categories in the Dash: searching is accomplished by utilizing one or more lenses, also known as scopes, and each lens
is responsible for providing a category of search results through the Dash.
The six lenses installed by default at the bottom are: Home lens ( ),
Applications lens ( ), Files and Folders lens ( ), Videos lens ( ), Music
lens ( ), and Photos lens ( ).
Search for files and applications with the Dash

The Dash is an extremely powerful tool allowing you to search your computer for applications and files.
Find files/folders

The Dash can help you find names of files or folders. Simply type a portion
of the file or folder name. As you type, results will appear in the Dash. The
Files and Folders lens will also assist in finding files or folders—showing
you the most recently accessed files as well as the most recent downloads.
You can use the filter results button in the top-right corner of the Dash to
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filter results by attributes such as file or folder modification times, file type
(.odt, .pdf, .doc, .txt, etc.), or size.
Find applications

A standard Ubuntu installation comes with many applications. Users can
additionally download thousands of applications from the Ubuntu Software
application. As you collect an arsenal of awesome applications (and get
a bonus point for alliteration!), it may become difficult to remember the
name of a particular application; the Applications lens on the Dash can
assist with this search. This lens will automatically categorize installed
applications under “Recently used,” “Installed,” or “Dash plugins.” You can
also enter the name of an application (or a part of it) into the search bar in
the Dash, and the names of applications matching your search criteria will
appear. Even if you don’t remember the name of the application at all, type
a keyword that is relevant to that application, and the Dash will find it. For
example, type music, and the Dash will show you the default music player
and any music player you’ve used.

The Ubuntu Software application and software
management will be discussed in detail at
Chapter 5: Software Management.

If you are new to the world of Ubuntu, be sure
to read Chapter 3: Working with Ubuntu. It
will provide you with assistance in choosing
application(s) to suit your needs.

Figure 2.7: You can see the default results when
you press the Applications lens.

External search results

In addition to searching your local computer for applications and files, the
Dash can also search various online resources (e.g., Amazon.com). Results
pertinent to your search criteria are returned to you in the Dash. The online
search results within the Dash are turned off by default during installation.
If you want external search results, go to System Settings ‣ Security &
Privacy ‣ Search and set the “Include online search results” switch to the On
position.
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Workspaces

Workspaces are also known as virtual desktops. These separate views of
your desktop allow you to group applications together, and by doing so,
help to reduce clutter and improve desktop navigation. For example, you
can open all of your media applications in one workspace, your office suite
in another, and your web browser in a third workspace. Ubuntu has four
workspaces by default.
The workspaces feature is not activated by default in Ubuntu. To activate
workspaces, click on Session Indicator ‣ System Settings ‣ Appearance then
click on the Behavior tab and click on the Enable workspaces box. When
this box is checked, you’ll notice that another icon is added to the bottom of
the Launcher that looks like a window pane. This is the workspace switcher.
Switching between workspaces

If you’ve activated the workspace switcher as described above, you can
switch between workspaces by clicking on the workspace switcher icon
located on the Launcher. This utility allows you to toggle through the
workspaces (whether they contain open applications or not) and choose the
one you want to use. You can also launch the workspace switcher by typing
Super+s and choose a workspace by using the keyboard arrows followed by
RET (the Return / Enter key).

Figure 2.8: The workspace switcher on the
Launcher.

Managing windows

When opening a program in Ubuntu (such as a web browser or a text editor
—see Chapter 3: Working with Ubuntu for more information on using applications)—a window will appear on your desktop. Simply stated, a window is
the box that appears on your screen when you start a program. In Ubuntu,
the top part of a window (the title bar) will have the name of the application to the left (most often, the title will be the same as the application’s
name). A window will also have three buttons in the top-left corner. From
left to right, these buttons represent close window, minimize window, and
maximize window. Other window management options are available by
right-clicking anywhere on the title bar.
Closing, maximizing, restoring, and minimizing windows

To close a window, click on the close button ( ) in the upper-left corner of
the window—the first button on the left-hand side.
The button immediately to the right of the close button is the minimize
button ( ), which hides the window from view and minimizes it to the
Launcher. When an application is minimized to the Launcher, the left-side
of the icon in the Launcher will display an additional triangle. Clicking the
icon of the minimized application will restore the window to its original
position.
Finally, the right-most button is the maximize button ( ) which causes
the application to completely fill the desktop space. If a window is maximized, its top-left buttons and menu are automatically hidden from view.
To make them appear, just move your mouse to the menu bar. Clicking the
maximize button again will return the window to its original size.

Figure 2.9: This is the top bar of a window,
named title bar. The close, minimize, and
maximize buttons are in the top-left corner of
the window.
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Moving and resizing windows

To move a window around the workspace, place the mouse pointer over the
window’s title bar, then click and drag the window while continuing to hold
down the left mouse button. You can also move a window by holding the
Alt key and then clicking and holding the left mouse button while pointing
anywhere in the window and dragging the window to a new location. To
resize a window, place the pointer on an edge or corner of the window so
that the pointer turns into a larger, two-sided arrow (known as the resize
icon). You can then click and drag to resize the window.
Switching between open windows

In Ubuntu, there are many ways to switch between open windows:
‣ If the window is visible on your screen, click any portion of it to raise it
above all other windows.
‣ Use Alt+Tab to select the window you wish to work with. Hold down
the Alt key, and keep pressing Tab until the window you’re looking
for appears highlighted in the pop-up window. Then, release the Alt
key, and the application highlighted in the pop-up will move to the
foreground of your desktop.
‣ Click on the corresponding icon on the Launcher by moving your mouse
to the left side of the screen and right-clicking on the application’s icon.
If the application has multiple windows open, double-click on the icon in
order to select the desired window.
Press Ctrl+Super+D to hide all windows and display the desktop; the same
works to restore all windows.
Moving a window to a different workspace

To move a window to a different workspace, verify that the window isn’t
maximized. If it is maximized, click on the right-most button on the left
side of the title bar to restore it to its original size. Then right-click on the
window’s title bar and select:
‣
‣
‣
‣

Move to Workspace Left, to move the window to the left workspace
Move to Workspace Right, to move the window to the right workspace
Move to Workspace Down, to move the window to the bottom workspace
Move to Another Workspace, and then choose the workspace to where
you wish to move the window.

Note that the options available when moving windows to different
workspaces depends on which workspace contains the window you are
moving. If the window exists in the lower-right workspace, you will not see
a Move to Workspace Down because there is no workspace available below
the lower-right quadrant of a four quadrant workspace.
Window always on the top or on visible workspace

At times, you may want to force a window to always be in the foreground
so that it can be seen or monitored while you work with other applications.
For example, you may want to browse the web and, at the same time, view
and answer an incoming instant message. To keep a window always in
the foreground, right-click on the window’s title bar, then select Always
On Top. This window will now be on the top of all windows opened in

You can also use Shift+Control+Alt in
combination with the arrow keys to move a
window to a different workspace.
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the current workspace. If you want to have a window always on the top
regardless of the workspace, right-click on the window’s title bar, then
select Always on Visible Workspace. This window will now be on top of all
other windows across all workspaces.
Unity’s keyboard shortcuts

When you long-press the Super key (also known as the Win key) for a few
seconds, Unity will display a list of useful keyboard shortcuts, some of
which have been mentioned above.
Figure 2.10: Common keyboard shortcuts as
displayed by Unity.

Browsing files on your computer

There are two ways to locate files on your computer—search for them or
access them directly from their directory. You can search for a file using
the Dash or the Files file manager. You can also use the Dash or Files file
manager to access commonly used directories (such as Documents, Music,
Downloads) as well as the most recently accessed files.
Your home directory

The home directory is used to store all of your personal files (rather than
system files, such as applications).
In Ubuntu, by default, the contents of your home directory are accessible for and can be read by other users who have an account on your
PC.
The name of your home directory matches your login name and is created when your user account is created. When opening your personal
directory, you will see a collection of several directories, including Desktop (which contains any files that are visible on the desktop), Documents,
Downloads, Music, Pictures, Public, Templates, and Videos. These directories are created automatically during the installation process. You can add
more files and directories as needed.

The terms “directory” and “folder ” are often
used interchangeably.
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Files file manager

Just as Microsoft Windows has Windows Explorer and OS X has Finder to
browse files and directories, Ubuntu uses the Files file manager by default.
The Files file manager window

When you select the Files shortcut in the Launcher, click on a directory in
the Dash, or double-click a directory on the desktop, Ubuntu will open the
Files file manager. The default window contains the following features:
Figure 2.11: Files file manager displaying your
home directory.

menu bar The menu bar is located at the top of the screen. The Files menu
allows you to modify the layout of the browser, show, browse and remove bookmarks, open a Help document, open a new window, connect
to a server, or quit. Choosing Enter Location will open the Locations
text field where you can enter any location directly.
title bar The title bar shows the name of the currently selected directory. It
also contains the Close, Minimize, and Maximize buttons.
toolbar The toolbar displays your directory browsing history (using two
arrow buttons), your location in the file system, a search button, and
options for your current directory view.
Figure 2.12: The toolbar of the Files application
while browsing the directory /var/log/apt/, with
the Search functionality activated.

- On the upper left corner of the toolbar, there are two arrow icons.
These are similar to the “Back” and “Forward” history functionality in
web browsers. The Files application keeps track of where you are and
allows you to backtrack if necessary. As such, the buttons Previous
visited location and Next visited location allow you to navigate
through your directory browsing history.
- In the middle of the toolbar, you will see a representation of your
current directory location.
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- Clicking on the Search icon opens a text field so you can search for a
file or directory by name.
- Clicking on the View items as a grid icon (the default setting) enables
you to see the files and directories as icons. In this view, previews of
photos and text files are also displayed.
- Clicking on the View items as a list icon allows you to see a list
of files and directories, along with their size, type, and date of last
modification. You may customize what information is displayed by
right-clicking on either Name, Size, Type, or Modified. This action
will display a checklist of available options.
left pane The left pane of the file browser has shortcuts to commonly used
directories. You can also bookmark a directory through the menu bar
by choosing Bookmarks ‣ Bookmark this Location. Once you have
bookmarked the directory, it should appear in the left pane. Regardless
of the directory you are currently browsing, the left pane will always
contain the same directories.
right pane The largest pane shows the files and directories within the
directory you are currently browsing.
To navigate to a directory in Files, click (or double-click) on its icon in
the right pane, the left pane, or the toolbar.
Opening files

A file, in its simplest form, is data. Data can represent a text document,
database information, or other media such as music or videos. To open a
file, you can double-click on its icon. Ubuntu will try to find an appropriate
application with which to open the selected file. In some cases, you may
wish to open the file with a different application than the one Ubuntu selected. To select an application, right-click the icon and select one of the
Open With options.
Creating new directories

To create a new directory from within the Files file manager, right-click
in the blank area of the right pane and select New Folder from the popup menu (this action will also work on the desktop). Replace the default
“Untitled Folder” title with your desired label (e.g., “Personal Finances”).
You can also create a new directory by pressing Ctrl+Shift+N.
Hidden files and directories

If you wish to hide certain directories or files, place a dot (.) in front of the
name (e.g., “.Personal Finances”). In some cases, it is impossible to hide files
and directories without prefixing them with a dot.
You can easily view hidden files by clicking View ‣ Show Hidden Files or
by pressing Ctrl+H. Hiding files with a dot (.) is not a security measure—it is
simply a way to help you organize your files.
Copying and moving files and directories

You can cut, copy, and paste files or directories in the Files file manager by
right-clicking on the item and selecting the corresponding button from the
pop-up menu. You can also use the keyboard shortcuts Ctrl+X, Ctrl+C, and
Ctrl+V to cut, copy, and paste files and directories, respectively.
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Multiple files can be selected by left-clicking in an empty space (i.e.,
not on a file or directory), holding the mouse button down, and dragging
the cursor across the desired files or directories. This “click-drag” action is
useful when you are selecting items that are grouped closely together. To
select multiple files or directories that are not positioned next to each other,
hold down the Ctrl key while clicking on each item individually. Once
the desired files and/or directories are selected, right-click on any of the
selected items to perform an action just like you would for a single item.
When one or more items have been “copied,” navigate to the desired
location, then right-click in an empty area of the window and select Paste
to copy them to the new location. While the copy command can be used to
make a duplicate of a file or directory in a new location, the cut command
can be used to move files and directories. That is, a copy will be placed in a
new location, and the original will be removed from its current location.
Note that when you “cut” or “copy” a file or directory, nothing will
happen until you “paste” it somewhere. Paste will only affect the most
recent item(s) cut or copied.
To move a file or directory, select the item to move, then click Edit ‣ Cut.
Navigate to the desired location, then click Edit ‣ Paste. If you click on a
file or directory, drag it, then hold down the Alt key and drop it to your
destination directory, a menu will appear asking whether you want to copy,
move, or link the item.
As with the copy command above, you can also perform this action using
the right-click menu, and it will work for multiple files or directories at
once. An alternative way to move a file or directory is to click on the item,
and then drag it to the new location.
Using multiple tabs and multiple Files windows

Opening multiple Files file manager windows can be useful for dragging
files and directories between locations. You can also have multiple tabs to
browse multiple locations at once.
To open a second window when browsing a directory in Files, select
File ‣ New Window or press Ctrl+N. This will open a new window, allowing
you to drag files and/or directories between two locations. To open a new
tab, click File ‣ New Tab or press Ctrl+T. A new row will appear above the
space used for browsing your files containing two tabs—both will display
the directory you were originally browsing. You can click these tabs to
switch between them and click and drag files or directories between tabs
the same as you would between windows.
When dragging items between Files windows or tabs, a small symbol
will appear over the mouse cursor to let you know which action will be
performed when you release the mouse button. A plus sign (+) indicates
you are about to copy the item, whereas a small arrow means the item will
be moved. The default action will depend on the directories you are using.
Searching for files and folders on your computer

You can search for files and folders using the Dash or the Files file manager.
Search using the Dash

In the Dash, simply type your search terms in the search bar at the top of
the Dash.

Search for files and folders quickly by pressing
Ctrl+F in Files and then typing what you want
to find.
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Alternatively, you may use the Applications or Files & Folders lenses;
here you can use a filter to narrow down your search. Open the drop-down
menu on the right side of the search bar. If you’ve selected Applications,
you will be able to filter by application type. If you’ve chosen Files & Folders, you can filter by a host of options, including Last modified, Type (e.g.,
Documents), or Size. It is sufficient to type the first few letters of the file or
folder for which you are searching.
Search using Files file manager

In Files file manager, click on the magnifying glass button or press Ctrl+F.
This opens the search field where you can type the name of the file or folder
you want to find.
Customizing your desktop

Figure 2.13: You can change most of your
system’s settings here.

Most customizations can be reached via the Session Indicator and then
selecting System Settings to open the System Settings application window.
The Dash, desktop appearance, themes, wallpapers, accessibility, and other
configuration settings are available here. For more information see Session
options.
Appearance
The Look tab

In the Look tab you can change the background, window theme, and
Launcher icon size to further modify the look and feel of your desktop.
To begin, open Appearance by either right-clicking on your background
and selecting Change Desktop Background or selecting Session Indicator ‣
System Settings… ‣ Appearance. Select the Look tab.
Theme The “Appearance” window will display the current selected background wallpaper and theme. Themes control the appearance of your windows, buttons, scroll bars, panels, icons, and other parts of the desktop. The
Ambiance theme is used by default, but there are other themes from which
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Figure 2.14: You can change the theme in the
Look tab of the “Appearance” window.

you can choose. Just click once on any of the listed themes to give a new
theme a try. The theme will change your desktop appearance immediately.
Desktop background To change the Background, either select Wallpapers,
Pictures Folder, or Colors and Gradients from the drop-down list. When
Wallpapers is selected, you will see Ubuntu’s default selection of backgrounds. To change the background, simply click the picture you would like
to use. You’re not limited to this selection. To use one of your own pictures,
click the + button and navigate to the image you would like to use. Then
click the Open button, and the change will take effect immediately. This
image will then be added to your list of available backgrounds. Selecting
Pictures Folder opens your Pictures folder where you can choose a picture
for the background. The Colors and Gradients button allows you to set
the background to a solid or gradient color. Click on the Solid Color button, then the Pick a Color to choose a solid color. The Vertical Gradient
and Horizontal Gradient buttons bring up two Pick a Color buttons. Just
choose any two colors you like and see if you have achieved the desired
result.
Launcher icon size At the bottom of the Look tab you find a slider to
change the size of icons on the Launcher. You may choose from a range
between 32 and 64 pixels.
The Behavior tab

In the behavior tab you find several options to change the behavior of your
desktop.
Auto-hide the Launcher Switch the Auto-hide the Launcher to either show
the Launcher or reveal it when moving the pointer to the defined hot spot.
When turned on, you can choose the reveal location—Left side or Top left
corner—and the reveal sensitivity.
Enable workspaces By default, workspaces are not enabled. You can enable
workspaces by checking this option.
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Add show desktop icon to the launcher Check this option if you want to
show the desktop icon on the Launcher.
Show the menus for a window Here you can choose if you want menus to
show in the menu bar or in the window’s title bar.
Menus visibility You can change the visibility of your application menus
between two options. The first is Displayed on mouse hovering, which
will show application menus when the mouse hovers over the application
window. The second option is Always displayed, which allows application
menus to always be displayed when possible.
You can restore the behavior settings by clicking the Restore Behavior
Settings button.
Accessibility

Ubuntu has built-in tools that make using the computer easier for people
with disabilities. You can find these tools by opening the Dash and searching for “Universal Access,” or by selecting Session Indicator ‣ System Settings… ‣ Universal Access. Use the Seeing tab to manage the text size, the
contrast of the interfaces, enable a zoom tool, a virtual keyboard, a screen
reader, and so on. Selecting high-contrast themes and larger on-screen fonts
can assist those with vision difficulties. You can activate “Visual Alerts”
through the Hearing tab if you have hearing impairment. You can also
adjust keyboard and mouse settings to suit your needs through the Typing and Pointing and Clicking tabs, respectively. The Profiles tab will
allow you to enable the Accessibility Profiles Indicator with which you may
switch between the following profiles: Minor Motor Difficulties, Screen
reader with speech, High Contrast, Braille, and On-screen Keyboard.
Figure 2.15: Universal Access allows you to
enable extra features to make it easier to use
your computer.

Once you have finished toggling the settings to your needs, you may
need to log out of the computer and log back in for the changes to take
effect.
Screen reader (Orca)

Orca is a useful tool for people who have difficulties with their vision. It
comes preinstalled with Ubuntu and provides the “Screen Reader” functionality in Universal Access.
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The screen reader can be activated by using one of the following methods:
‣ Using the keyboard shortcut ALT-Super-s (in that order), or
‣ Using Session Indicator ‣ System Settings… ‣ Universal Access ‣ Screen
Reader ‣ ON/OFF, or
‣ Clicking on Dash and launching Orca.
Session options

When you have finished working on your computer, you can choose to log
out, suspend, restart, or shut down through the Session Indicator on the far
right side of the top panel.
Logging out

Logging out will leave the computer running but return the desktop to
the login screen. This is useful for switching between users, such as when
a different person wishes to log in to their account or if you are ever instructed to “log out and back in again.” You can also log out by pressing
Ctrl+Alt+Del. Before logging out, always verify that you have saved your
work in any open application.
Suspending

To save energy, you can put your computer into suspend mode which will
save the current opened applications to internal memory (RAM), power
off most of the internal devices and hardware, and allow you to start back
up more quickly. Unlike hibernation (which is not officially supported or
enabled in Ubuntu/Unity since 14.04 but can be enabled through other
means), while in a suspended state the computer will continue operating
using minimal electricity. Note that if the power goes out during this state,
unsaved changes will be lost and data loss may also occur. To put your
computer in suspend mode, select Suspend from the “Session Indicator”.
Rebooting

To reboot your computer, select Shut Down… from the “Session Indicator,”
then click the Restart icon.
Shutting down

To totally power down your computer, select Shut Down… from the “Session Indicator,” then click the Shut Down icon.
Other options

From the “Session Indicator”, select Lock/Switch Account… to either
lock the screen of the current user or switch user accounts. You can lock
your screen quickly by using the keyboard shortcut Ctrl+Alt+L. Locking
your screen is recommended if you are away from your computer for any
amount of time.
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Getting help
General Help

Figure 2.16: The built-in system help, accessible
via the keyboard shortcut F1, provides topicbased help for Ubuntu.

Like with many other operating systems, Ubuntu has a built-in help
reference called the Ubuntu Desktop Guide (Figure 2.16 on page 34). To
access it, click on the Dash and type Help. Alternatively, you can press F1
while on the desktop, or select Ubuntu Help from the Help menu in the
menu bar. Many applications have their own help section which can be
accessed by clicking the Help menu within the application window.
Online Help

If you can’t find an answer to your question in this manual or in the Ubuntu
Desktop Guide, you can ask for assistance from other Ubuntu users using
the Ubuntu Forums (http://ubuntuforums.org). To best assist you in solving the issue, it is best to provide as much information as possible when
submitting your query, such as:
‣
‣
‣
‣

System information (e.g. Ubuntu version, PC make and model)
The full text of any error messages you have encountered,
What you were doing at the time,
What were you trying to achieve / what you were expecting to happen…

Many Ubuntu users open an account on the forums to receive help and
in turn provide support to others as they gain more knowledge. Another
useful resource is the Ubuntu Wiki (https://wiki.ubuntu.com/community),
a website maintained by the Ubuntu community. You can additionally find
the Official Ubuntu Documentation, prepared by Ubuntu developers, at
https://help.ubuntu.com.
Last but not least, one other helpful resource for online help and assistance is Ask Ubuntu (https://askubuntu.com/). Ask Ubuntu is provided by
Stack Overflow and can be a helpful resource in addition to the previouslymentioned ones.
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Heads-Up Display help

Figure 2.17: The HUD (Heads-Up Display) shows
application-specific information and options
based on your general input.

The hud (Heads-Up Display) is a keyboard-friendly utility to help you
find commands, features, and preferences embedded deep within the
stacked menu structure of an application. Activate the hud by tapping
the Alt key on the keyboard.
For example, if you want to add music in Rhythmbox (the default music
player in Ubuntu) you can open the application, press Alt, and begin typing
add music. The options available in Rhythmbox will begin to appear as you
type, meaning you usually do not have to type many characters to obtain
useful results. You can use the Down/Up Arrow keys to navigate these results
and press the Enter key to active the selected option. While the hud is
primarily of use within applications, particularly those with deep menus
such as LibreOffice or GIMP, it may also be used on the Unity desktop itself
with no applications opened or given focus. With the hud, you can often
easily perform within a few keystrokes something that would otherwise
require navigating various menus and sub-menus.

3 Working with Ubuntu
All the applications you need

Because Ubuntu is a separate operating system, some applications that are
available for other operating systems (such as FreeBSD, Windows, or OS X)
may not be available for Ubuntu and vice versa. This is especially true for
closed source (i.e., proprietary) software released by makers of closed source
operating systems.
If you are migrating from a Windows or Mac platform, some of the
programs you were using have native Linux versions. For those that lack
compatibility, there are well established free software alternatives that will
cover your needs. This section will recommend some of these free software
applications that are known to work well on Ubuntu.
Office Suites

In Ubuntu you may choose among many office suites. The most popular
suite is LibreOffice (formerly OpenOffice). Included in the suite:
‣
‣
‣
‣
‣
‣

Writer: word processor
Calc: spreadsheet
Impress: presentation manager
Draw: drawing program
Base: database
Math: equation editor

The LibreOffice Suite comes pre-installed with Ubuntu by default. Note
that Base is not installed by default but can be installed through Ubuntu
Software.
Other office productivity applications that you might want to try out are
KOffice, Gnome Office (for older Ubuntu versions), Gnumeric (spreadsheet
application), Kexi (database application), and so on.
Email Applications

As with office suites, there are multiple options for email applications.
One very popular email application is Mozilla Thunderbird, which is also
available for Windows. Thunderbird is the default email application in
Ubuntu. Other options include Evolution and KMail.
Web Browsers

The default web browser in Ubuntu is Firefox. Other browsers you may
want to try out include Epiphany, Midori, Chromium, Opera*, and Google
Chrome*.
PDF Readers

Evince is the default pdf reader in Ubuntu. Others include Okular and
Adobe Reader*.

Most of the applications listed in this section
can be installed via the Ubuntu Software
application, are open source, and are freely
available. Those followed by an asterisk (*) can
be downloaded directly from their respective
official websites.
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Multimedia Players

For multimedia, Ubuntu users have a wide variety of options for high quality players. While VLC is a perennial favorite among videophiles, the classic
and user-friendly Totem is the default media player in Ubuntu. Other media
players, most of which can be installed through Ubuntu Software, are: Media Player, SMPlayer, Parole Media Player, mpv Media Player, Tomahawk,
Internet DJ Console, KMPlayer, Banshee (an all-round media player), and
Kaffeine (KDE).
Music Players and Podcatchers

There are several options for listening to music with Ubuntu: Rhythmbox
(installed by default), Amarok, Audacity (also a sound editor), Miro (also
a video player), VLC, and so on. These applications allow you to listen to
music and to your favorite podcasts. Amarok is similar to Winamp. Miro
may be of use especially to those who watch video podcasts and tv shows
from the Internet. VLC is well known for its ability to play a very wide
range of multimedia file formats.
CD/DVD Burning

There are several popular disk burning applications such as Gnome-baker,
Brasero, SimpleBurn, cd burner, Xfburn, and K3b. These CD/DVD creation
tools are powerful and offer user-friendly interfaces and numerous features.
Photo Management

You can view and manage your favorite photos with Shotwell, Ubuntu’s
default photo manager, gThumb, Gwenview, or F-Spot, among others.
Graphics Editors

gimp is a very powerful graphics editor. You can create your own graphics,
taper your photographs, and modify your pictures. Another useful Graphics
Editor is Inkscape, which allows you to create and edit Scalable Vector
Graphics images. Both gimp and Inkscape can be installed through Ubuntu
Software.
Instant Messaging

You can use Pidgin, Empathy, or Kopete to communicate over most protocols including: aim, msn, Google Talk, irc, Jabber/xmpp, Facebook, Yahoo!,
and icq. This means that you need only one application to communicate
with all of your friends. Note that some of these clients have limited video
support.
VoIP Applications

voip technologies allow you to talk to people over the Internet. The most
popular application is Skype, which is available for Ubuntu. An open-source
alternative, Ekiga, supports voice communication using the sip protocol.
Skype uses a proprietary protocol and is thus incompatible.
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BitTorrent Clients

There are a number of BitTorrent clients for Ubuntu: Transmission, Ubuntu’s
default client, is simple and light-weight. Deluge, Vuze, and KTorrent offer
many features and can satisfy the most advanced users.
Getting online

This section of the manual will help you to check your connection to the
Internet and help you configure it where needed. Ubuntu can connect to the
Internet using a wired, wireless, or dialup connection. Ubuntu also supports
more advanced connection methods, which will be briefly discussed at the
end of this section.
A wired connection is when your computer connects to the Internet
using an Ethernet cable. This is usually connected to a wall socket or a
networking device—like a switch or a router.
A wireless connection is when your computer connects to the Internet
using a wireless radio network—usually known as Wi-Fi. Most routers now
come with wireless capability, as do most laptops and netbooks. Because of
this, Wi-Fi is the most common connection type for these types of devices.
Wireless connectivity makes laptops and netbooks more portable when
moving to different rooms of a house and while travelling.
A dialup connection is when your computer uses a modem to connect to
the Internet through a telephone line.
NetworkManager

Networking in Ubuntu is by default managed with the NetworkManager
utility. NetworkManager allows you to turn network connections on or off,
manage wired and wireless networks, and make other network connections,
such as dialup, mobile broadband, and vpns.
You can access NetworkManager by using its icon found in the top panel.
This icon may look different depending on your current connection state.
Clicking this icon will reveal a list of available network connections. The
current connections (if any) will have the word “disconnect” underneath.
You can click on “disconnect” to manually disconnect from that network.
This menu also allows you to view technical details about your current
connection or edit all connection settings.
In the image to the right, you will see a check mark next to “Enable Networking.” Deselect “Enable Networking” to disable all network connections.
Select “Enable Networking” to enable networking again. This can be very
useful when you are required to turn off all wireless communications, like
in an airplane.
Establishing a wired connection

If you are already online at this point as indicated by the NetworkManager
icon in the top panel showing a connection, then you may have successfully
connected during the Ubuntu setup process. You can also simply open a
browser and see if you have access to the Internet. If so, you do not need to
do anything for the rest of this section. If not, then continue reading.
If you have an Ethernet cable running from a wall socket or networking
device, such as a switch or router, then you will want to setup a wired
connection in Ubuntu.

(a)
(b)
(c)
Figure 3.1: The network connection states: (a)
disconnected, (b) wired, and (c) wireless.

Figure 3.2: Here you can see the currently active
connection is “Wired connection 1.”
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In order to connect to the Internet with a wired connection, you need to
know whether your network supports dhcp (Dynamic Host Configuration
Protocol). dhcp is a way for your computer to automatically be configured
to access your network and/or Internet connection. dhcp is usually automatically configured on your router. This is usually the quickest and easiest
way of establishing a connection to the Internet. If you are unsure whether
your router is setup to use dhcp, you may wish to contact your isp’s (Internet Service Provider) customer service line to check. If your router isn’t
configured to use dhcp then they will also be able to tell you what configuration settings you need in order to get online. If you are connected to your
office LAN, you should contact your network administrator.
Automatic connections with DHCP

Figure 3.3: This window displays your IP address
and other connection information.

If your network supports dhcp, then you may already be set up for online access. To check this, click on the NetworkManager icon. There should
be an “Ethernet Network” heading in the menu. If either “Wired connection 1” or “Auto Ethernet” appears directly underneath, then your machine
is currently connected and probably setup for dhcp. If “Disconnected” appears in gray underneath the wired network section, look below to see if an
option labeled “Wired connection 1” appears in the list. If so, click on it to
attempt to establish a wired connection.
If you are still not online after following these steps, you may need to try
setting up your network connection manually using a static ip address. To
check if you are online, look for the NetworkManager icon in the top panel.
If the icon shows , then your computer was not successfully assigned
connection information through dhcp. If the icon shows either or ,
then it is likely that your dhcp connection to the router was successful.
To test your Internet connection, you may want to open the Firefox web
browser to try loading a web page. More information on using Firefox can
be found later in this chapter.
Manual configuration with static address

If your network does not support dhcp, then you need to know a few items
of information before you can get online. If you do not know any of this
information, then you call your isp.

An IP (Internet Protocol) address is a unique
number assigned to your machine so that your
router can identify you on the network. Think
of it like a phone number for your computer.
Having this unique address allows the router
to speak to your computer, and therefore
send/receive data.
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‣ An ip address—This is a unique address used for identifying your computer on the network. An ip address is always given in four numbered
groups, separated by dots, for example, 192.168.100.10. When connecting using dhcp, this address will periodically change (hence, the name
“dynamic”). However, if you have configured a static ip address, your ip
address will never change.
‣ A network mask—This tells your computer the size of the network to
which it is being connected. It is formatted the same way as the ip address, but usually looks something like 255.255.255.0.
‣ A gateway—This is the ip address of the device that your machine looks
to for access to the Internet. Usually, this will be the router’s ip address.
‣ dns server—This is the ip address of the dns (Domain Name Service)
server. dns is what your computer uses to resolve ip addresses to domain
names. For example http://www.ubuntu.com resolves to 91.189.94.156.
This is the ip address of the Ubuntu website on the Internet. dns is
used so you don’t have to remember ip addresses. Domain names (like
ubuntu.com) are much easier to remember. You will need at least one
dns server address but you can enter up to three addresses in case one
server is unavailable. If you do not know your isp’s dns server addresses,
Google has dns servers that anyone in the world can use for free. The
addresses of these servers are: Primary—8.8.8.8 Secondary—8.8.4.4.
To manually configure a wired connection, click on the NetworkManager
icon and select Edit Connections. Make sure you are looking at the Wired
tab inside the “Network Connections” window. The list may already have
an entry, such as “Wired connection 1” or a similar name. If a connection is
listed, select it and click the Edit button. If no connection is listed, click the
Add button.
If you are adding a connection, you need to provide a name for the
connection. This will distinguish the connection being added from any
other connections added in future. In the “Connection Name” field, choose a
name such as “Wired Home.”
Figure 3.4: In this window you can manually edit
a connection.

To setup the connection:
1. Make sure that the Connect automatically option is selected under the
connection name.
2. Switch to the ipv4 Settings tab.
3. Change the Method to “Manual.”
4. Click on the Add button next to the empty list of addresses.
5. Enter your ip address in the field below the Address header.
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6. Click to the right of the ip address, directly below the Netmask header
and enter your network mask. If you are unsure, “255.255.255.0” is the
most common.
7. Click on the right of the network mask directly below the Gateway
header and enter the address of your gateway.
8. In the dns Servers field below, enter the address of your dns server(s).
If you are entering more than one, separate them with commas—for
example, “8.8.8.8, 8.8.4.4”.
9. Click Save to save your changes.
A mac address is a hardware address for your computer’s network card. Entering
this information is sometimes important when using a cable modem connection.
If you know the mac address of your network card, this can be entered in the
appropriate text field in the Wired tab of the editing window. To find the mac
addresses for all installed networking devices, open a terminal window, and at
the command line prompt, type ifconfig. This will display a lot of information about each of the network devices installed on the computer. The wired
devices will begin with one of the four possible prefixes, and that prefix is en, for
Ethernet devices. wl is for Wireless (or Wireless Lan), sl is for Serial Line IP (slip),
and ww is for WWAN.

When you have returned to the Network Connections screen, your
newly added connection should now be listed. Click Close to return to the
desktop. If your connection was configured correctly, the NetworkManager
icon should have changed to show an active wired connection. To test if
your connection is properly set up, simply open a web browser. If you can
access the Internet, then you are connected!
Wireless

If your computer is equipped with a wireless (Wi-Fi) card and you have a
wireless network nearby, you should be able to set up a wireless connection
in Ubuntu.
Connecting to a wireless network for the first time

If your computer has a wireless network card, you can connect to a wireless
network. Most laptops and netbooks have a built-in wireless networking
card.
Ubuntu is usually able to detect any wireless network in range of your
computer. To see a list of wireless networks, click on the NetworkManager icon. Under the “Wireless Networks” heading you should see a list of
available wireless networks. Each network will be shown by its name and a
signal meter to the left showing its relative signal strength. The signal meter
looks like a set of bars similar to what is seen when viewing signal strength
of a cell phone. Simply put, the more bars, the stronger the signal. To improve speed and reliability of your wireless connection, try moving closer to
your router or wireless access point.
A wireless network can be open to anyone, or it can be protected with
a password. A small padlock will be displayed alongside the signal bar if
any wireless networks within range are password-protected. You will need
to know the correct password in order to connect to these secured wireless
networks.
To connect to a wireless network, select the desired network by clicking
on its name within the list. This will be the name that was used during the
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installation of the wireless router or access point. Most isps provide preconfigured routers with a sticker on them detailing the current wireless
network name and password. Most publicly accessible wireless networks
will be easily identifiable by the name used for the wireless network—for
example “Starbucks-Wireless.”
If the network is unprotected (i.e., the signal meter does not show a padlock), a connection should be established within a few seconds—and without a password required. The NetworkManager icon in the top panel will
animate as Ubuntu attempts to connect to the network. If the connection
is successful, the icon will change to display a signal meter. An on-screen
notification message will also appear informing you that the connection
was successful.
If the network is password-protected, Ubuntu will display a window
called “Wi-Fi Network Authentication Required” as it tries to make a connection. This means that a valid password is required to make a connection.
This is what the screen should look like:
Figure 3.5: Enter your wireless network
password.

If you know the password, enter it in the Password field and then click
on the Connect button. As you type the password, it will be obscured from
view to prevent others from reading the password as you type it. To verify
the characters you are entering for the password, you can view the password by selecting the Show Password check box. Then, you can make the
password obscure again by deselecting the Show password check box.
Once the password is entered, click on the Connect button. The NetworkManager icon in the top panel will animate as Ubuntu attempts to connect
to the network. If the connection is successful, the icon will change to display a signal meter. An on-screen notification message will also appear
informing you that the connection was successful.
If you entered the password incorrectly, or if it doesn’t match the correct password (for example if it has recently been changed and you have
forgotten), NetworkManager will make another attempt to connect to the
network, and the “Wi-Fi Network Authentication Required” window will
re-appear so that you can re-type the password. You can hit the Cancel button to abort the connection. If you do not know the correct password, you
may need to call your isp’s customer support line or contact your network
administrator.
Once you have successfully established a wireless connection, Ubuntu
will store these settings (including the password) to make it easier to connect to this same wireless network in the future. You may also be prompted
to select a keyring password here. The keyring stores passwords in one
place so you can access them all in the future by remembering just the
keyring password.
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Connecting to a saved wireless network

Ubuntu will automatically try to connect to a wireless network in range
if it has the settings saved. This works on both open and secure wireless
networks.
If you have numerous wireless networks in range that are saved on
your computer, Ubuntu may choose to connect to one network while you
may want to connect to another network. To remedy this action, click on
the NetworkManager icon. A list of wireless networks will appear along
with their signal meters. Simply click on the network to which you wish to
connect, and Ubuntu will disconnect from the current network and attempt
to connect to the one you have selected.
If the network is secure and Ubuntu has the details for this network
saved, Ubuntu will automatically connect. If the details for this network
connection are not saved, are incorrect, or have changed, then you will be
prompted to enter the network password again. If the network is open (no
password required), all of this will happen automatically and the connection
will be established.
Connecting to a hidden wireless network

In some environments, you may need to connect to a hidden wireless network. These hidden networks do not broadcast their names, and, therefore,
their names will not appear in the list of available wireless networks even
if they are in range. In order to connect to a hidden wireless network, you
will need to get its name and security details from your network administrator or isp.
To connect to a hidden wireless network:
1. Click on NetworkManager in the top panel.
2. Select Connect to a hidden wireless network. Ubuntu will then open
the “Connect to Hidden Wireless Network” window.
3. In the Network name field, enter the name of the network. This is also
known as the ssid (Service Set Identifier). You must enter the name exactly how it was given to you. For example, if the name is “UbuntuWireless,” entering “ubuntu-wireless” will not work as the “U” and “W”
are both uppercase in the correct name.
4. In the Wireless security field, select one of the options. If the network
is an open network, leave the field set to “None.” If you do not know the
correct setting for the field, you will not be able to connect to the hidden
network.
5. Click the Connect button. If the network is secure, you will be prompted
for the password. Provided you have entered all of the details correctly,
the network should then connect, and you will receive an on-screen
notification informing you that the connection was a success.
As is the case with visible wireless networks, hidden wireless network
settings will be saved once a connection is made, and the wireless network
will then appear in the list of saved connections.
Disabling and enabling your wireless card

By default, wireless access is enabled if you have a wireless card installed in
your computer. In certain environments (like on airplanes), you may need
to temporarily disable your wireless card.
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To disable your wireless card, click on the NetworkManager icon and
deselect the Enable Wireless option. Your wireless radio will now be turned
off, and your computer will no longer search for wireless networks.
To reactivate your wireless card, simply select the Enable Wireless option. Ubuntu will then begin to search for wireless networks automatically.
If you are in range of a saved network, you will automatically be connected.
Many modern laptops also have a physical switch/button built into the
chassis that provides a way to quickly enable/disable the wireless card.
Changing an existing wireless network

At times you may want to change the settings of a saved wireless network
—for example, when the wireless password gets changed.
To edit a saved wireless network connection:
1. Click on the NetworkManager icon and select Edit Connections…
2. A “Network Connections” window will open. Click on the Wireless tab.
3. By default, saved networks are in chronological order with the most
recently connected at the top. Find the network you want to edit, select
it, and click on the Edit button.
4. Ubuntu will now open a window called “Editing 〈connection name〉”,
where 〈connection name〉 is the name of the connection you are editing.
This window will display a number of tabs.
5. Above the tabs, there is a field called Connection name where you can
change the name of the connection to give it a more recognizable name.
6. If the Connect automatically option is not selected, Ubuntu will detect
the wireless network but will not attempt a connection until it is selected from the NetworkManager menu. Select or deselect this option as
needed.
7. On the Wireless tab, you may need to edit the ssid field. A ssid is the
wireless connection’s network name. If this field isn’t set correctly,
Ubuntu will not be able to connect to the wireless network in question.
8. Below the ssid is a Mode field. The “Infrastructure” mode means that
you would be connecting to a wireless router or Access Point. The “adhoc” mode is for a computer-to-computer connection (where one computer shares another’s connection) and is often only used in advanced
cases.
9. On the Wireless Security tab, you can change the Security field. A
selection of “None” means that you are using an open network that
doesn’t require a password. Other selections in this tab may require
additional information:
wep 40/128-bit Key is an older security setting still in use by some older
wireless devices. If your network uses this method of security, you
will need to enter a key in the Key field that will appear when this
mode is selected.
wep 128-bit Passphrase is the same older security as above. However,
instead of having a key, your network administrator should have
provided you with a passphrase to connect to the network.
wpa & wpa2 Personal is the most common security mode for wireless
networking. Once you select this mode, you will need to enter a
password in the Password field.
If your network administrator requires leap, Dynamic wep or wpa &
wpa2 Enterprise then you will need to have the administrator help
you with those modes.
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10. In the ipv4 Settings tab, you can change the Method field from “Automatic (dhcp)” to “Manual” or one of the other methods. For setting up
manual settings (also known as a static address), please see the section
above on manual setup for wired network connections.
11. When you finish making changes to the connection, click Apply to save
your changes and close the window. You can click Cancel at any time to
close the window without saving any changes.
12. Finally, click Close on the “Network Connections” window to return to
the desktop.
After clicking Apply, any changes made to the network connection will
take effect immediately.
Connecting to a mobile broadband network

If you have a mobile device capable of tethering, such as an Android tablet
or phone, then you may be able to utilize the mobile network connection
on your computer through the device. The steps to enable tethering on any
device can vary widely, but once you have enabled tethering on the device
and connected it to your computer (usually through usb) then it will show
up on the list of available and current connections in the NetworkManager
applet, located in the top panel. Be aware that doing this will send your
network traffic over the carrier provider’s mobile network and data rates
may apply (and add up quickly!). Many standard desktop applications do
not yet either detect mobile connections and restrict bandwidth usage or
allow you to change a setting in the application to have it do so.
Other connection methods

There are other ways to get connected with Ubuntu:
‣ With NetworkManager, you can connect to digital subscriber line (dsl)
networks, a method of connecting to the Internet through your phone
line via a modem.
‣ It is possible for NetworkManager to establish a virtual private network
(vpn) connection. These are most commonly used to create a secure
connection to a workplace network.
The instructions for making connections using dsl, or creating and
establishing vpn connections, are beyond the scope of this guide.
Browsing the web

Once you have connected to the Internet, you should be able to browse the
web. Mozilla Firefox is the default application for this in Ubuntu.
Starting Firefox

There are several ways to start Firefox. By default Ubuntu has the Firefox
icon within the Launcher (the vertical bar down the left side of the screen).
Select this icon to open Firefox. Or, open the Dash (the top-most icon in the
Launcher) and search for firefox using the search box. If your keyboard
has a “www” button, you can press that button to start Firefox.
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Figure 3.6: The default Ubuntu home page for
the Firefox web browser.

Navigating web pages
Viewing your homepage

When you start Firefox, you will see your home page. By default, this is the
Ubuntu Start Page.
To quickly go to your home page, press Alt+Home on your keyboard or
press on the home icon in Firefox.
Navigating to another page

To navigate to a new web page, you need to enter its Internet address (also
known as a url) into the Location Bar. urls normally begin with “http://”
followed by one or more names that identify the address. One example
is “http://www.ubuntu.com/.” (Normally, you can omit the “http://” part.
Firefox will fill it in for you.)

URL stands for uniform resource locator, which
tells the computer how to find something on
the Internet—such as a document, web page or
an email address. WWW stands for World Wide
Web, which means the web pages by which
most people interact with the Internet.

Figure 3.7: You can enter a web address or
search the Internet by typing in the location bar.

To navigate:
1. Double-click in the Location Bar, or press Ctrl+L, to highlight the url
that is already there.
2. Enter the url of the page you want to visit. The url you type replaces
any text already in the Location Bar.
3. Press Enter.
If you don’t know the url that you need, type a search term into the
Search Bar to the right of the Location bar. Your preferred search engine
—Google by default—will return a list of websites for you to choose from.
(You can also enter your query directly into the Location Bar).
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Selecting a link

Most web pages contain links that you can select. These are known as
“hyperlinks.” A hyperlink can let you move to another page, download a
document, change the content of the page, and more.
To select a link:
1. Move the mouse pointer until it changes to a pointing finger. This happens whenever the pointer is over a link. Most links are underlined text,
but buttons and pictures on a web page can also be links.
2. Click the link once. While Firefox locates the link’s page, status messages will appear at the bottom of the window.
Retracing your steps

If you want to visit a page you have viewed before, there are several ways
to do so.

To go backwards and forwards you can also use
Alt+Left and Alt+Right respectively.

‣ To go back or forward one page, press the Back or Forward button by
the left side of the Location Bar.
‣ To go back or forward more than one page, click-and-hold on the respective button. You will see a list of pages you have recently visited. To
return to a page, select it from the list.
‣ To see a list of any urls you have entered into the Location Bar, press
the down arrow at the right end of the Location Bar. Choose a page from
the list.
‣ To choose from pages you have visited during the current session, open
the History menu and choose from the list in the lower section of the
menu.
‣ To choose from pages you have visited over the past few months, open
the History ‣ Show All History (or press Ctrl+Shift+H). Firefox opens a
“Library” window showing a list of folders, the first of which is “History.”
Select a suitable sub-folder, or enter a search term in the search bar (at
the top right), to find pages you have viewed before. Double-click a
result to open the page.
Stopping and reloading

If a page is loading too slowly or you no longer wish to view a page, press
Esc to cancel it. To reload the current page if it might have changed since
you loaded it, press on the Reload button or press Ctrl+R.
Opening new windows

At times, you may want to have more than one browser window open. This
may help you to organize your browsing session better, or to separate web
pages that you are viewing for different reasons.
There are four ways to create a new window:
‣ On the top bar, select File ‣ New Window.
‣ Press Ctrl+N.
‣ Right-click on Firefox’s icon on the Launcher and select Open New
Window.
‣ Click on Firefox’s icon on the Launcher using your middle mouse button.
Once a new window has opened, you can use it exactly the same as
the first window—including navigation and opening tabs. You can open
multiple windows.

The Reload button is at the right end of the
Location Bar.
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Opening a link in a new window

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own independent window.
There are two ways to open a link in its own window:
‣ Right-click a link and select Open Link in New Window.
‣ Press-and-hold the Shift key while clicking a link.
Tabbed browsing

An alternative to opening new windows is to use Tabbed Browsing instead.
Tabbed browsing lets you open several web pages within a single Firefox
window, each independent of the other. This frees space on your desktop
as you do not have to open a separate window for each new web page. You
can open, close, and reload web pages in one place without having to switch
to another window.
You can alternate quickly between different tabs by using the keyboard
shortcut Ctrl+Tab.

A new tab is independent of other tabs in the
same way that new windows are independent
of other windows. You can even mix-and-match
—for example, one window may contain tabs
for your emails, while another window has tabs
for your work.

Opening a new blank tab

There are three ways to create a new blank tab:
‣ Click on the Open new tab button (a green plus-sign) on the right side of
the last tab.
‣ On the top bar, open File ‣ New Tab.
‣ Press Ctrl+T.
When you create a new tab, it contains a blank page with the Location
Bar focused. Type a web address (url) or other search term to open a website in the new tab.
Opening a link in its own tab

Sometimes, you may want to click a link to navigate to another web page,
but do not want the original to close. To do this, you can open the link in its
own tab.
There are several ways to open a link in its own tab.
‣ Right-click a link and select Open Link in New Tab.
‣ Press-and-hold the Ctrl key while clicking a link.
‣ Click the link using either the middle mouse button or both left and right
mouse buttons simultaneously.
‣ Drag the link to a blank space on the tab bar or onto the Open new tab
button.
‣ Press-and-hold Ctrl+Shift while clicking a link.
Closing a tab

Once you have finished viewing a web page in a tab, you have various ways
to close it:
‣
‣
‣
‣

Click on the Close button on the right side of the tab.
Click the tab with the middle mouse button or the mouse wheel.
Press Ctrl+W.
Right-click the tab and select Close Tab.

A tab always opens “in the background”—in
other words, the focus remains on the original
tab. The last method (Ctrl+Shift) is an
exception; it focuses the new tab immediately.
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Restoring a closed tab

Sometimes, you may close the wrong tab by accident, or want to bring back
a tab that you have recently closed. Bring back a tab in one of the following
two ways:
‣ Press Ctrl+Shift+T to re-open the most recently closed tab.
‣ Select History ‣ Recently Closed Tabs, and choose the name of the tab to
restore.
Changing the tab order

Move a tab to a different location on the tab bar by dragging it to a new
location using your mouse. While you are dragging the tab, Firefox displays
a small indicator to show the tab’s new location.
Moving a tab between windows

You can move a tab into a new Firefox window or, if one is already open,
into a different Firefox window.
Drag a tab away from the tab bar, and it will open into a new window.
Drag it from the tab bar into the tab bar of another open Firefox window,
and it will move there instead.
Searching

You can search the web from within Firefox without first visiting the home
page of the search engine. By default, Firefox will search the web using the
Google search engine.
Searching the web

To search the web in Firefox, type a few words into the Firefox search Bar.
For example, if you want to find information about Ubuntu:
1. Move your cursor to the Search Bar using your mouse or press Ctrl+K.
2. Type the phrase Ubuntu. Your typing replaces any text currently in the
Search Bar.
3. Press the magnifying glass or Enter to search.
Search results from Google for “Ubuntu” will appear in the Firefox window.
Selecting search engines

If you do not want to use Google as your search engine in the Search Bar,
you can change the search engine that Firefox uses.
To change your preferred search engine, press the search logo (at the
left of your Search Bar—Google by default) and choose the search engine of
your choice. Some search engines, such as Bing, Google and Yahoo, search
the whole web; others, such as Amazon and Wikipedia, search only specific
sites.
Searching the web for words selected in a web page

Sometimes, you may want to search for a phrase that you see on a web
page. You can copy and paste the phrase into the Search Bar, but there is a
quicker way.

Figure 3.8: These are the other search engines
you can use—by default—from the Firefox
search bar.
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1. Highlight the word or phrase in a web page using your left mouse button.
2. Right-click the highlighted text and select Search [Search Engine] for
[your selected words].
Firefox passes the highlighted text to the search engine, and opens a new
tab with the results.
Searching within a page

Figure 3.9: You can search within web pages
using the Find Toolbar.

You may want to look for specific text within the web page you are
viewing. To find text within the current page in Firefox:
1. Choose Edit ‣ Find or press Ctrl+F to open the Find Toolbar at the
bottom of Firefox.
2. Enter your search query into the Find field in the Find Toolbar. The
search automatically begins as soon as you type something into the field.
3. Once some text has been matched on the web page, you can:
‣ Click on Next to find text in the page that is below the current cursor
position.
‣ Click on Previous to find text that is above the current cursor position.
‣ Click on Highlight all to highlight all occurrences of your search
words in the current page.
‣ Select the Match case option to limit the search to text that has the
same capitalization as your search words.
To quickly find the same word or phrase again, press F3.
You can skip opening the Find Toolbar altogether.
1. Turn on the relevant Accessibility option with Edit ‣ Preferences ‣
Advanced ‣ General ‣ Accessibility ‣ Search for text when I start typing ‣ Close.
2. Now, provided your cursor is not within a text field, when you start
typing, it will automatically start searching for text.
Viewing web pages full screen

To display more web content on the screen, you can use Full Screen mode.
Full Screen mode hides everything but the main content. To enable Full
Screen mode, choose View ‣ Full Screen or press F11. While in full-screen
mode, move your mouse to the top of the screen to reveal the url and
search bars.
Press F11 to return to normal mode.
Copying and saving pages

With Firefox, you can copy part of a page so that you can paste it elsewhere,
or save the page or part of a page as a file on your computer.
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Copying part of a page

To copy text, links or images from a page:
1. Highlight the text and images with your mouse.
2. Right-click the highlighted text and select Copy, or press Ctrl+C.
To copy just a single image, it is not necessary to highlight it. Just rightclick the image and select Copy.
You can paste the results into another application, such as LibreOffice.
Copying a link

To copy a text or image link (url) from a page:
1. Position the pointer over the text, link or image. Your mouse pointer
changes to a pointing finger.
2. Right-click the link or image to open a pop-up menu.
3. Select Copy Link Location.
You can paste the link into other applications or into Firefox’s Location
Bar.
Saving all or part of a page

To save an entire page in Firefox:
1. Choose File ‣ Save Page As from the top bar, or press Ctrl+S. Firefox
opens the “Save As” window.
2. Choose a location for the saved page.
3. Type a file name for the page.
4. Press Save.
To save an image from a page:
1. Position the mouse pointer over the image.
2. Right-click the image and select Save Image As. Firefox opens the “Save
Image” window.
3. Choose a location for the saved image.
4. Enter a file name for the image.
5. Press Save.
Changing your home page

Firefox shows the home page when it opens. By default, this is the Ubuntu
Start Page. You can change your default home page to a new one, or even to
several new ones.
To change your home page:
1. Navigate to the page that you would like to become your new home
page. If you want Firefox to open more than one tab when it starts, open
a new tab and navigate to the extra page as many times as you would
like.
2. Choose Edit ‣ Preferences ‣ General ‣ Startup ‣ Use Current Pages ‣
Close.

The home page can also be set by entering the
addresses that should be open in the Home
Page, with a pipe (“|”) separating pages to be
opened in separate tabs.
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Figure 3.10: Change Firefox settings in this tab.

Download settings

In Edit ‣ Preferences ‣ General ‣ Downloads, you can tell Firefox where to
place downloaded files, and whether or not to ask where each time.
Bookmarks

When browsing the web you may want to come back to certain web pages
again without having to remember the url. To do this, you bookmark each
page. These bookmarks are saved in the web browser, and you can use them
to re-open to those web pages.
Bookmarking a page

After navigating to a web page you can save its location by bookmarking it.
There are two ways to bookmark a page:
‣ From the top bar, choose Bookmarks ‣ Bookmark This Page, or press
Ctrl+D. A window opens, allowing you to provide a descriptive name for
the bookmark and a location (within the browser’s bookmarks) to save it.
Press Done to save.
‣ Press the star on the right-hand side in the Location Bar. It turns blue.
This saves the page in the Unsorted Bookmarks folder.
Navigating to a bookmarked page

To navigate to a bookmarked page, open the Bookmarks menu from the top
bar, and choose your bookmark. Firefox opens the bookmark in the current
tab.
You can reveal the bookmarks, including the Unsorted Bookmarks, in a sidebar
on the left of the browser window. Select View ‣ Sidebar ‣ Bookmarks, or press
Ctrl+B. Repeat, or press the close button at its top, to hide the sidebar.

The Downloads folder in the Library lists files
downloaded in the past. It can be used to open
or re-download files.
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Deleting or editing a bookmark

To delete or edit a bookmark, do one of the following:
‣ If you are viewing the page already, the star in the Location Bar will
be blue. Press it. Firefox opens a small pop-up window, where you can
either Remove Bookmark or edit the bookmark.
‣ Select Bookmarks ‣ Show All Bookmarks or press Shift+Ctrl+O. In
the window that opens, you can navigate to bookmarks. Select the one
you would like to change. To delete, right-click and choose Delete or
press Delete on your keyboard. To edit, change the details shown at the
bottom of the window.
History

Whenever you are browsing the web, Firefox saves your browsing history.
This allows you to come back to a web page that you have recently visited
without needing to remember or bookmark the page’s url.
To see your most recent history, open the History menu from the top
bar. The menu displays several of the most recent web pages that you have
viewed. Choose one of the pages to return to it.
To view the complete history, either:
‣ Select View ‣ Sidebar ‣ History or press Ctrl+H to view the history in
a sidebar; this replaces the bookmarks sidebar if it is open. (Repeat, or
press the close button at its top, to hide the sidebar.)
‣ Select History ‣ Show All History or press Shift+Ctrl+H to view the
history in a pop-up window.
Your browsing history is categorized as “Today,” “Yesterday,” “Last 7
days,” “This month,” the previous five months by name, and finally “Older
than 6 months.” If the history for a category does not exist, that category
will not be listed. Select one of the date categories in the sidebar to expand
it and reveal the pages that you visited during that time. Once you find the
page you want, select it to re-display it.
You can also search for a page by its title or url. Enter a few letters
from one or more words or, optionally, the url in the Search field at the
top of the history sidebar. The sidebar displays a list of web pages matching
your search words. Select the page you want. (You can even do this in the
Location Bar, saving you from having to open the History sidebar or pop-up
window.)
Clearing private data

Firefox stores all its data only on your computer. Nevertheless, if you share
your computer, you may at times want to delete all private data.
Select History ‣ Clear Recent History… or press Shift+Ctrl+Delete.
Choose your Time range to clear, and under Details which items to clear,
and press Clear Now.
Preventing Firefox from recording private data

You can start a “private browsing” session during which Firefox will not
record anything permanently. This lasts until you disable private browsing
or restart Firefox.
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Choose File ‣ New Private Window or press Shift+Ctrl+P. As long
as you remain in this mode, Firefox will not record browsing, download,
form or search history, or cookies, nor will it cache files. However, if you
bookmark anything or download files, these will be retained.
To end private browsing, just close the private browsing window by
clicking on its close button or pressing Shift+Ctrl+W, or restart Firefox.
Using a different web browser

Figure 3.11: The Default Applications where you
can change your preferred browser.

If you choose to install a different web browser on your computer,
you may want to use it as the default browser when you click links from
emails, instant messages, and other places. Canonical supports Firefox and
Chromium (Google’s open-source version of Chrome), but there are several
others that you can install.
To change your preferred web browser, open Session Indicator from the
top panel on the far right-hand side, and open System Settings… ‣ Details ‣
Default Applications. Choose your preferred web browser from the dropdown menu Web.
Reading and composing email
Introduction to Thunderbird

Thunderbird is an email client developed by Mozilla and is easy to setup and
use. It is free, fast, and comes packed full of useful features. Even if you are
new to Ubuntu and Thunderbird, you will be up and running in no time,
checking your email and staying in touch with friends and family.
Setting up Thunderbird

In the top right corner of the Ubuntu desktop you will see an envelope
icon in the notification area. This is the messaging menu. From here, you
can launch Thunderbird by clicking Set up Mail. Alternatively, you can
click the Ubuntu button in the top left corner of the screen at the top of the
Launcher to bring up the Dash and type thunderbird into the search box.
Once Thunderbird opens, you will be greeted by a pop-up box prompting
you to setup your email account.
Before a valid email account is set up in Thunderbird, the first screen to
appear will be an introductory message from Mozilla inviting you to set
up an email account through a local service provider in your area. For the
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Figure 3.12: Setting up Thunderbird

purposes of these instructions, we will assume you already have an email
address, so you can click on the button in the lower right corner of the
screen that says Skip this and use my existing email.
On the next screen titled Mail Account Setup, enter your name in the
first text box, your email address in the second text box (for example, username@domain.com), and your email password in the third text box.
Once completed, click the Continue button. Thunderbird will automatically set up your email account for you. When Thunderbird finishes
detecting your email settings, click Create Account and Thunderbird will do
the rest. You can also set Thunderbird as your default news and rss reader
by checking the boxes in the pop-up box that appear after you click Create
Account. If you don’t want to see this message box every time you start
Thunderbird, simply deselect Always perform this check when starting
Thunderbird. You are now ready to start using Thunderbird.
Around the Thunderbird workspace

Now that you have your email account set up, let’s get to know the Thunderbird workspace. Thunderbird is designed to be very user-friendly and
easy to navigate. When you open the application, you will see the main
workspace with your email folders (all folders pane) on the left. On the
right of the screen, you will see two panes. The top-right pane displays a
list of your received email, and the bottom-right pane displays the current
email you are viewing. The size of these panes can be easily resized to suit
your viewing environment. To resize the panes, simply left-click and hold
the dividing bar that separates two panes and drag it to the desired position.
The All Folders pane is where you can see your mail folders. This pane can
also include:
Inbox Where your email is stored and accessed
Email address folder You will see one of these folders for each of the accounts you have setup
Drafts Where your draft emails are stored
Sent mail Where the emails you have sent are stored
Spam This is where suspected spam email is stored so you can check them
to make sure you haven’t lost any important emails
Trash This is where messages you’ve deleted are stored so you can double
check to make sure you haven’t accidentally deleted an important email
(also one of the local folders)
Important This is where emails you have marked as important are stored
Starred This is where emails you have marked with a star are stored

If Thunderbird fails to create the account,
you may need to configure it manually, using
the parameters that were sent to you by your
email address provider and your ISP. If you
are still unable to set up your account, you
can get help from community members at
http://ubuntuforums.org.
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Personal This is where emails you have marked as personal are stored
Receipts You can move important receipts to this folder.
Travel You can use this folder to store travel emails such as flight times and
bookings
Work You can store work emails in this folder to keep them separate from
your personal email
Outbox Where the emails you are in the process of sending are stored (also
one of the local folders)
Across the top of the Thunderbird workspace, you will see at least four
control buttons, Get Mail, Write, Address Book, and Tag. These are used to
get your mail, write your mail, access your address book, and tag your email
messages.
At the top-right of the All Folders pane, you will see a set of quick filter
buttons, Unread, Starred, Contact, Tags, and Attachment. You can use
these buttons to filter your email messages so that you only see your unread
mail, your favorite mail (starred), mail from people in your address book,
mail you have tagged, and mail that includes attachments.
If you are accustomed to a more traditional desktop and you have Thunderbird maximized to full screen, you might be wondering where the menus
are located. They are still there, and if you want to access them, move your
mouse to the top of the screen and you will see the familiar menus: File,
Edit, View, Go, Message, Tools, and Help.
At the top of the pane that displays your email, you can see six action
buttons, Reply, Reply All, Forward, Archive, Junk, and Delete. You will
find these very useful for quickly replying to email, forwarding your email
to another person, archiving (backing up) your email, marking an email as
junk mail, and quickly deleting an email. To the left of these quick action
buttons, you will see information about the email you are viewing that
includes the sender’s name, the subject of the email, the reply address, and
the recipient of the email.
Using your address book

At the top of the main workspace, you will see the Address Book button.
Click this button to access your address book. The address book opens in a
new window. From here, you can easily organize your contacts. At the top
of the address book window, you will see five buttons, New Contact, New
List, Properties, Write, and Delete. They function in the following ways:
New Contact This button allows you to add a new contact and add as much
detail as you wish to save, including name, nickname, address, email,
additional email, screen name, work number, home number, fax, pager
and mobile/cell number.
New List This button allows you to add lists for your contacts such as
family, friends, acquaintances, etc.
Properties This button allows you to rename your address book name. The
default name is personal address book, but you can change the name as
you see fit.
Write This button allows you to quickly send an email to a selected contact
without needing to go back to the main Thunderbird workspace. Simply
select a contact from your contacts list and click the Write button to
send them an email.
Delete This button allows you to quickly delete a contact from your address
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book. Just select the contact you want to delete and press Delete to
remove the contact from your address book.
Checking and reading messages

Thunderbird will automatically check your email account for new messages every ten minutes, but if you need to manually check for new messages at any time, left-click the Get Mail button in the top left corner of
the workspace. Thunderbird will then check your email account for new
messages and download them.
As they are downloaded, you will see the new email appear in the message pane on the right side of the workspace. When you click on one of
your emails, it will appear in the pane below your email list. If you want to
view your email in a full window, double-left-click your chosen email, and
Thunderbird will display the email in a full window in its own tab.
At the top of the open email, you will see information about the email
and the five quick action buttons, Reply, Forward, Archive, Junk and
Delete as previously discussed. If an email has remote content, you will
see a message asking if you want to display the email or not.
You may want to sort out your emails from time to time; this is easily
done with Thunderbird. When you have an email selected and you want
to tag the email, simply click the Tag button and a drop-down list will be
displayed. In this drop-down list, you have the options to Remove All Tags
or Mark as…, Important, Work, Personal, To Do, Later. You can also create
a New Tag more suited to your own personal requirements.
Composing Messages

To compose a new email message, click the Write button in the top left of
the workspace. This will bring up a new window where you can compose
your new email. In the To: field, enter the email address of the destination
—the contact to whom you are sending this email. If there is more than one
contact to whom you are writing, separate multiple recipients with commas.
If a contact that you are addressing is in your address book, you can
address them by name. Start typing the name of the contact; Thunderbird
will display the list of mailing contacts below your text. Once you see the
contact you intend to address, click on their email address or use the down
arrow key and then press Enter to select the address.
If you would like to carbon-copy (Cc) some contacts, click the To: field
and select Cc:. Contacts who are listed on the To: and Cc: lines will receive
the email, and will see the rest of the contacts to whom an email was sent.
If you would like to send an email to some contacts without disclosing to
whom your email was sent, you can send a blind carbon-copy, or Bcc. To
enable Bcc, select Bcc: by clicking the To: field and selecting Bcc:. Any
contacts entered in the Bcc: field will receive the message, but none of the
recipients will see the names or emails of contacts on the Bcc: line.
Instead of typing the email addresses or names of the contacts you are
addressing in the message, you can select the contacts from your address
book. Start typing a few letters from your contact’s first or last name in the
To: field to filter the list to only show mailing contacts. Once you identify
the contact you would like to address, click on their name in the list. If
you’ve added the contact in error, delete their address and enter the correct
address.
You may enter a subject for your email in the Subject field. Messages

Remote content represent parts of an email
that may be hosted elsewhere. Remote content
might consist of video or audio, but most
often is graphics or HTML content. For security
purposes, Thunderbird will ask you if you wish
to view this remote content.
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should have a subject to help the recipient identify the general contents of
the email while glancing at their message list. Enter the contents of your
message in the big text field below the subject. There is no practical limit on
the amount of text you can include in your message.
By default, Thunderbird will auto-detect the correct format for your
email but you can change this by clicking Options then mouse over Delivery Format and select your preferred option from the list. You have a
choice of Auto-Detect, Plain Text Only, Rich Text (HTML) Only, and Plain and
Rich (HTML) Text.
When you have finished composing your email, click on the Send button
on the window’s toolbar. Your message will be placed in the Outbox, and
will be sent to your desired recipient.
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If you do not include a subject in your email,
Thunderbird will warn you about this omission.

Attaching files

At times, you may want to send files to your contacts. To send files, you
will need to attach them to your email message. To attach a file to an email
you are composing, click on the Attach button. When the new window
opens, select the file you want to send and click Open. The file you selected
will then be attached to the email when you click send.

You can attach quite a few different file types
to emails, but be careful about the size of the
attachments! If they are too big, some email
systems will reject the email you are sending,
and your recipient will never receive it!

Replying to Messages

In addition to composing new messages, you may want to reply to messages
that you receive. There are three types of email replies:
Reply or Reply to Sender sends your reply only to the sender of the message
to whom you are replying.
Reply to All sends your reply to the sender of the message as well as any
address in To: or Cc: lines.
Forward allows you to send the message, with any additional comments
you may add, to some other contacts.
To use any of these methods, click on the message to which you want
to reply and then click the Reply, Reply to All, or Forward button on the
message toolbar. Thunderbird will open the reply window. This window
should look much like the window for composing new messages, but the
To:, Cc:, Subject:, and main message content fields should be filled in from
the message to which you are replying. Edit the To:, Cc:, Bcc:, Subject: or
main body as you see fit. When your reply is finished, click on the Send
button on the toolbar. Your message will be placed in the Outbox and will
be sent.
Using instant messaging

To communicate with people online in real time, you will first need to
install an instant messaging application such as Empathy, which lets you
connect to many instant messaging networks (such as Google Talk, Salut,
Jabber, Yahoo!, and aim). To install Empathy, open the Dash, search for
Terminal and hit Enter or click on the icon labeled “Terminal”. Once inside
the terminal, type sudo apt install empathy and hit Enter.
Running Empathy for the first time

To run Empathy for the first time, you need to start it from the Dash (see
The Dash) by searching for Empathy and hitting Enter. Altenately, you can

Figure 3.13: This is the icon that Empathy
displays in the launcher.
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click on its icon, shown in 3.13. After Empathy launches, you should see a
window similar to that in figure 3.14. At this time, Empathy does not know
about any of your instant messaging accounts.
Figure 3.14: You should see a window like this
the first time you open Empathy.

Adding accounts

You must have existing chat accounts that are compatible with Empathy. If you
do not have an existing account, you will need to create one before continuing.

On the first run, the Online Accounts manager will appear, allowing you
to add accounts to be used with Empathy. You can return to this dialog at
any time by navigating to Empathy ‣ Accounts. You should see a dialog
similar to that in figure 3.15.

Be aware that when you Add or Remove
accounts using the Online Accounts manager
you will be adding or removing those accounts
to or from all the applications that they
integrate with, not just Empathy.

Figure 3.15: Add your existing chat accounts
for use in Empathy using the Online Accounts
manager.

Click Add account… on the left-hand side of the window if it is not
already selected. At the top of the window, where it says Show accounts that
integrate with:, select Empathy from the drop-down menu. Now click on
the name of the chat service with which you have an account. Shown in
figure 3.16, we have selected a Google account. You must now enter your
login credentials and authorize Ubuntu to access your account.
When you have authorized Ubuntu to access your account, you are
shown all the applications that integrate with the account, including Empathy. All the applications have an ON/OFF button to control their integration with the account. Make sure the ON/OFF button is set to ON for
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Figure 3.16: You must enter your account
credentials and authorize Ubuntu to use your
account.

Empathy. There is also an Options button for you to edit details used by
Empathy. The details shown are specific to each application. After adding
your accounts, you can now use Empathy to chat with all of your friends,
right from your Ubuntu desktop!
Communicating with contacts
Text

To communicate with a contact, select the contact in Empathy’s main window and double-click their name. Empathy should open a new window
where you can type messages to your contact and see a record of previously
exchanged messages.
Figure 3.17: Chatting with friends in Empathy.

To send a message to the contact, enter your message in the text field
below the conversation history. When you have typed your message press
the Enter key to send the message to your contact. When the person you
are chatting with is typing to you, a small keyboard icon will appear next to
their name in the chat window.
If you are communicating with more than one person, then all of the
conversations will be shown either in tabs in your Empathy window or in
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separate windows, depending on the option you have chosen in the menu
item Empathy ‣ Preferences.
Audio and Video Calling

You also can use Empathy to chat with your friends using audio and video.
To start an audio or video call, right click on the contact name, then select
Audio Call or Video Call, as shown in figure 3.18. This will notify the
person you are trying to call, and they will be asked if they would like to
answer the call.
If the person you are calling accepts your call request, you will be connected, and you can begin talking. If the person you are calling cannot see
or hear you, your webcam or microphone may not be properly configured;
see the sections on Sound and Using a webcam, respectively. You can end
the call by clicking on the red telephone button in the chat window.

Figure 3.18: Right-clicking a contact exposes
many ways to communicate.

Sending and receiving files
Sending a file

When you are in a conversation with a contact and you would like to send
them a file, right-click the contact in the contact list—as in figure 3.18—
and select Send File. Empathy should open the “Select file” window. Find
the file you wish to send, and click on the Send button. A “File Transfers”
window will open showing the file and its transfer progress. When the file
transfer is complete, you can close the “File Transfers” window.
Changing your status

You can use your status to show your contacts how busy you are or what
you are doing. Your contacts see your status next to your name when they
chat with you. You can use the standard statuses, which are:
‣
‣
‣
‣
‣

Available
Busy
Away
Invisible
Offline

Two of these statuses have additional functionality. The Invisible status
lets you see which of your contacts are online, but does not allow them to
see that you are online. The Offline status logs you out entirely; you will
not be able to see which of your contacts are online, nor can they see you or
chat with you.
You can change your status from the drop-down list at the top of the
main Empathy window, as shown in figure 3.19. This same drop-down list
lets you set a custom status by choosing “Custom Message…” next to the
icon that matches your status. Enter what you would like your status to say,
and click on the green check mark.
Desktop Sharing

Desktop sharing is a very nice feature available with Ubuntu. It can be used
for a lot of purposes, like troubleshooting, online meetings, or just showing
off your cool desktop to your friend. It is very easy to get remote desktop
sharing working between two Ubuntu machines.

Figure 3.19: Change your Empathy status
from the drop-down list at the top of the main
window.
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To share your screen, you will first have to set up Desktop Sharing. Open
the Desktop Sharing application from the Dash (see The Dash). Next, select
Allow other users to view your desktop; you may want to deselect Allow
other users to control your desktop.
After you have Desktop Sharing configured, open Empathy. To begin
sharing your desktop, right-click on the contact you wish to share your
desktop with, and select Share my desktop.
It should be noted that the other user will obviously be able to see the
information displayed on your screen. Please be sure to keep this in mind
if you have documents or files that are of a private nature open on your
desktop.
Changing account settings

If you need to add more accounts after the initial launch of Empathy, open
the Empathy menu on the menu bar, then select Accounts. Empathy will
then display the Online Accounts manager window.
Editing an account

You might need to edit the details of an account. Select the account you
want to change on the left side of the Online Accounts window then click
the Options button for Empathy. The Online Accounts manager should
show the current information for the account. Once you have made your
changes, click Done.
Removing an account from Empathy

To stop an account from showing in Empathy, select the account on the
left hand side of the Online Accounts manager window. Then click on the
ON/OFF button for Empathy and set it to OFF.
Editing contacts
Adding a contact

To add a contact open Empathy ‣ Contacts ‣ Add contacts.. from the menu
bar. Empathy opens the “New Contact” window.
In the Account drop-down list, choose the account you want to add
contacts for. When creating a contact you must select the service that
matches the service your contact is using.
After choosing the account you wish to add the contact to, enter their
login id, their username, their screen name, or their email address in the
Identifier text field. Next, in the Alias text field, enter the name you want to
see in your contact list. Click Add to add the contact to your list of contacts.
Removing a contact

Right click on the contact that you want to remove, then select Remove.
This will open the “Removing contact” window. Click on the Delete button
to confirm that you want to remove this contact, or click Cancel to keep the
contact.
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Microblogging

There is no longer a default microblogging client included within the core
of Ubuntu/Unity, and so you will need to first install an appropriate application for whatever service you intend to use.
Corebird is a modern GTK+ based Twitter client that, while not installed
by default, is available in the default repositories.
Install Corebird with sudo apt install corebird in a terminal. When
you first start Corebird, it will give you a chance to request a token from
Twitter in your web browser. This token will log you in to your Twitter
account in Corebird.
Figure 3.20: Corebird is a modern GTK+ client
for Twitter

Choqok, from an ancient Persian word for Sparrow, is a well-maintained
and fully-featured client for Twitter.com, Pump.io (Formerly known as
Identi.ca), and OpenDesktop.org services. It uses the Qt toolkit, is a part
of the KDE Project, and also has ties to the Ubuntu community project
Kubuntu.
Figure 3.21: Choqok is a powerful microblogging client for Twitter.com, Pump.io, and
OpenDesktop.org services.

Install Choqok with sudo apt install choqok in a terminal. The startup
wizard will authorize the client to utilize your Twitter account via a gen-
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erated token you will retrieve in your web browser, which by default in
Ubuntu is Mozilla Firefox.
Viewing and editing photos

Shotwell Photo Manager is the default photo application in Ubuntu. This
application allows you to view, tag, edit, and share photos. To start Shotwell
Photo Manager, click on the Dash near the top-left of the screen, then select
the Shotwell Photo Manager icon labeled View Photos. If you do not see
Shotwell Photo Manager, simply type Shotwell in the search bar at the top
of the Dash and then select the Shotwell Photo Manager application.
Figure 3.22: Manage your photo collection,
enhance your photos while keeping the original,
and share your memories online using Shotwell
Photo Manager.

Importing Photos

When you launch Shotwell Photo Manager for the first time, you will be
greeted with the “Welcome!” window which provides instructions on how
to import photos. Click OK. You can now import photos by dragging photos
into the Shotwell Photo Manager window or by connecting your camera or
external storage device to the computer.
From a digital camera Connect your camera to the computer using the
data cable, and power on your camera. If your camera is properly detected,
you will see a new window prompting you to launch an application. Select
Shotwell Photo Manager in the drop-down menu, then click OK. Your
camera will be listed in the Shotwell Photo Manager sidebar. Select your
camera in the sidebar. You will see a preview of the contents stored in the
camera’s memory. Select individual photos by pressing and holding Ctrl
and clicking on each photo you want to import, and then click Import
Selected on the bottom bar of the window. Or, you can choose to import all
photos by clicking Import All.
From your computer You can import photos into Shotwell Photo Manager
by dragging photos from the file browser into the Shotwell Photo Manager
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window. Alternatively, you can click File ‣ Import From Folder, then select
the folder containing the photos you want to import.
From external hard drive, usb flash drive, or cd/dvd Importing photos
from external storage is similar to importing from your computer. Your
external storage device may also appear under the Camera label on the
Shotwell Photo Manager sidebar. Follow the instructions for importing from
a camera or computer.
Choosing where Shotwell Photo Manager saves photos

The default location for the Shotwell Photo Manager Library is your Pictures folder in your home directory. When importing pictures using the
“Import” window, you will be given the option to copy the files to your
Library or keep the files in place.
If you have your photos stored on your computer, the option Import in
Place will be suitable. This will prevent photos from being duplicated. If
you are importing photos from an external source, such as a portable hard
drive, usb flash drive, or cd/dvd, you should select Copy into Library so
the photos are copied to your computer—otherwise the photos won’t appear
when you remove the external source.
Viewing photos

Choose Library or any collection in the sidebar to display photos from
your selection. Use the slider on the bottom bar to adjust the size of the
thumbnails. To view a full-window image, double-click an individual photo.
In the full-window view, you can navigate through the collection using
the backward and forward arrows, zoom in on the image using the slider,
pan by clicking and dragging the image, and exit the full-window view by
double-clicking the image.
To view the collection in full-screen mode, press F11 or go to View ‣
Fullscreen. You can navigate through the collection using the toolbar by
moving your mouse to the bottom of the screen. To view a slideshow presentation of the collection, press F5 or go to View ‣ Slideshow. Press the Esc
key to exit the Fullscreen or Slideshow views.
Organizing photos

Shotwell Photo Manager makes finding photos of the same type easier by
using tags. You can apply as many tags to a photo as you like. To apply tags
to photos, first select the photos. Then right-click on the photos and select
Add Tags. Enter the tags you want into the text field, separated by commas.
If you are adding new tags, these will appear in the side bar on the right
under the Tags label.
Editing images

You may want to edit some of the photos you import into Shotwell Photo
Manager. For example, you may want to remove something at the edge,
adjust the color, reduce the red-eye effect, or straighten the image. To edit a
photo, double-click on the photo you want to edit, and then click on one of
the following buttons:
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Rotate

Click Rotate to rotate the image 90° clockwise. You can click the button
more than once and it will rotate the image clockwise in 90° intervals.
Crop

Click Crop to change the framing of the photo. The image will darken and a
selection will appear. Adjust the selection to your desired crop by dragging
a corner or side. If you want to choose a specific aspect ratio, use the dropdown menu to select one of the preset ratios or enter your own custom
ratio. A pivot button is provided to change your selection from landscape to
portrait and vice versa. Once you are happy with the selection, click OK to
apply the crop or Cancel to discard it.
Red-eye reduction

If you have taken a photo and the flash has caused the subject to have
red eyes, you can fix this problem in Shotwell Photo Manager using the
following process.
1. Click the Red-eye button. A circle will appear.
2. Drag this circle over one of the subjects eyes and then use the slider to
adjust the circle size.
3. When the circle is over the eye, click Apply to fix the red eye.
You will need to repeat this for each individual eye. Use caution when
adjusting the size of the circle. A circle too large that covers the skin may
cause discoloration when applying the red-eye reduction.
Adjust

Clicking Adjust will bring up a window that lets you edit a few things:
Level Similar to contrast.
Exposure How bright the image is.
Saturation How colorful the image is.
Tint The overall color.
Temperature Whether the image is warm (more yellow) or cool (more blue).
Shadows How dark the shadows are.
To change these values, drag the sliders until you are satisfied with the
image. Click OK to apply the changes, Reset to undo the changes and start
over, or Cancel to discard the changes.
Auto-adjustment with Enhance

Click Enhance to let Shotwell Photo Manager automatically adjust the
color, levels, exposure, contrast, and temperature to create a more pleasing
image.
Reverting an edited photo to the original

When you edit a photo in Shotwell Photo Manager, your original image remains untouched. You can undo all of the changes and revert to the original
version by right-clicking on the photo, then selecting Revert to Original.
This option is only available for edited photos.
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Sharing your photos

You can easily share your photos on the web using Shotwell Photo Managers’s Publish feature. Select the photos you want to share, then go to the
top menu and click File ‣ Publish. A new window will appear asking where
the photos are to be published. Choose Facebook, Flickr, or Picasa Web Albums in the upper right-hand drop-down menu. Some services may require
you to authorize Shotwell Photo Manager before allowing the application to
publish photos. Follow the instructions in the window, select your desired
options, and click Publish to upload your images to the web.
Further information

We’ve only just touched on the features of Shotwell Photo Manager. To
get more help, select Help ‣ Contents. This will load the online manual,
where you can get more detailed instructions on how to use Shotwell Photo
Manager effectively.
Watching videos and movies

To watch videos and dvds in Ubuntu, you can use the Videos application.
To start Videos, click on the Dash, then search for “Videos” and select it.
This will open the “Videos” window.
Figure 3.23: The “Videos” (commonly called
“Totem”) application plays videos as well as
music.

Codecs

Watching most commercial dvds and some video files may require you
to install additional software. You will need “codecs” for Ubuntu to decode proprietary music and video files as well as for music and video files
encumbered by drm. You will need “unscrambling software” to access commercial dvds encrypted by drm.
Legal Notice: Patent and copyright laws differ depending on which country you
are in. Please obtain legal advice if you are unsure whether a particular patent or
restriction applies to a media format you wish to use in your country.

To install these additional codecs, open the Terminal either through
the Dash or the Launcher. When the “Terminal” window opens, use apt to
install the following packages via sudo apt install:
‣ ubuntu-restricted-extras

DRM, or Digital Restrictions Management, is the
practice of imposing technological restrictions
that control what users can do with digital
media. When a program is designed to prevent
you from copying or sharing a song, reading an
ebook on another device, or playing a singleplayer game without an Internet connection,
you are being restricted by DRM.
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‣ libdvdread4
‣ libdvdnav4
Double-click each item above and then click the Install button. This
may open an “Authenticate” window. If so, enter your administrative password, then click Authenticate to start the installation process. The ubunturestricted-extras meta-package includes most if not all restricted codecs as
well as the Adobe Flash Player npapi plugin and Microsoft corefonts.
Playing videos from file

Open the Movie menu in the Videos application, then select Open Local
Video… or Open Web Video… which will open the “Add Videos” or “Add
Web Video” window, respectively. Find the file or files that you want to play
and click on the Add button. The video or videos will now be available for
viewing in the Videos tab, along with any other videos already located in an
indexed folder such as your Videos folder in your user home directory.
Playing a DVD

When you insert a dvd in the computer, Ubuntu should open the “You have
just inserted a Video dvd. Choose what application to launch.” window.
Make sure that Videos is chosen in the drop-down list and then click OK.
The “Movie Player” window will open and the movie will begin. You can
also choose to always perform the action you just specified when another
Video dvd is inserted.
If the “Videos” window is already open, then open the Videos tab, and
select the dvd title that should now appear in the list as a tile.
Listening to audio and music

Ubuntu comes with the Rhythmbox Music Player for listening to your music, streaming Internet radio and managing playlists and podcasts. Rhythmbox (Figure 3.24) can also help you find and purchase music, along with
managing subscriptions to your favorite rss feeds.
Starting Rhythmbox

There are several ways to start Rhythmbox.
‣ Open the Dash, type Rhythmbox or Music and click on the Rhythmbox
Music Player icon.
‣ Ubuntu comes with an indicator menu in the top bar for sound-related
applications and devices ( ). After you’ve opened Rhythmbox the first
time, a link to start Rhythmbox and basic controls will be placed under
this indicator.
If you close Rhythmbox by pressing Alt+F4, or CTRL+W, or clicking the
red close button ( ), it will disappear from view but continue to play in the
background. You can still control music playback or reopen the application
from the sound indicator ( ), as shown in Figure 3.25.
Playing music

To play music, you can either double-click on your music file or, alternatively, import your music into your library. To do the latter, choose File ‣
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Figure 3.24: Rhythmbox Music Player

Figure 3.25: Rhythmbox controls as displayed
under the sound indicator. The application is currently playing Hexenritt, from
Humperdinck’s opera Hänsel Und Gretel.

Add Music… or press Ctrl+O on your keyboard to import a folder containing audio files. You can use the dropdown box to select the folder where
your music resides or click the Other… option to find an alternate folder.
The Rhythmbox toolbar contains most of the controls that you will use
for browsing and playing your music. If you want to play a song, doubleclick a track; or click it and press the Play button on the toolbar, choose
Control ‣ Play from the menu bar, or press Ctrl+Space. When a song is
playing, the Play button will become a Pause button. Use this button, Control ‣ Play, or Ctrl+Space to toggle between playing and pausing the track.
Next and Previous buttons are next to the Play/Pause button. Click on
these buttons to play the next and previous songs in your library or playlist.
Rhythmbox also has options to toggle repeat mode (Repeat, Control ‣
Repeat or Ctrl+R) and shuffle mode (Shuffle, Control ‣ Shuffle or Ctrl+U).
Playing Audio CDs

When you insert an audio cd in the computer, Ubuntu should open the
“You have just inserted an Audio cd. Choose what application to launch.”
window. Make sure that Rhythmbox is chosen in the drop-down list and
then click OK. The “Rhythmbox” window will open. You can also choose
to always perform the action you just specified when another Video dvd is
inserted.
To play your cd once in Rhythmbox you can use the audio controls in
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the Rhythmbox toolbar. Adding the music to your library, or ”Ripping” the
audio, is covered below and available in this same window.
Importing (“Ripping”) Audio CDs

Begin by inserting a cd. Rhythmbox will automatically detect it and add it
to the side menu. If you have an active Internet connection, Rhythmbox will
try to find the album details via the web. Click the cd. Uncheck any tracks
you don’t want imported. Press the Extract button, located at the upper-left
corner of the right panel. Rhythmbox will begin importing the cd. As it
finishes each track, it will appear in your Music Library.
Listening to streaming audio

Rhythmbox is pre-configured to enable you to stream audio from various
sources. These include Internet broadcast stations (Radio from the Side
Pane), Last.fm and Libre.fm. To listen to an Internet radio station, click on
the Radio icon in the Side Pane for a list of pre-configured stations. You can
filter by genre in the middle pane. To add a new radio station, select Add
and enter the radio station url.
Connect digital audio players

Streaming audio stations are “radio stations”
that broadcast over the Internet. Some of these
are real radio stations that also stream over the
Internet, and others broadcast only over the
Internet.

You can browse a selected list of radio stations
at http://en.wikipedia.org/wiki/List_of_
Internet_stations or you can use your browser
to search for “Internet radio stations.”

Rhythmbox can connect with many popular digital media players. Connected players will appear in the Devices list. Features will vary depending
on the player (and often the player’s popularity), but common tasks like
transferring songs and playlists should be supported. If your device isn’t
shown on the Devices list, try searching for it by clicking on the + button ‣
Check for New Devices in the bottom-left corner.
Figure 3.26: Rhythmbox connected to an
Android device

Listen to shared music

If you are on the same network as other Rhythmbox users (or most other
music player software), you can share your music and listen to their shared

DAAP stands for “Digital Audio Access Protocol,” and is a method designed by Apple to let
software share media across a network.
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music. To do this, click File ‣ Connect to DAAP Share… Then enter the
ip address and the port number. Click OK. Clicking a shared library will
enable you to browse and play songs from other computers.
Manage podcasts

Rhythmbox can manage all of your favorite podcasts. Select Podcasts from
the Side Pane to view all added podcasts. The toolbar will display additional
options to Browse, View All, Add and Update. Choose Add on the toolbar
and enter the url of the podcasts to save it to Rhythmbox. You can also
search for podcasts to find here to add to Rhythmbox. Podcasts will be
automatically downloaded at regular intervals or you can manually update
feeds. Select an episode and click Play. You can also delete episodes.
Rhythmbox preferences

The default configuration of Rhythmbox may not be exactly what you want.
Choose Edit ‣ Preferences to alter the application settings. The Preferences
tool is broken into four main areas: general, playback, music, and Podcasts.
General includes how you want Rhythmbox to display artist and track
information. You can adjust the columns visible in your library and how
the toolbar icons are displayed.
Playback options allow you to enable crossfading and the duration of the
fade between tracks.
Music includes where you would like to place your music files and the
library structure for new tracks added to Rhythmbox. You can also set
your preferred audio format.
Podcasts designates where podcasts are stored on your computer along
with the ability to change how often podcast information is updated.
Plugins

Rhythmbox supports a wide array of plugins, which add functionality
to Rhythmbox. Many of the plugins provide basic audio playback, and
you may check a few more boxes, for example, to access Soundcloud or to
provide a consistent playback volume (ReplayGain). To view or change the
activated plugins, use the global menu bar (Tools ‣ Plugins).
Managing your music

Rhythmbox supports creating playlists. Playlists can be either static lists
of songs to be played in order or smart playlists based on filter criteria.
Playlists do not contain the actual songs, but only provide references to
them. Thus, if you remove a song from a playlist (right-click on the song ‣
Remove from Playlist), the song will remain in your library and on your
hard drive.
To create a playlist, choose File ‣ Playlist ‣ New Playlist… or + button ‣
New Playlist in the bottom-left corner, or press Ctrl+N. It appears in the
sidebar as “New Playlist.” Select the new playlist in the sidebar on the left
and then press F2 to give the new playlist a name of your choosing. Drag
songs from your library to the new playlist in the side pane or right-click on
songs and select Add to Playlist and pick the playlist.
Automatic Playlists are created in a similar way. Choose File ‣ Playlist ‣
New Automatic Playlist… or + button ‣ New Automatic Playlist in the
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bottom-left corner. Define the filter criteria. You can add multiple filter
rules and select a name. Save. You can update any playlist (including the
predefined ones) by first selecting it on the sidebar and then selecting the
Playlist button and selecting Edit….
Rhythmbox supports song ratings. Right-click a song in your library ‣
Properties ‣ Details and click on the number of stars. To remove a rating,
select zero stars. Other song information such as Title, Artist and Album
can be changed. Right-click a song in your library ‣ Properties ‣ Basic.
To remove a song, right-click ‣ Remove. To delete a song from your hard
drive entirely, right-click ‣ Move to the Rubbish Bin. If you ever want to
move a song, highlight the song (or group of songs) from your library and
drag it to a folder or to your desktop. This will make a copy of the audio file
in the new location.
Audio codecs

Different audio files (mp3, wav, aac, ogg, etc.) require unique tools to decode them and play the contents. These tools are called codecs. Rhythmbox
attempts to detect any missing codecs on your system so you can play all of
your audio files. If a codec is missing, it automatically tries to find the codec
online and guides you through its installation.
Rhythmbox support

Rhythmbox is used by many users throughout the world. There are a variety of support resources available in many languages.
‣
‣
‣
‣

Help ‣ Contents or F1 for the main help.
Help ‣ Get Help Online to ask questions and report bugs.
The Rhythmbox website at http://www.rhythmbox.org/.
The Multimedia & Video category of Ubuntu Forums at http://ubuntuforums.
org/forumdisplay.php?f=334.

Burning CDs and DVDs

To create a cd or dvd, you will need to first install a burning application
such as Brasero (The GNOME default) or K3b (A powerful utility built
with the Qt toolkit). For the purposes of the Manual we will install and
use Brasero. To do this, click the Ubuntu Software icon on the launcher,
located to the left by default but it may also be on the bottom of the screen.
Once Ubuntu Software opens search for Brasero using the top search bar
in the “Ubuntu Software” window. Press ”Install” and enter your password.
Ubuntu Software will now create an icon for Brasero on your launcher.
Click on this icon. This opens the Brasero Disc Burner application. The
burning options (Figure 3.27) appearing within Brasero are explained below.
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If you only need to burn a disc image such as an ISO file, you can do this from
the Files application’s context menu when you right-click on a disk image file.
After right-clicking the ISO file in Files, select ”Open With ‣ Disk Image Writer”.
At this point, do not select one of your hard disks in the window that appears
unless you are certain you intend to wipe that device! Select a destination (such
as your optical drive with blank media inserted) and click ”Start Restoring…”.
This uses the GNOME Disks component/utility, which is included within the base
Ubuntu/Unity system. A burning application such as Brasero or K3b is only necessary if you plan on creating your own disc images, or ”projects”, or if you prefer
greater control over the burning process.

Figure 3.27: Brasero burns music, video, data
DVDs and CDs.

Getting Started

Before you can use Brasero, you need to Create a new project. There are
three types of media projects available: Audio Project, Data Project, and
Video Project. There are also two utility projects available: Disc Copy and
Burn Image. Make your selection based on your requirements.
The following options apply for all projects except Disc Copy and Burn Image.

Adding files to a project

To add files to the list, click the + button. This button will open the “Select
Files” window. Navigate to the file you want to add, click the desired file,
then click the Add button. Repeat this process for each file until all desired
files have been added.
Removing files

If you want to remove a file from the project, click the file in the list and
click on the - button. To remove all the files in the list click on the Broom
shaped button.

At this current time, Brasero does not support
Blu-Ray.
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Saving a project

To save an unfinished project, choose Project ‣ Save. The “Save Current
Project” window will be opened. Choose where you would like to save the
project. In the Name: text field, enter a name for the project. Click the Save
button, and your unfinished project will be saved. When saving a project,
you are only saving the parameters of the project; you’ve burned nothing to
the disc at this time.
Burning the disc

When you click the Burn… button, you will see the “Properties of …” window.
You can specify the burning speed in the Burning speed drop-down. It is
safest to choose the slowest speed to prevent a corrupted CD / DVD disc.
To burn your project directly to the disc, select the Burn the image
directly without saving it to disc option. With this option selected, no
image file is created, and no files are saved to the hard disk. All data is
saved to the blank cd or dvd. Note that Brasero only burns information
onto standard CDs and DVDs; Brasero does not burn data onto Blu-Ray
DVDs at this time.
The Simulate before burning option is useful if you encounter problems
burning discs. Selecting this option allows you to simulate the disc burning
process without actually writing data to a disc—a wasteful process if your
computer isn’t writing data correctly. If the simulation is successful, Brasero
will burn the disc after a ten second pause. During those ten seconds, you
have the option to cancel the burning process.
Blanking a disk

Some CDs and DVDs have an rw marking on them. rw simply indicates
the disc is Re-Writable, meaning the current data on the disc can be completely erased and new data can be written to it. To erase a disc, open the
Tools menu, then select Blank. The “Disc Blanking” window will be open.
In the Select a disc drop-down choose the disc that you would like to erase.
You can enable the Fast blank option if you would like to shorten the
amount of time to perform the blanking process. However, selecting this
option will not fully remove the files; if you have any sensitive data on your
disc, it would be best not to enable the Fast blank option.
Once the disc is erased (blank), you will see The disc was successfully
blanked. Click the Close button to finish.
Audio project

If you record your own music, then you may want to transfer this music
onto an audio cd so your friends and family can listen. You can start an
audio project by clicking Project ‣ New Project ‣ New Audio Project.
When burning a music cd, it is important to remember that commercial
music cds usually contains a two-second gap between the songs. To ensure
your music has this same gap between songs, click the file and then click
the pause button.
You can slice files into parts by clicking the Knife button. This opens a
“Split Track” window. The Method drop-down gives you four options; each
option lets you split the track in a different way. Once you have split the
track, click OK.
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In the drop-down list at the bottom of the main “Brasero” window, make
sure that you have selected the disc where you want to burn the files. Then
click the Burn button.
Data project

If you want to, for instance, make a back up of your documents or photos,
it would be best to make a data project. You can start a data project by
clicking Project ‣ New Project ‣ New Data Project.
If you want to add a folder, click the Folder picture, then enter the name
of the folder.
In the drop-down list at the bottom of the main “Brasero” window, be
sure to select the disc where you want to burn the files. Then click the Burn
button.
Video project

If you want to, for instance, make a dvd of your family videos, it would be
best to make a video project.
You can start a video project by clicking Project ‣ New Project ‣ New
Video Project.
In the drop-down list at the bottom of the main “Brasero” window, be
sure to select the disc where you want to burn the files. Then click the Burn
button.
Disc copy

You can make a copy of an existing disc by clicking Project ‣ New Project ‣
Disc copy. This opens the “Copy cd/dvd” window.
If you have only one drive, you will need to first make a disc image and
then burn it to a blank disc. If you have two cd/dvd drives, you can copy a
disc from one to the other directly, assuming that the source disc is in one
drive and the destination disc (the blank media) is in the other drive.
In the Select disc to copy drop-down choose the disc to copy. In the
Select a disc to write to drop-down either choose image file or the disc that
you want to copy to.
Disc image

You can make an image file of your data as well. An “image,” in this context,
is a single-file representation of the contents of the disk. The file usually has
an .iso or .img extension. An image file is similar to a set of zipped files.
Change where the image file is saved by clicking Burn…. This shows the
“Location for Image File”. You can edit the name of the file in the Name:
text field.
The default location to save the image file is your home folder, but you
can change the location by clicking the + button next to Browse for other
folders. Once you have chosen where you want to save the photo or image,
click Close.
Returning to the “Copy cd/dvd” window, click Create Image. Brasero
will open the “Creating Image” window and will display the job progress.
When the process is complete, click Close.
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Burn image

“Burning” an image to a disc should not be confused with copying an image file
to a disc. When burnt, the contents of the image file are copied over to the disc,
rather than the image file itself.

To burn an image, that is, to transfer the contents inside an image file
to a blank disc, open the Project ‣ New Project ‣ Burn Image. Brasero will
open the “Image Burning Setup” window. Click on the Click here to select
a disc image drop-down and the “Select Disc Image” window will appear.
Navigate your way to the image you wish to burn, click on it, and then click
Open.
In the Select a disc to write to drop-down menu, click on the disc to
which you’d like to write, then click Create Image.
Working with documents, spreadsheets, and presentations

LibreOffice Suite is the default office suite when working with documents,
spreadsheets, and slide presentations.
Working with documents

If you need to work with documents, you can use the LibreOffice Word Processor. Writer has all the features you need from a modern, full-featured
word processing and desktop publishing tool including a built-in PDF creator. It also has the ability to save documents in several common formats,
such as “.doc” or “.txt” files. It’s simple enough for a quick memo, and yet
powerful enough to create complete books with contents, diagrams, indexes, and more. You’re free to concentrate on your message, while Writer
will make it look great. To start the word processor, open the Dash and
search for LibreOffice Writer. Then select LibreOffice Writer.
Working with spreadsheets

If you need to work with spreadsheets, you can use LibreOffice Spreadsheet
(Calc). Calc is the spreadsheet program you’ve always needed. Newcomers
find it intuitive and easy to learn. Professional data miners and number
crunchers will appreciate the comprehensive range of advanced functions. To start the spreadsheet application, open the Dash and search for
LibreOffice Calc. Then select LibreOffice Calc.
Working with presentations

If you need to work with slides for a presentation, you can use LibreOffice
Impress. Impress is a truly outstanding tool for creating effective multimedia presentations. Your presentations can be enhanced with 2D and 3D
clip art, special effects and transition styles, animations, and high-impact
drawings. To start the presentation application, open the Dash and search
for LibreOffice Impress. Then select LibreOffice Impress.
Getting more help

Each of these applications come with a comprehensive set of help screens.
If you are looking for more assistance with these applications, press the F1
key after starting the application.

The LibreOffice Word Processor is known as
LibreOffice Writer. LibreOffice Spreadsheet is
known as Calc, and LibreOffice Presentation is
known as Impress.

4 Hardware
Using your devices

Ubuntu supports a wide range of hardware, and support for new hardware
improves with every release.
Hardware identification

There are various ways to identify your hardware in Ubuntu. The easiest
would be to install an application from the Ubuntu Software application,
called Sysinfo.
Firstly, open the “Ubuntu Software” application, then use the search box
at the top of the window to search for sysinfo. Select the Application, click
Install. Enter your password when prompted, to install the application.
To run the application, search for Sysinfo at the Dash search bar. Click
on the program once you find it. The Sysinfo program will open a window
that displays information about the hardware in your system.
Displays
Hardware drivers

A driver is a piece of software which tells your computer how to communicate with a piece of hardware. Every component in a computer requires a
driver to function, whether it’s the printer, dvd player, hard disk, or graphics card.
The majority of graphics cards are manufactured by three well-known
companies: Intel, amd/ati, and nvidia Corp. You can find your video card
manufacturer by referring to your computer’s manual, by looking for the
specifications of your computer’s model on the Internet, by opening an
application such as Sysinfo, or by using the command lspci in a terminal.
The Ubuntu Software application houses a number of applications that can
tell you detailed system information. SysInfo, see the previous section,
is one such program that you can use to find relevant information about
your System devices. Ubuntu comes with support for graphics devices
manufactured by the above companies, and many others, out of the box.
That means you don’t have to find and install any drivers yourself, Ubuntu
takes care of it all.
Keeping in line with Ubuntu’s philosophy, the drivers that are used by
default for powering graphics devices are open source. This means that the
drivers can be modified by the Ubuntu developers and problems with them
can be fixed. However, in some cases a proprietary driver (restricted driver)
provided by the company may provide better performance or features that
are not present in the open source driver. In other cases, your particular
device may not be supported by any open source drivers yet. In those
scenarios, you may want to install the restricted driver provided by the
manufacturer.
For both philosophical and practical reasons, Ubuntu does not install
restricted drivers by default but allows the user to make an informed choice.
Remember that restricted drivers, unlike the open source drivers for your

Your graphics card is the component in your
computer which outputs to the display.
Whether you are watching videos on YouTube,
viewing DVDs, or simply enjoying the smooth
transition effects when you maximize/minimize
your windows, your graphics device is doing the
hard work behind the scenes.
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device, are not maintained by Ubuntu. Problems caused by those drivers
will be resolved only when the manufacturer wishes to address them. To
see if restricted drivers are available for your system, go to System Settings,
then open Software and Updates and go to the Additional Drivers tab. If
a driver is provided by the company for your particular device, it will be
listed there. You can choose the proprietary driver for your graphics card,
then click on the Apply Changes button to enable the driver. This process
requires an active Internet connection and it will ask for your password.
Once installation is complete you may have to reboot your computer to
finish activating the driver.
The Ubuntu developers prefer open source drivers because they allow
any problem to be identified and fixed by anyone with knowledge within
the community. Ubuntu development is extremely fast and it is likely that
your device will be supported by open source drivers. You can use the
Ubuntu Live dvd to check your device’s compatibility with Ubuntu before
installing, or go online to the Ubuntu forums or to http://www.askubuntu.
com to ask about your particular device.

Another useful resource is the official online
documentation (http://help.ubuntu.com), which
contains detailed information about various
graphics drivers and known problems. This
same documentation can be found by searching
for Help in the Dash search bar or by pressing
F1 on your keyboard.

Setting up your screen resolution

One of the most common display related tasks is setting the correct screen
resolution for your desktop monitor or laptop.
Ubuntu correctly identifies your native screen resolution by itself and
sets it for you. However, due to a wide variety of devices available, sometimes it can’t properly identify your resolution.
To set or check your screen resolution, go to System Settings ‣ Displays.
The “Displays” window automatically detects the type of display and shows
your display’s name and size. The screen resolution and refresh rate is set
to the recommended value by Ubuntu. If the recommended settings are
not to your liking, you can change them here. For example, to change the
resolution click on the triangle in the Resolution drop-down and choose
the resolution you want. Ubuntu 16.04 now includes HiDPI settings in the
System Settings Display module. You can now scale menu and title bars
according to your viewing needs.
Adding an extra display

Sometimes, you may want to add more than one display device to your
desktop, or you may want to add an external monitor to your laptop. Doing
this is quite simple. Whether it’s an extra monitor, lcd tv, or a projector,
Ubuntu can handle it all. Ubuntu supports the addition of multiple displays
by default, which is as easy as plug and play.
Ubuntu recognizes almost all the latest monitors, tvs and projectors
by default. Sometimes it may happen that your additional display is not
detected when you connect it to the machine. To resolve this, go to System Settings ‣ Displays and click on Detect Displays. This will detect the
monitors connected to the machine. This menu can also be found from the
Power Off menu on the top panel. You can also search for Displays at the
Dash search bar.
Now, there are two modes which you can enable for your displays. One
option is to spread your desktop across two or more monitors. This is particularly useful if you are working on multiple projects and need to keep
an eye on each of them at the same time. You can configure the screen to
be on any side of your primary screen i.e. to your right, your left or on the

Displays are made up of thousands of tiny
pixels. Each pixel displays a different color,
and when combined they all display the image
that you see. The native screen resolution is a
measure of the amount of actual pixels on your
display.
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top (particularly nice if you are working on a large screen i.e. a big monitor
or a TV connected to your 12-13 inch laptop); just move the screen on the
Displays settings to the side of your choice.
The second option is to mirror the desktop onto each of the displays.
This is useful when you are using a laptop to display something on a larger
screen e.g. projector. To enable this option just check the box beside Mirror displays and click Apply to save the settings. You will get a pop-up
notification asking if you want to keep the current setting or revert to the
previous setting. Click to keep the current setting. Starting from Ubuntu
12.04, you can also select whether you want the Unity Launcher in both the
displays or only in the primary display. Ubuntu 16.04 LTS inherited better
multi-monitor support for higher resolutions introduced in Ubuntu 13.04.
Connecting and using your printer

Ubuntu supports most new printers. You can add, remove, and change
printer properties by navigating to System Settings ‣ Printers. You can also
search for Printers from the Dash search bar. Opening Printers will display
the “Printers-localhost” window.
When you want to add a printer, you will need to make sure that it is
switched on, and plugged into your computer with a usb cable or connected
to your network.
Adding a local printer

If you have a printer that is connected to your computer with a usb cable
then this is termed a local printer. You can add a printer by clicking on the
Add Printer button.
In the left hand pane of the “New Printer” window any printers that you
can install will be listed. Select the printer that you would like to install and
click Forward.
You can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally, click Apply.
Adding a network printer

Make sure that your printer is connected to your network either with an
Ethernet cable or via wireless, and that it is turned on. You can add a printer
by opening Printers, and then clicking the Add button. The “New Printer”
window will open. Click on the small triangle next to Network Printer.
If your printer is found automatically it will appear under Network
Printer. Click the printer name and then click Forward. In the text fields
you can now specify the printer name, description and location. Each of
these should remind you of that particular printer so that you can choose
the right one to use when printing. Finally click Apply.
You can also add your network printer by entering the ip address of the
printer. Select “Find Network Printer,” enter the ip address of the printer
in the box that reads Host: and press the Find button. Ubuntu will find the
printer and add it. Most printers are detected by Ubuntu automatically. If
Ubuntu cannot detect the printer automatically, it will ask you to enter the
make and model number of the printer.

If your printer can automatically do double
sided printing, it will probably have a duplexer.
Please refer to the instructions that came with
the printer if you are unsure. If you do have a
duplexer, make sure the Duplexer Installed
option is checked and then click the Forward
button.

The default printer is the one that is automatically selected when you print a file. To set a
printer as default, right-click the printer that
you want to set as default and then click Set As
Default.
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Changing printer options

Printer options allow you to change the printing quality, paper size and
media type. They can be changed by right-clicking a printer and choosing
Properties. The “Printer Properties” window will show; in the left pane,
select Printer Options.
You can now specify settings by changing the drop-down entries. Some
of the options that you might see are explained.
Media size

This is the size of the paper that you put into your printer tray.
Media source

This is the tray that the paper comes from.
Color Model

This is very useful if you want to print in Grayscale to save on ink, or to
print in Color, or Inverted Grayscale.
Media type

Depending on the printer you can change between:
‣
‣
‣
‣
‣

Plain Paper
Automatic
Photo Paper
Transparency Film
cd or dvd Media

Print quality

This specifies how much ink is used when printing, Fast Draft using the
least ink and High-Resolution Photo using the most ink.
Sound

Ubuntu usually detects the audio hardware automatically during installation. Audio in Ubuntu is provided by a sound server named PulseAudio.
The audio preferences are easily configurable with the help of a very easy to
use gui which comes preinstalled with Ubuntu.
Volume indicator and sound preferences

A volume icon is present on the top panel which provides quick access to a
number of audio related functions. When you click on the volume icon you
are greeted with four options: A mute option at the very top, a slider button which you can move horizontally to increase/decrease volume, another
slider button to increase/decrease the volume of the microphone, a shortcut
to the default music player, Rhythmbox, and an option for accessing the
Sound Settings. Selecting Sound Settings… opens up another window, which
provides access to options for changing input and output hardware preferences for speakers, microphones and headphones. It also provides options
for setting the volume level for each application. Sound Settings can also be
found from System Settings…. It is known as Sound.
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Output The Output tab will have a list of all the sound cards available
in your system. Usually there is only one listed; however, if you have a
graphics card which supports hdmi audio, it will also show up in the list.
The Output tab is used for configuring the output of audio. You can increase/decrease and mute/unmute output volume and select your preferred
output device. If you have more than one output device, it will be listed in
the section which reads “Choose a device for sound output.” The default
output hardware, which is automatically detected by Ubuntu during installation will be selected. This section also allows you to change the balance
of sound on the left and right speakers of your desktop/laptop. A new option introduced in Ubuntu 14.04 LTS will allow you to increase the output
volume past 100. You need to check the box ”Allow louder than 100%”.
Input The second tab is for configuring audio Input. You will be able to
use this section when you have an in-built microphone in your system or
if you’ve plugged in an external microphone. You can also add a Bluetooth
headset to your input devices which can serve as a microphone. You can
increase/decrease and mute/unmute input volume from this tab. If there is
more than one input device, you will see them listed in the white box which
reads Choose a device for sound input. If you run VoIP applications such as
Skype, you will find the microphone slider just below the volume slider in
the top panel sound menu during a voice or video call.

By default, the volume in Ubuntu is set to
maximum during installation.

If you change your sound output device, it will
remain as default.

A microphone is used for making audio/video
calls which are supported by applications like
Skype or Empathy. It can also be used for sound
recording.
You should note that by default in any Ubuntu
installation, the input sound for mic is either
very low or muted. You will have to manually
increase the volume or unmute the input to
enable your microphone to record sound or use
it during audio/video calls.

Sound Effects The third tab is Sound Effects. You can enable, disable, or
change the existing sound theme from this section. You can also change the
alert sounds for different events.
Applications The Applications tab is for changing the volume for running
applications. This comes in handy if you have multiple audio applications
running, for example, if you have Rhythmbox, Totem Movie Player and a
web-based video playing at the same time. In this situation, you will be able
to increase/decrease, mute/unmute volume for each application from this
tab.
More functionality

The icon can control various aspects of the system, application volume
and music players like Rhythmbox, Banshee, Clementine and Spotify. The
volume indicator icon can now be easily referred to as the sound menu,
given the diverse functionality of the icon. Media controls available include
play/pause, previous track, and next track. You can also switch between
different playlists from the Choose Playlist option. If the current playing
song has album art, it will show up beside the name of the current track,
otherwise you will see only the details of the song. It displays the track
name, the artist name and the album name of the current track.
Using a webcam

Webcams often come built into laptops and netbooks. Some desktops, such
as Apple iMacs, have webcams built into their displays. If you purchase a
webcam because your computer doesn’t have its own, it will most likely
have a usb connection. To use a usb webcam, plug it into any empty usb
port of your desktop.

You can start and control the default music
player, Rhythmbox, by simply left clicking on
the sound menu and selecting Rhythmbox from
the list. Clicking the play button also starts the
player.
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Almost all new webcams are detected by Ubuntu automatically. You can
configure webcams for individual applications such as Skype and Empathy
from the application’s setup menu. For webcams which do not work right
away with Ubuntu, visit https://wiki.ubuntu.com/Webcam for help.
Scanning text and images

Scanning a document or an image is very simple in Ubuntu. Scanning is
handled by the application Simple Scan. Most of the time, Ubuntu will
simply detect your scanner and you should just be able to use it. To scan a
document, follow these steps:
1.
2.
3.
4.
5.
6.
7.

Place what you want to scan on the scanner.
Click to open the Dash and enter scan.
Click on Simple Scan.
Click to choose between Text or Photo from Document ‣ Scan ‣ Text.
Click Scan.
Click the Paper Icon to add another page.
Click Save to save.

You can save the scanned documents and pictures in jpeg. You can also
save in pdf format to enable opening in Acrobat Reader. To do that, add the
extension .pdf at the end of the filename.
Troubleshooting your scanner

If your scanner is not detected, Ubuntu may give you a “No scanners detected” message when trying to scan. There may be a reason why Ubuntu
cannot find your scanner.
‣ Simply unplug the scanner and plug it back in. If it is a newer usb scanner, it is likely that it will just work.
‣ The driver for your scanner is not being automatically loaded. Restart
your system. It might help!
‣ Try restarting the scanner service. Open a terminal from the Dash and
type in sudo /etc/init.d/saned restart
‣ Your scanner is not supported in Ubuntu. The most common type
of scanner not supported is old parallel port or Lexmark All-in-One
printer/scanner/faxes.
‣ sane project listing of supported scanners. The sane (Scanner Access
Now Easy) project provides most of the back-ends to the scanning software on Ubuntu.
‣ Check https://wiki.ubuntu.com/HardwareSupportComponentsScanners
to find out which scanners work with Ubuntu.
Keyboard and mouse

The keyboard and mouse are essential input devices for a large number
of computer users today. There are many different makes and models of
keyboards and mice, including lots of keyboards with support for different
languages.
In this section we will look at the different settings for your keyboard
and mouse. This will be of great use to international users.

There are several applications which are useful
if you have a webcam. Cheese can capture
pictures with your webcam and VLC media
player can capture video from your webcam.
You can install these from the Ubuntu Software
application.
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Keyboard

The keyboard is likely to be one of the main ways that you interact with
your computer. Unfortunately not all keyboards are uniform in design;
they can differ by country, by language or appearance. In Ubuntu 16.04, the
default language set for the keyboard now appears as an applet menu right
next to the Network Manager icon. Clicking on the keyboard applet menu
will show you what is the default language set for the keyboard and also
enable you to access three options: 1. Character Map 2. Keyboard Layout
3. Text Entry Settings….
Mouse and Touchpad

A mouse is another mode of input and goes hand in hand with the keyboard. Ubuntu supports all types of plug and play mice, including touchpads and trackballs. If you are planning to use a mouse with your laptop,
just plug it in and Ubuntu will recognize it instantly.
There is a settings menu under System Settings ‣ Mouse and Touchpad where you can change the mouse settings such as double-click speed,
pointer speed and left handed or right handed clicks. If you are using touchpad on your laptop/netbook you can also increase the sensitivity of your
touchpad. You can also enable horizontal, edge scrolling and two finger
scrolling on your laptop/netbook.
Multitouch and gesture support

Ubuntu has full support for multitouch gestures. This means that anyone
with a touch-enabled device or interface can use the multitouch features.
Once triggered, resizing and moving windows in touch-friendly devices can
be done using three fingered tap on an application window.
Ubuntu also supports two-finger scrolling similar to OS X laptops and
desktops. This setting can be enabled from System Setting ‣ Mouse and
Touchpad ‣ Touchpad. Select “Two-finger scrolling” from the Scrolling
options. You can also search for Mouse and Touchpad from the Dash search
bar and enable the option. Please note that enabling two finger scrolling
will disable edge scrolling.
Other devices
USB

usb ports are available as standard on almost all computers available now.
They are used to connect a multitude of devices to your computer. These
could include portable hard drives, flash drives, removable cd/dvd/Blu-ray
drives, printers, scanners and mobile phones.
When connected, flash drives and portable hard drives are automatically
detected—the file manager will open and display the contents of the drive.
You can then use the drives for copying data to and from the computer.
All new cameras, camcorders and mobile phone sd cards are automatically detected by Ubuntu. These sd cards have different types of data, so a
window will appear with a drop-down menu to choose between video, audio import and the file manager—you can choose your desired action from
this menu.

Figure 4.1: Keyboard applet menu.
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Firewire

Firewire is a connection on some computers that allows you to transfer data
from devices. This port is generally used by camcorders and digital cameras.
If you want to import video from your camcorder you can do so by
connecting your camcorder to the Firewire port. You will need to install a
program called Kino which is available in Ubuntu Software.

Firewire is officially known as IEEE 1394. It
is also known as the Sony i.LINK and Texas
Instruments Lynx.
To find out more about Kino, visit http://www.
kinodv.org/.

Bluetooth

Bluetooth is a wireless technology that is widely used by different types of
devices to connect to each other. It is common to see a mouse or a keyboard
that supports Bluetooth. You can also find gps devices, mobile phones,
headsets, music players and many other devices that can connect to your
desktops or laptop and let you transfer data, listen to music, or play games
as an example.
If your computer has Bluetooth support then you should be able to see
a Bluetooth icon on the top panel, usually on the left side of the volume
icon. If you click on the Bluetooth icon it will open a drop down menu with
choices to Turn on/off Bluetooth, to Turn on/off visibility of the device,
setup access to a Bluetooth device and also access Bluetooth settings.
The Bluetooth preferences can also be accessed from System Settings ‣
Bluetooth. If you want to connect (pair) a new device—for example, to
have a mobile phone send pictures or videos to your computer—click on the
Bluetooth icon on the top panel and select Setup new device….
Ubuntu will open a window for new device setup. When you click Forward, Ubuntu will show you how many Bluetooth devices are present near
your computer. The list of available devices might take a minute or so to
appear on the screen as your system scans for these devices. Each device
will be displayed as soon as it is found by Ubuntu. Once a device you’d like
to connect with appears in the list, click on it. Then, choose a pin number
by selecting PIN options.
Three predefined pin numbers are available, but you can also create a
custom pin. You will need to enter this pin on the device you will be pairing
with Ubuntu.
Once the device has been paired, Ubuntu will open the “Setup completed” window. In Ubuntu, your computer is hidden by default for security
reasons. This means that your Ubuntu system can search other Bluetooth
devices, but others cannot find your Ubuntu system when they perform a
search on their own computer. If you would like to let another device find
your computer, you will have to explicitly allow your computer to be found.
To allow your computer to be found by other bluetooth devices, turn ’on’
the “Visibility of yourcomputername” from System Settings ‣ Bluetooth. You
can also click on the Bluetooth icon and click on Visible to turn on visibility
which will make your computer discoverable.
You can also add a fancy name for your Bluetooth-enabled Ubuntu system by changing the text under Friendly Name.
Another feature present in the Bluetooth icon menu is “Send files to
device.” Use this option to send a file to a mobile phone without pairing
with the computer.

Figure 4.2: The Bluetooth applet menu.

When you pair two Bluetooth devices, you are
letting each device trust the other one. After
you pair two devices, they will automatically
connect to each other in the future without
requiring a PIN.

Android devices need to be paired at all times,
even while transferring files.

5 Software Management
Software management in Ubuntu

Installing software in Ubuntu extends the functionality and usability of this
operating system. This chapter describes the way Ubuntu manages software
installation and how it keeps all software current.
Package management system

Ubuntu and various other Linux variants use a collection of software tools
called a package management system, or package manager. A package manager is a collection of tools that make installing, deleting, upgrading, and
configuring software easy. A package management system has a database
of software called a repository where individual software is arranged into
a collection called a package. These packages, apart from the software,
contain important information about the software itself, such as the software’s name, description, version, name of the vendor, and a list of various
dependencies upon which the software relies for proper installation.
Most other operating systems require a user to purchase commercial
software (online or through a physical store) or search the Internet for
a free alternative (if one is available). The correct installation file must
then be verified for integrity, downloaded, and located on the computer,
followed by the user proceeding through a number of installation prompts
and options. A package management system removes the user interaction
from these steps and automates most, if not all, of the installation process.
Ubuntu comes with a package management system called Advanced
Packaging Tool or apt.
As discussed in Chapter 3: Working with Ubuntu, Ubuntu offers a wide
range of applications for your daily work. Ubuntu comes with a basic set
of applications for common tasks, like surfing the Internet, checking email,
listening to music, and organizing photos and videos. At times, you may
need an extra level of specialization. For example, you may want to retouch
your photos, run software for your business, or play new games. In each of
these cases, you can search for an application, install it, and use it—usually
with no extra cost.
By default, Ubuntu provides a centralized point with two different ways
to browse the repositories for searching, installing, and removing software.
‣ The Ubuntu Software application
‣ Command line apt-get
Ubuntu Software makes searching, installing, and/or removing applications easy and convenient; it is most often the application management
system used by both beginning and expert Ubuntu users. We highly recommend Ubuntu Software for searching, installing, and removing applications,
although you can still use the command-line application apt-get or install
and use the advanced application Synaptic Package Manager. Since software in Ubuntu is delivered in the form of packages, software installation
becomes a one-click, one-step process when using the Ubuntu Software
application.

Figure 5.1: Software Center icon
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Using Software Center

There are numerous ways to install software on an operating system. In
Ubuntu, the quickest and easiest way to find and install new applications
is through Ubuntu Software. Ubuntu Software is your very own storefront and gives you instant access to thousands of great applications. Some
of these applications are free to download whereas others are available
commercially. Each application within Ubuntu Software comes with ratings
and reviews making it easier for you to decide which of the applications
you want to install.
To start Ubuntu Software, click on its icon in the Launcher, or click on
the Dash and search for Ubuntu Software.

In Ubuntu 16.04, Ubuntu Software Center is
replaced by GNOME Software which has been
renamed as Ubuntu Software. Ubuntu Software
Center can still be installed optionally via
Ubuntu Software.

Figure 5.2: You can install and remove applications from your computer using Ubuntu
Software.

Ubuntu Software can be used to install applications available in the official Ubuntu repositories. The Ubuntu Software window has four sections
—Featured Application, Editor’s Picks, Recommended Applications and
Categories. Clicking on a category will take you to a list of related applications. For example, the Internet category contains the Firefox web browser
application.
At the top of the window there are three buttons. Click the All button
to go to Ubuntu Software’s main page, click the Installed button to see a
list of software already installed on your computer, or click Updates to see
available updates.
Find your application

If you are looking for an application, you may already know its specific
name (for example, vlc Media Player). Just type the name of the application in the search box at the top of the window and Ubuntu Software will
show the application in the main window. Or you may just have a general
category in mind (for example, the Audio category includes a number of
different software applications, such as audio editors and music players).
To help you find the right application, you can browse the Ubuntu Software catalog by clicking on the category reflecting the type of software you
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seek. When you select a category, you will be shown a list of applications.
Most categories have sub-categories—for example, the Games category has
sub-categories such as Simulation, Action, Adventure, Card Games. To go
to a sub-category, select one in the left pane; Ubuntu Software will show all
available applications in this category in the main window.
Figure 5.3: Searching for an application in
Ubuntu Software.

Installing software

Once you have found an application you would like to try, installing it is
just one click away.
To install software:
1. Click the Install button.
2. After clicking Install, enter your password into the authentication window. This is the same password you use to log in to your account. You
are required to enter your password whenever installing or removing
software in order to prevent someone without administrator access from
making unauthorized changes to your computer. If you receive an Authentication Failure message after typing in your password, check that
you typed it correctly and try again.
3. Wait until the package is finished installing. During the installation
of programs, you will see an animated icon of the application in the
Launcher. This animated icon shows the Progress of the installation. If
you like, you can go back to the main browsing window and choose
additional software packages to be installed by following the steps above.
Once Ubuntu Software has finished installing an application, it is ready
to be used. You can start the newly installed application by going to the
Dash and typing the name of the application in the search bar.
Removing software

Removing applications is very similar to installing software. First, find the
installed software in Ubuntu Software. You can click on the Installed button
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Figure 5.4: Here, clicking on “Install” will
download and install the package “Stellarium.”

to see all installed software listed in alphabetic order. Scroll down to the
application you wish to remove, then click on the Remove button. Before
actually removing the application, you get a dialog asking you if you are
sure you want to remove it. In this dialog you see two buttons, Cancel and
Remove. This way you can decide whether you really want to remove the
application, or cancel the action.
Figure 5.5: Here, clicking on “Remove” will
remove the package “SuperTuxKart.”

To remove software:
1. Click the Remove button to the right of the application you want to
remove.
2. Enter your password into the authentication window. Similar to installing software, removing software requires your password to help
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protect your computer against unauthorized changes. After confirming
the remove action, the package will be removed.
Removing a package will also update your menus accordingly.
Software Recommendations

On its main page Ubuntu Software shows recommended software in The
“Recommended” section. The content of this section changes regularly.
Figure 5.6: Software Recommendations.

Managing additional software

Although Ubuntu Software provides a large library of applications from
which to choose, you may be interested in a particular application not available in these repositories. It is important to understand alternative methods
for accessing and installing software in Ubuntu, such as downloading an
installation file manually from the Internet, or adding extra repositories.
First, we will look at how to manage your repositories through Software &
Updates.
Software Sources

Ubuntu Software lists only those applications that are available in your
enabled repositories. Repositories can be added or removed through the
Software & Updates application. To open Software & Updates, simply open
System Settings and click on Software & Updates in the System section.
Figure 5.7: The Software & Updates program
enables you to add, remove and manage
package repositories.

Managing the official repositories

When you open Software & Updates, you will see the Ubuntu Software tab
where the first four options are enabled by default.
Canonical-supported free and open-source software (main) This repository
contains all the open-source packages maintained by Canonical.
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Community-maintained free and open-source software (universe) This repository contains all the open-source packages developed and maintained by
the Ubuntu community.
Proprietary drivers for devices (restricted) This repository contains proprietary drivers which may be required to utilize the full capabilities of
some of your devices or hardware.
Figure 5.8: Drivers can be installed or removed
via the Additional Drivers application.

Software restricted by copyright or legal issues (multiverse) This repository
contains software possibly protected from use in some states or countries
by copyright or licensing laws. By using this repository, you assume
responsibility for the usage of any packages that you install.
Source code This repository contains the source code used to build software
packages from some of the other repositories. Building applications from
source is an advanced process for creating packages, and usually only
concerns developers. The Source code option should not be selected
unless you have experience with building applications from source.
Selecting the best software server

To distribute applications and software, Ubuntu grants permission to many
servers all across the world to act as official mirrors to host an exact copy of
all the files contained in the official Ubuntu repositories.
When selecting a server, you may want to consider the following:
Distance to server. This will affect the speed you can achieve with the file
server—the closer the server to your location, the faster the potential
connection.
Internet Service Provider. Some Internet service providers offer low-cost or
unlimited free downloads from their own servers.
Quality of server. Some servers may only offer downloads at a capped
speed, limiting the rate at which you can install and update software on
your computer.
Ubuntu will automatically choose an appropriate server while installing.
It is recommended these settings not be changed unless your physical location significantly changes or if you feel a higher speed should be achieved
by your Internet connection. The guide below will help in choosing an
optimal server.
Ubuntu provides a tool for selecting the server that provides the fastest
connection with your computer.
1. Click the dropdown box next to “Download from:” in the Software &
Updates window.
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Figure 5.9: You can use automatic selection or
choose a server manually.

2. Select “Other…” from the list.
3. In the “Choose a Download Server” window, click the Select Best Server
button in the upper-right. Your computer will now attempt a connection
with all the available servers, then select the one with the fastest speed.
If you are happy with the automatic selection, click Choose Server to
return to the Software & Updates window.
If you are not happy with the automatic selection or prefer not to use
the tool, the fastest server is often the closest server to you geographically.
In this case, simply choose “Other” then find the nearest location to your
location. When you are happy with the selection, click Choose Server to
return to the Software & Updates window.
If you do not have a working Internet connection, updates and programs
can be installed from the installation media itself by inserting your media
and clicking the box under “Installable from cd-rom/dvd.” Once this box is
checked, the media within the cd-rom/dvd drive will function as an online
repository, and the software on the media will be installable from Ubuntu
Software.
Adding more software repositories

Ubuntu makes it easy to add additional third-party repositories to your list
of software sources. The most common repositories added to Ubuntu are
called ppas. A ppa is a Personal Package Archive. These are online repositories used to host the latest versions of software packages, digital projects,
and other applications. ppas allow you to install software packages that are
not available in the official repositories. ppas also allow you to automatically be notified whenever updates for these packages are available.
If you know the web address of a ppa’s Launchpad site, adding it to your
list of software sources is relatively simple. To do so, you will need to use
the Other Software tab in the “Software & Updates” window.
On the Launchpad site for a ppa, you will see a heading to the left called
“Adding this PPA to your system.” Underneath will be a short paragraph
containing a unique url in the form of ppa:test-ppa/example. Highlight this
url by selecting it with your mouse, then right-click and select Copy.
Return to the “Software & Updates” window, and in the Other Software
tab, click Add… at the bottom. A new window will appear, and you will
see the words “Apt line:” followed by a text field. Right-click on the empty
space in this text field and select Paste. You should see appear the url you
copied from the ppa’s Launchpad site earlier. Click Add Source to return
to the “Software & Updates” window. You will see a new entry has been
added to the list of sources in this window with a selected check box in
front (meaning it is enabled).
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Figure 5.10: This is an example of the Launchpad page for the Sublime Text PPA. Sublime
Text is an application that is not available in
the official Ubuntu repositories. However,
by adding this PPA to your list of software
sources, it will be easy to install and update
this application through the Ubuntu Software
application.

If you click Close in the bottom right corner of this window, a message
will appear informing you that “The information about available software
is out-of-date.” This is because you have just added a new repository to
Ubuntu, and it now needs to connect to that repository and download a list
of the packages it provides. Click Reload, and wait while Ubuntu refreshes
all of your enabled repositories (including this new one you just added).
When it has finished, the window will close automatically.
Congratulations, you have just added a ppa to your list of software
sources. You can now open Ubuntu Software and install applications from
this ppa in the same way you previously installed applications from the
default Ubuntu repositories.
Manual software installation

Although Ubuntu has extensive software available, you may want to manually install a software package not available in the repositories. If no ppa
exists for the software, you will need to install it manually. Before you
choose to do so, make sure you trust the package and its maintainer.
Packages in Ubuntu have a .deb extension. Double-clicking a package
will open an overview page in Ubuntu Software which will give you more
information about that package.
The overview provides technical information about that package, a
website link (if applicable), and the option to install. Clicking Install will
install the package just like any other installation in Ubuntu Software.
Updates and upgrades

Ubuntu also allows you to decide how to manage package updates through
the Updates tab in the Software & Updates window.
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Figure 5.11: Installing .deb files manually using
Ubuntu Software.

Ubuntu updates

In this section, you are able to specify the kinds of updates you wish to
install on your system. The type of update usually depends upon your
preferences with regards to system stability versus having access to the
latest developments.
Figure 5.12: You can update installed software
by using the Software Updater application in
Ubuntu.

Important security updates (xenial-security) These updates are highly recommended to ensure your system remains as secure as possible. These
updates are enabled by default.
Recommended updates (xenial-updates) These updates are not as important
in keeping your system secure. Rather, updates listed in this section will
keep your software updated with the most recent bug fixes or minor
updates that have been tested and approved. This option is also enabled
by default.
Unsupported updates (xenial-backports) These are updates that have not
yet been fully tested and reviewed by Canonical. Some bugs may occur
when using these updates, and so this option is also not enabled by
default.
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An additional option “Pre-released updates (xenial-proposed)” has been moved
to a separate tab Developer Options. This option is for those who would rather
remain up-to-date with the very latest releases of applications at the risk of installing an update that has unresolved bugs or conflicts. Note that it is possible
you will encounter problems with these updated applications, therefore, this
option is not enabled by default.

Automatic updates

The middle section of this window allows you to customize how your system manages updates, such as the frequency with which it checks for new
packages, as well as whether it should install important updates right away
(without asking for your permission), download them only, or just notify
you about them.
Release upgrade

At the bottom of the Updates tab in the Software & Updates window, you
will see a dropdown box labeled Notify me of a new Ubuntu version:. This
option allows you to tell Ubuntu how you would like to handle release
updates. This dropdown box contains the following options for notification:
Never Choose this option if you would rather not be notified about any
new Ubuntu releases.
For any new version Choose this option if you always want to have the
latest Ubuntu release, regardless of whether it is a long-term support
release or not. This option is recommended for normal home users.
For long-term support versions Choose this option if you need a release
that will be more stable and have support for a longer time. If you use
Ubuntu for business purposes, you may want to consider selecting this
option.
Canonical will release a new version of the Ubuntu operating system every six months. Almost every release is a normal release. However, every
fourth release—or every 2 years—Canonical releases a long-term support
(lts) version of the operating system. Long-term support releases are
intended to be the most stable releases available and are supported for a
longer period of time. Ubuntu 16.04 is an LTS release. Ubuntu 16.10 will
be a normal release.

6 Advanced Topics
Ubuntu for advanced users

To this point, we’ve provided detailed instructions on getting the most from
Ubuntu’s basic features. In this chapter, we’ll detail some of Ubuntu’s more
advanced features—like the terminal, a powerful utility that can help you
accomplish tasks without the need for a graphical user interface (gui). We’ll
also discuss some advanced security measures you can implement to make
your computer even safer.
This chapter has been written with advanced users in mind. If you’re
new to Ubuntu, don’t feel as though you’ll need to master these topics to
get the most out of your new software (you can easily skip to the next chapter without any adverse impact to your experience with Ubuntu). However,
if you’re looking to expand your knowledge of Ubuntu, we encourage you
to keep reading.
Introduction to the terminal

Throughout this manual, we have focused primarily on the GUI. In order
to fully realize the power of Ubuntu, you will need to learn how to use the
terminal.
What is the terminal?

Most operating systems, including Ubuntu, have two types of user interfaces. The first is a GUI. This is the desktop, windows, menus, and toolbars
you click to get things done. The second, much older type of interface is the
command-line interface (cli).
The terminal is Ubuntu’s CLI. It is a method of controlling some aspects
of Ubuntu using only commands that you type on the keyboard.
Why would I want to use the terminal?

You can perform most day-to-day activities without ever needing to open
the terminal. However, the terminal is a powerful and invaluable tool that
can be used to perform many useful tasks you might not be able to accomplish with a GUI. For example:
‣ Troubleshooting any difficulties that may arise when using Ubuntu
sometimes requires you to use the terminal.
‣ A command-line interface is sometimes a faster way to accomplish a
task. For example, it is often easier to perform operations on many files
concurrently using the terminal.
‣ Learning the command-line interface is the first step towards more
advanced troubleshooting, system administration, and software development skills. If you are interested in becoming a developer or an advanced
Ubuntu user, knowledge of the command-line is essential.
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Opening the terminal

You can open the terminal by clicking Dash then searching for word “term”.
You’ll see an application named terminal. Click on this application to open
a terminal. Alternatively, you can open the terminal by hitting Ctrl+Alt+T
simultaneously.
The terminal gives you access to what is called a shell. When you type
a command in the terminal, the shell interprets this command, resulting in
the desired action. Different types of shells accept slightly different commands. The most popular is called “bash,” and is the default shell in Ubuntu.
When the terminal window opens, it will be largely blank with the exception of some text at the top left of the screen, followed by a blinking block,
known as a cursor. This text is your prompt—it displays, by default, your
login name and your computer’s name, followed by the current directory.
The tilde (~) means that the current directory is your home directory. Finally, the blinking block is called the cursor—this marks where text will be
entered as you type.
To test a terminal command, type pwd and press Enter. The terminal
should display /home/yourusername. This text is called the “output.” You
have just used the pwd (print working directory) command, which outputs
(displays) the current directory.
Figure 6.1: The default terminal window allows
you to run hundreds of useful commands.

All commands in the terminal follow the same approach: Type a command, possibly followed by some parameters, and press Enter to perform
the specified action. Parameters (also called switches) are extra segments
of text, usually added at the end of a command, that change how the command itself is interpreted. These usually take the form of -h or --help, for
example. In fact, --help can be added to most commands to display a short
description of the command, as well as a list of any other parameters that
can be used with that command.
Often, some type of output will be displayed confirming the action was
completed successfully, although this can depend on the command being
executed. For example, using the cd command to change your current directory (see above) will change the prompt but will not display any output.
The rest of this chapter covers some very common uses of the terminal. Throughout the second part of this manual, we will continue to refer
to the command line, particularly when discussing steps involved in troubleshooting as well as when describing more advanced management of your
computer.
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Ubuntu file system structure

Ubuntu uses the Linux file system, which is based on a series of folders
in the root directory. These folders contain important system files that
cannot be modified unless you are running as the root user or use sudo. This
restriction exists for both security and safety reasons; computer viruses will
not be able to change the core system files, and ordinary users should not
be able to accidentally damage anything vital.
Figure 6.2: Some of the most important
directories in the root file system.

We begin our discussion of the Ubuntu file system structure at the top
—also known as the root directory—as denoted by /. The root directory
contains all other directories and files on your system. Below the root
directory are the following essential directories:
and /sbin Many essential system applications (equivalent to C:\Windows).
System-wide configuration files.
/home Each user will have a subdirectory to store personal files (for
example, /home/yourusername) which is equivalent to C:\Users or
C:\Documents and Settings in Microsoft Windows.
/lib Library files, similar to .dll files on Windows.
/media Removable media (cd-roms and usb drives) will be mounted in this
directory.
/root This contains the root user’s files (not to be confused with the root
directory).
/usr Pronounced “user,” it contains most program files (not to be confused with each user’s home directory). This is equivalent to C:\Program
Files in Microsoft Windows.
/var/log Contains log files written by many applications.
/bin
/etc

Every directory has a path. The path is a directory’s full name—it describes a way to navigate the directory from anywhere in the system.
For example, the directory /home/yourusername/Desktop contains all the
files that are on your Ubuntu desktop. It can be broken down into a handful
of key pieces:
‣
‣
‣

/—indicates

that the path starts at the root directory
the root directory, the path goes into the home directory
yourusername/—from the home directory, the path goes into the yourusername directory
‣ Desktop—from the yourusername directory, the path ends up in the
Desktop directory
home/—from
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Every directory in Ubuntu has a complete path that starts with the / (the
root directory) and ends in the directory’s own name.
Directories and files that begin with a period are hidden. These are
usually only visible with a special command or by selecting a specific option. In the Files file manager, you can show hidden files and directories
by selecting the Show Hidden Files option in the View menu. Hidden files
can also be shown by simply pressing Ctrl+H in the Files file manager. If
you are using the terminal, then you would type ls -a and press Enter
to see the hidden files and directories. There are many hidden directories in your home folder used to store program preferences. For example,
/home/yourusername/.thunderbird stores preferences used by the Thunderbird mail application.
Mounting and unmounting removable devices

Any time you add storage media to your computer—an internal or external
hard drive, a usb flash drive, a cd-rom—it needs to be mounted before it is
accessible. Mounting a device means to associate a directory name with the
device, allowing you to navigate to the directory to access the device’s files.
When a device, such as a usb flash drive or a media player, is mounted in
Ubuntu, a folder is automatically created for it in the media/yourusername
directory, and you are given the appropriate permissions to be able to read
and write to the device.
Most file managers will automatically add a shortcut to the mounted
device in the side bar of your home folder or as a shortcut directly on the
desktop so that the device is easily accessible. You shouldn’t have to physically navigate to the media directory in Ubuntu unless you choose to do so
from the command line.
When you’ve finished using a device, you can unmount it. Unmounting a
device disassociates the device from its directory, allowing you to eject it. If
you disconnect or remove a storage device before unmounting it, you may
lose data.
Securing Ubuntu

Now that you know a bit more about using the command line, we can use it
to make your computer more secure. The following sections discuss various
security concepts, along with procedures for keeping your Ubuntu running
smoothly, safely, and securely.
Why Ubuntu is safe

Ubuntu is secure by default for a number of reasons:
‣ Ubuntu clearly distinguishes between normal users and administrative
users.
‣ Software for Ubuntu is kept in a secure online repository containing no
false or malicious software.
‣ Open-source software like Ubuntu allows security flaws to be easily
detected.
‣ Security patches for open-source software like Ubuntu are often released
quickly.
‣ Many viruses designed to primarily target Windows-based systems do
not affect Ubuntu systems.
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Just because Ubuntu implements strong security model by default doesn’t
mean the user can “throw caution to the wind.” Care should always be
taken when downloading files, opening email, and browsing the Internet.
Using a good antivirus program is warranted as well.
Basic security concepts

The following sections discuss basic security concepts—like file permissions,
passwords, and user accounts. Understanding these concepts will help you
in securing your computer.
Permissions

In Ubuntu, files and folders can be set up so that only specific users can
view, modify, or run them. For instance, you might wish to share an important file with other users, but do not want those users to be able to edit the
file. Ubuntu controls access to files on your computer through a system of
“permissions.” Permissions are settings configured to control exactly how
files on your computer are accessed and used.
To learn more about modifying permissions, visit https://help.ubuntu.
com/community/FilePermissions.
Passwords

You should use a strong password to increase the security of your computer.
Your password should not contain names, common words, or common
phrases. By default, the minimum length of a password in Ubuntu is four
characters. We recommend a password with more than the minimum number of characters. A password with a minimum of eight characters which
includes both upper and lower case letters, numbers, and symbols is considered strong.
Locking the screen

When you leave your computer unattended, you may want to lock the
screen. Locking your screen prevents another user from using your computer until your password is entered. To lock the screen:
‣ Click the session menu icon in the right corner of the top panel, then
select Lock/Switch Account…, or
‣ Press Ctrl+Alt+L to lock the screen. This keyboard shortcut can be
changed by going to Session Indicator ‣ System Settings… ‣ Keyboard ‣
Shortcuts and then selecting System from the list in the left column and
clicking on Lock Screen in the right column.
Users and groups
User accounts

When Ubuntu is installed, it is automatically configured for use by a single
user. If more than one person will use the computer, each person should
have his or her own user account. This way, each user can have separate
settings, documents, and other files. If necessary, you can also protect files
from being viewed or modified by users without administrative privileges.
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Like most operating systems, Ubuntu allows you to create separate user
accounts for each person. Ubuntu also supports user groups, which allows
you to administer permissions for multiple users at the same time.
Every user in Ubuntu is a member of at least one group. At a bare minimum, the user of the computer has permissions in a group with the same
name as the user. A user can also be a member of additional groups. You
can configure some files and folders to be accessible only by a user and a
group. By default, a user’s files are only accessible by that user, and system
files are only accessible by the root user.
Figure 6.3: Add, remove and change the user
accounts.

Managing users

If the account you are using is an administrator account, you can manage
users and groups using the Users and Groups administration application.
To find this application, click Session Indicator ‣ System Settings… ‣ User
Accounts. Then click the Unlock button and enter your password to unlock
the user settings. Next, select the user that you want to modify from the list.
Then click on the element that you want to change.
Adding a user Click the + button underneath the list of the current user
accounts. A window will appear with three fields. The Account Type field
contains a list of user account types. Take care in determining what type
of account to assign a user. An Administrator has full access to all areas
of Ubuntu, whereas the Standard account type is more limited. The Full
Name field contains a friendly display name. The Username field is for the
actual username. As you enter the user’s full name, the Username field
will automatically fill with a lowercase, no space version of the user’s full
name. If you prefer to use a different username for this user, highlight
the existing username and type in the username of your choice. Once all
fields are filled in, click Add. The new user will be added to the list of user
accounts. New accounts are disabled by default. To enable an account, click
the Account disabled field next to the Password label. A new window will
appear allowing you to set the password for the new user.
At the top of the new window is a dropdown menu next to the label
Action. By default, the “set a password now” option will be automatically
selected. You may also choose “log in without a password”, however, this
is not advised as the account will be available to anyone. The final option,
“enable this account” is available once a password has been set. Using this
option allows an administrator to enable or disable an account without
losing the password.
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Ubuntu provides a way to create a secure password by clicking the gears
button located inside of the New password field. A random sequence of
numbers, letters, and symbols will be entered into this field. You can also
simply enter a password of your choosing by entering it into the New
password field. Then, re-enter this same password into the space next to
Confirm password.
Ubuntu enforces the password policies on this screen, so pay attention to the
status information located between the New password and Confirm password
fields for information about the password you’re setting. If there are problems
with the password, Ubuntu will tell you what is wrong with the password and
will prevent you from entering the same password into the Confirm password
field until the new password meets the requirements.

Modifying a user Click on the name of a user in the list of users, then click
on the text entry next to any of the following options:
‣
‣
‣
‣

Account type:
Language:
Password:
Automatic Login:

You may also change the username by clicking on the username at the top
and entering a new name.
Deleting a user Select a user from the list and click -. Ubuntu will deactivate the user’s account, and you can choose whether to remove the user’s
home folder or leave it in place. If a user is removed and the user’s files remain, the only user who can access the files are the root user—also known
as the superuser—or anyone associated with the file’s group.
Managing groups

Group management is accomplished through the command line (Terminal)
or by adding third-party applications (the latter is beyond the scope of this
manual). You will find more information in the section below titled “Using
the command line”.
Adding a group To add a group, type sudo addgroup groupname and press
Enter, replacing groupname with the name of the group you wish to add.
For example, sudo addgroup ubuntuusers will add the group ubuntuusers
to the list of groups.
Modifying a group To alter the users in an existing group, type sudo
adduser username groupname to add a user, or sudo deluser username
groupname to remove a user, and press Enter, replacing username and
groupname in these commands with the actual user and group name with
which you’re working.
Deleting a group To delete a group, type sudo delgroup groupname and
press Enter, replacing groupname with the name of the group you wish to
delete.

104 getting started with ubuntu 16.04

Applying groups to files and folders

To change the group associated with a file or folder, open the Files file manager and navigate to the appropriate file or folder. Then, either select the
menu Files and choose Properties, or right-click on the file or folder and
select Properties. In the Properties dialog window, click on the Permissions
tab and select the desired group from the Groups drop-down list. Then
close the window.
Using the command line

You can also modify user and group settings via the command line, but
we recommend you use the graphical method above unless you have a
good reason to use the command line. For more information on using the
command line to modify users and groups, see the Ubuntu Server Guide at
https://help.ubuntu.com/13.04/serverguide/user-management.html.
System updates

Good security happens with an up-to-date system. Ubuntu provides free
software and security updates. You should apply these updates regularly.
See Updates and upgrades to learn how to update your Ubuntu computer
with the latest security updates and patches.
Trusting third party sources

Normally, you will add applications to your computer via Ubuntu Software
which downloads software from the Ubuntu repositories as described in
Chapter 5: Software Management. However, it is occasionally necessary
to add software from other sources. For example, you may need to do this
when an application is not available in the Ubuntu repositories or when
you need a version of software newer than what is currently in the Ubuntu
repositories.
Additional repositories are available from sites such as http://www.
getdeb.net and Launchpad ppas which can be added as described in Software Sources. You can download the deb packages for some applications
from their respective project sites on the Internet. Alternatively, you can
build applications from their source code.
Using only recognized sources, such as a project’s site, ppa or various
community repositories (such as http://www.getdeb.net), is more secure
than downloading applications from an arbitrary (and perhaps less reputable) source. When using a third party source, consider its trustworthiness, and be sure you know exactly what you’re installing on your computer.
Firewall

A firewall is an application that protects your computer against unauthorized access by people on the Internet or your local network. Firewalls
block connections to your computer from unknown sources. This helps
prevent security breaches.
Uncomplicated Firewall (ufw) is the standard firewall configuration program in Ubuntu. It runs from the command line, but a program called Gufw
allows you to use it with a graphical user interface gui. See Chapter 5:
Software Management to learn more about installing the Gufw package.
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Once Gufw is installed, start Gufw by clicking Dash ‣ Applications ‣
Firewall configuration. To enable the firewall, select the Enable option. By
default, all incoming connections are denied. This setting should be suitable
for most users.
If you are running server software on your Ubuntu system (such as a
web server, or an ftp server), then you will need to open the ports these
services use. If you have no need to run any server applications or services,
you will likely not need to open any additional ports.
To open a port click on the Add button. For most purposes, the Preconfigured tab is sufficient. Select Allow from the first box and then select the
program or service required.
The Simple tab can be used to allow access on a single port, and the
Advanced tab can be used to allow access on a range of ports.
Encryption

You may wish to protect your sensitive personal data—for instance, financial records—by encrypting it. Encrypting a file or folder essentially “locks”
that file or folder by encoding it with an algorithm that keeps it scrambled
until it is properly decoded with a password. Encrypting your personal data
ensures that no one can open your personal folders or read your private
data without your authorization through the use of a private key.
Ubuntu includes a number of tools to encrypt files and folders. This
chapter will discuss two of them. For further information on using encryption with either single files or email, see Ubuntu Community Help
documents at https://help.ubuntu.com/community.
Home folder

When installing Ubuntu, it is possible to encrypt a user’s home folder. See
Chapter 1: Installation for more on encrypting the home folder.
Private folder

If you have not chosen to encrypt a user’s entire home folder, it is possible
to encrypt a single folder—called Private—in a user’s home folder. To do
this, follow these steps:
1. In the terminal, install the ecryptfs-utils software package using the
command sudo apt install ecryptfs-utils.
2. Use the terminal to run ecryptfs-setup-private to set up the private
folder.
3. Enter your account’s password when prompted.
4. Either choose a mount passphrase or generate one.
5. Record both passphrases in a safe location. These are required if you ever
have to recover your data manually.
6. Log out and log back in to mount the encrypted folder.
After the Private folder has been set up, any files or folders in it will
automatically be encrypted.
If you need to recover your encrypted files manually see https://help.
ubuntu.com/community/EncryptedPrivateDirectory.
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Running Windows Programs on Ubuntu

As many Windows users will know, some programs that you can use on a
Windows system cease to work on Ubuntu. For example, LibreOffice works
on both Windows and Ubuntu systems, but Microsoft Office works only on a
Windows system. Since many Windows users who use Ubuntu want all of
their Windows programs back, many programmers have worked together to
create Wine. Wine is an acronym for “W ine I s N ot an Emulator”.
This section will discuss what Wine is, and how to use it on your Ubuntu
installation. For recent information about Wine, please visit the official
Wine website at http://www.winehq.org.
What is Wine?

Wine is a background application that allows Linux and OS X users to
install and run Windows programs on their system. While not every Windows program is compatible with Wine, many programs seem to be completely compatible with Wine while running on Linux or OS X. For example,
Microsoft Office may not be compatible without installing additional components (such as Microsoft.NET Framework 4.0). The current stable version
of Wine is 1.8.2, and the most recent development version is 1.9.8.
Installing Wine

To install Wine Version 1.8.2, follow the following steps:
If you have a previous version of Wine installed, uninstall Wine before continuing
using the command, sudo apt remove --purge wine1.* winetricks && sudo
apt-get autoremove

1. Open the terminal and type: sudo apt-add-repository ppa:ubuntuwine/ppa. This will install the Official Wine ppa.
2. After the terminal has finished installing the Wine ppa, type: sudo apt
update. This will update the ppa list.
3. Once the terminal has finished refreshing the ppa list, type: sudo apt
install -y wine1.8 winetricks. This will install Wine 1.8.2 and Winetricks. Winetricks is a software center for Wine, and is, in most cases,
optional.

Figure 6.4: The Terminal showing the installation of the Wine PPA.

During the installation of Wine and Winetricks, you will have to accept the Microsoft End User License Agreement and the Microsoft Core
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Fonts License Agreement so that the Microsoft fonts and native files can be
installed.
Figure 6.5: The Microsoft Core Fonts EULA
dialog opened in the Terminal.

When accepting the Microsoft Core Fonts License Agreement, the Ok
button is not highlighted. To highlight and accept the Microsoft EULA,
press the Tab key and then the Enter key. The Microsoft End User License
Agreement will be shown after you accept the Microsoft Core Fonts EULA.
By default, the No button is highlighted. To highlight the Yes button and
accept the Microsoft EULA, press the Tab key and then the Enter key.
Figure 6.6: The Microsoft Core Fonts EULA
dialog opened in the Terminal.

Please Note: It is recommended to reboot your system after installing
Wine and Winetricks, although this is not always required.
Configuring Wine

Wine 1.8.2 contains many features that will change the look and feel of the
Windows applications you are trying to run. For example, you can change
the theme of the Windows interface, and what version of Windows you
would like to run (from Windows 2.0 to Windows 8).
To change these settings, open the Dash and search for Configure Wine.
Then, open the application. You may see a dialog asking you to install the
packages Mono and Wine Gecko. You can either press the Install button, or
go to the Wine website for details.
Application Tab In the Application tab, you can change the way Wine
runs applications. Some Windows programs work only for specific versions
of Windows. This feature allows you to change the version of Windows
Wine will run as for a specific application, or for all of them to run under
one version.
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Figure 6.7: The Wine configuration open to the
Application Tab.

Libraries Tab In the Libraries tab, you can change core Windows files,
to suit your needs. Many Windows programs install dll files, or Dynamic
Link Libraries. These files contain all of the information needed for an
application to work on a Windows system. Many dll files are needed for
a Windows system to run, and are different between versions of Windows.
In this feature, you may edit or replace existing dll files. This allows you to
change the Windows System files, to suit you needs.
These files should not be edited. These are core files needed for Wine to run
correctly. Only edit these files if you have to.

Graphics Tab In the Graphics tab, you can change the look and feel of
how Wine runs. You can make Wine emulate a Virtual Desktop (this feature
opens a new window that will contain any Windows application that is
currently running while this option is in effect), how the applications look,
and what resolution to run the application in.
Desktop Integration Tab In the Desktop Integration tab, you can change
the way buttons, menus, and other elements appear in an application. Each
version of Windows has brought its own unique visual style for its applications. In this feature, you can install and change the applied theme.
In this tab, you can also change major file folders. For example, while
using Ubuntu, your picture folder is located at /home/user/Pictures/
but in Windows, your picture folder is located at C:\Documents and Settings\User\My Documents\My Pictures\ or C:\Users\User\My Pictures\.
This feature allows you tell Wine where your folders are, for quick reference.
Drives Tab In the Drives tab, you can manage the connected drives that
Wine will be able to access. Unlike Ubuntu, Windows applies a Drive Letter
to each drive. This letter identifies the drive. For example, on every Windows system, the C: drive is the core drive. It contains all of the needed files
for the operating system to work. The C: drive is the equivalent to root (File
System, or / ) in Ubuntu. This feature allows you to change the drive letters
for any drive, or add a drive letter for a specific folder in your file system, or
for a cd drive.
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Audio Tab In the Audio tab, you can change the audio settings. This feature allows you to change the audio source that Wine will use for Windows
applications (speakers, microphones, etc.).
About Tab In the About tab, you can see the current Wine version you
have installed, including Wine’s note to all users. This feature also allows
you to add a Name and Company Name to the Windows information. Applications use this information to identify you by name.
Microsoft .NET Framework and Wine

Microsoft has created many programs that are needed to run commonly
used applications, Microsoft .NET Framework being the most common. .NET
Framework is needed to run most of the newer applications created by
Microsoft, and by other companies as well. Wine is not fully supported by
all versions of .NET, but is compatible with most versions. Here is a list of
.NET versions, and their compatibility with Wine:
‣
‣
‣
‣
‣
‣
‣
‣
‣

.NET Framework 1.0
.NET Framework 1.1
.NET Framework 2.0
.NET Framework 3.0
.NET Framework 3.5
.NET Framework 4.0
.NET Framework 4.5*
.NET Framework 4.5.1**
.NET Framework 4.5.2**

For more compatibility information about installing and running Microsoft .NET Framework using Wine, go to: http://appdb.winehq.org/
objectManager.php?sClass=application&iId=2586.

* This framework has known issues running
under Wine and is, in most cases, installable and
stable enough to use for most applications.
** This framework has not been tested using a
current version of Wine running on Ubuntu, so it
is unknown if it will be compatible or not. Use at
your own risk.

7 Troubleshooting
Resolving problems

Sometimes things may not work as they should. Luckily, problems encountered while working with Ubuntu are often easily fixed. This chapter is
meant as a guide for resolving basic problems users may encounter while
using Ubuntu. If you need any additional help beyond what is provided
in this chapter, take a look at other support options that are discussed in
Finding additional help and support later in this book.
Troubleshooting guide

The key to effective troubleshooting is to work slowly, complete all of the
troubleshooting steps, and to document the changes you made to the utility
or application you are using. This way, you will be able to undo your work,
or give fellow users the information about your previous attempts—the
latter is particularly helpful in cases when you look to the community of
Ubuntu users for support.
Ubuntu fails to start after I’ve installed Windows

Occasionally you may install Ubuntu and then decide to install Microsoft
Windows as a second operating system running side-by-side with Ubuntu.
This is supported in Ubuntu, but you might also find after installing Windows that you will no longer be able to start Ubuntu.
When you first turn on your computer, a “bootloader” is responsible for
initiating the start of an operating system, such as Ubuntu or Windows.
When you installed Ubuntu, you automatically installed an advanced
bootloader called grub. grub allows you to choose between the various
operating systems installed on your computer, such as Ubuntu, Windows,
Solaris, or OS X. If Windows is installed after Ubuntu, the Windows installation removed grub and replaced the bootloader with it’s own. As a result,
you can no longer choose an operating system to use. You can restore grub
and regain the ability to choose your operating system by following the
steps below, using the same dvd you used to install Ubuntu.
First, insert your Ubuntu dvd into your computer and then restart the
computer, making sure to instruct your computer to boot from the dvd
drive and not the hard drive (see Chapter 1: Installation). Next, choose your
language (e.g., English) and select Try Ubuntu. Once Ubuntu starts, click
on the top-most icon in the Launcher (the Dash icon). Then, search for
Terminal using the search box. Then, select Terminal in the search results
(or press Ctrl+Alt+T). A window should open with a blinking prompt line.
Enter the following, and press the Enter key:
$ sudo fdisk -l
Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot

Start

End

Blocks

Id

System

A bootloader is the initial software that loads
the operating system when the computer is
powered up.
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/dev/sda1

1

1224

1225

2440

/dev/sda3

2441

14593

/dev/sda4

14532

14593

/dev/sda2

*

64228+
9767520
97618972+
498015

83

Linux

a5

Windows

5
82

Extended
Linux swap

Partition table entries are not in disk order

This output shows that your system (Linux, on which Ubuntu is based)
is installed on device /dev/sda1, but as indicated by the asterisk in the
Boot column, your computer is booting to /dev/sda2 (where Windows is
located). We need to fix this by telling the computer to boot to the Linux
device instead.
To do this, create a place to connect your existing Ubuntu installation
with your temporary troubleshooting session:
$ sudo mkdir /mnt/root

Next, link your Ubuntu installation and this new folder:
$ sudo mount /dev/sda1 /mnt/root

If you’ve done this correctly, then you should see the following:
$ ls /mnt/root
bin dev home lib mnt root srv usr
boot etc initrd lib64 opt sbin sys var
cdrom initrd.img media proc selinux tmp vmlinuz

Now, you can reinstall grub:
$ sudo grub-install --root-directory=/mnt/root /dev/sda
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script grub-install.
(hd0) /dev/sda

Next you’ll want to unmount the hard drive. This ensures that the drive
won’t become corrupted when you reboot:
$ sudo umount /mnt/root

Finally, remove the Ubuntu disc from your dvd-rom drive, reboot your
computer, and then start enjoying your Ubuntu operating system once
again.
This guide may not work for all Ubuntu users due to differences in the
various system configuration. Still, this is the recommended and most
successful method for restoring the grub bootloader. If you are following
this guide and if it does not restore grub on your computer, then try the
other troubleshooting methods at https://help.ubuntu.com/community/
RecoveringUbuntuAfterInstallingWindows.
I forgot my password

If you forgot your password in Ubuntu, you will need to reset it using the
“Recovery mode.”
To start the Recovery mode, shut down your computer and then start
again. As the computer starts up, press Shift. Select the Recovery mode
option using the arrow keys on your keyboard. Recovery mode should be
under the heading Advanced Options in the list.
Wait until Ubuntu starts up—this may take a few minutes. Once booted,
you will not be able to see a normal login screen. Instead, you will be presented with the Recovery Menu. Select root using the arrow keys and press
Enter.
You will now be at a terminal prompt:

The device (/dev/sda1, /dev/sda2, etc.) we
are looking for is identified by the word “Linux”
in the System column. Modify the instructions
below if necessary, replacing /dev/sda1 with
the name of your Linux device.
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Figure 7.1: This is the grub screen in which you
can choose recovery mode.

root@ubuntu:~#

To reset your password, enter:
# passwd username

Replace “username” above with your username, after which Ubuntu will
prompt you for a new password. Enter your desired password, press the
Enter key, and then re-type your password again, pressing Enter again
when done. (Ubuntu asks for your password twice to make sure you did
not make a mistake while typing). Once you have restored your password,
return to the normal system environment by entering:
# init 2

Login as usual and continue enjoying Ubuntu.
I accidentally deleted some files that I need

If you’ve deleted a file by accident, you may be able to recover it from
Ubuntu’s Trash folder. This is a special folder where Ubuntu stores deleted
files before they are permanently removed from your computer.
To access the Trash folder click on the trash icon at the bottom of the
Unity Launcher.
If you want to restore deleted items from the Trash:
1. Open Trash
2. Click on each item you want to restore to select it. Press and hold Ctrl
to select multiple items.
3. Click Restore to move the deleted items back to their original locations.
How do I clean Ubuntu?

Ubuntu’s software packaging system accumulates unused packages and
temporary files through regular updates and use. These temporary files, also
called caches, contain files from all of the installed packages. Over time, this
cache can grow quite large. Cleaning out the cache allows you to reclaim
space on your computer’s hard drive for storing your documents, music,
photographs, or other files.
To clear the cache, you can either use the clean, or the autoclean option
for the command-line program apt-get.
To run clean, open Terminal and enter:
$ sudo apt-get clean

The clean command will remove every
single cached item, while the autoclean
command only removes cached items that can
no longer be downloaded (these items are
often unnecessary).
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Packages can also become unused over time. If a package was installed
to assist with running another program—and that program was subsequently removed—you no longer need the supporting package. You can
remove it with apt-get autoremove.
Load Terminal and enter:
$ sudo apt-get autoremove

I can’t play certain audio or video files

Many of the formats used to deliver rich media content are proprietary,
meaning they are not free to use, modify, or distribute with an open-source
operating system like Ubuntu. Therefore, Ubuntu does not include the capability to use these formats by default; however, users can easily configure
Ubuntu to use these proprietary formats. For more information about the
differences between open source and proprietary software, see Chapter 8:
Learning More.
If you find yourself in need of a proprietary format, you can install the
required files from the Terminal. This is covered in the Codecs portion of
Chapter 3. Ensure that you have the Universe and Multiverse repositories
enabled before continuing. See the Software Sources section to learn how to
enable these repositories.
One program that can play many of these formats is vlc. It can be installed from the Terminal or Ubuntu Software. Once Ubuntu has successfully installed this software, your rich media content should work properly.
How can I change my screen resolution?

The image on every monitor is composed of millions of little colored dots
called pixels. Changing the number of pixels displayed on your monitor is
called “changing the resolution.” Increasing the resolution will make the
displayed images sharper, but will also tend to make them smaller. The
opposite is true when screen resolution is decreased. Most monitors have
a “native resolution,” which is a resolution that most closely matches the
number of pixels in the monitor. Your display will usually be sharpest when
your operating system uses a resolution that matches your display’s native
resolution.
The Ubuntu configuration utility Displays allows users to change the
resolution. Open it by clicking on the session indicator and then on Displays…. The resolution can be changed using the drop-down list within
the program. Picking options higher up on the list (for example, those with
larger numbers) will increase the resolution.
You can experiment with various resolutions by clicking Apply at the
bottom of the window until you find one that is comfortable. Typically,
the highest resolution will be the native resolution. Selecting a resolution
and clicking Apply will temporarily change the screen resolution to the
selected value, and a dialog box will also be displayed for 30 seconds. This
dialog box allows you to revert to the previous resolution setting or keep
the new resolution setting. If you’ve not accepted the new resolution and/or
30 seconds have passed, the dialog box will disappear and the display’s
resolution will return to its previous setting.
This feature was implemented to prevent someone from being locked out
of the computer by a resolution that distorts the monitor output and makes
it unusable. When you have finished setting the screen resolution, click
Close.
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Figure 7.2: You can change your display
settings.

Figure 7.3: You can revert back to your old
settings if you need to.

Ubuntu is not working properly on my Apple MacBook or MacBook Pro

When installed on notebook computers from Apple—such as the MacBook
or MacBook Pro—Ubuntu does not always enable all of the computer’s
built-in components, including the iSight camera and the Airport wireless
Internet adapter. Luckily, the Ubuntu community offers documentation
on fixing these and other problems. If you are having trouble installing or
using Ubuntu on your Apple notebook computer, please follow the instructions at https://help.ubuntu.com/community/MacBook. You can select the
appropriate guide after identifying your computer’s model number.
Ubuntu is not working properly on my Asus EeePC

When installed on netbook computers from Asus—such as the EeePC—
Ubuntu does not always enable all of the computer’s built-in components,
including the keyboard shortcut keys and the wireless Internet adapter.
The Ubuntu community offers documentation on enabling these components and fixing other problems. If you are having trouble installing
or using Ubuntu on your Asus EeePC, please follow the instructions at
https://help.ubuntu.com/community/EeePC. This documentation page contains information pertaining specifically to EeePC netbooks.
To enable many of the features and Function Keys, a quick fix is to add
“acpi_osi=Linux” to your grub configuration. From the Terminal
$ gksudo gedit /etc/default/grub

and very carefully change the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Save and close the file. Then, from the terminal:
$ sudo update-grub

After the command finishes, and you restart the computer, you will be able
to use the Fn keys normally.
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My hardware is not working properly

Ubuntu occasionally has difficulty running on certain computers, usually
when hardware manufacturers use non-standard or proprietary components. The Ubuntu community offers documentation to help you troubleshoot many common issues in this situation, including problems with
wireless cards, scanners, mice, and printers. You can find the complete
hardware troubleshooting guide on Ubuntu’s support wiki, accessible at
https://wiki.ubuntu.com/HardwareSupport. If your hardware problems
persist, please see Getting more help for more troubleshooting options or
information on obtaining support or assistance from an Ubuntu user.
Getting more help

This guide does not cover every possible workflow, task, issue, or problem
in Ubuntu. If you require assistance beyond the information in the manual,
you can find a variety of support opportunities online.
More details about many support options available to you can be found
at Finding additional help and support later in this book.

8 Learning More
What else can I do with Ubuntu?

At this point, you should now be able to use Ubuntu for most daily activities—such as browsing the web, sending email, and creating documents.
Now, you may be interested in learning about other versions of Ubuntu
that may integrate into your digital lifestyle. In this chapter, we’ll introduce
additional versions of Ubuntu designed and specialized for certain tasks.
We’ll also provide resources for answering any remaining questions as well
as direct you to how you can get involved in the worldwide community
of Ubuntu users. First, we’ll discuss the technologies that make Ubuntu a
powerful collection of software and a progressive operating system.
Open source software

Ubuntu is open source software (OSS). OSS differs from proprietary software. Proprietary software is defined as software whose source code is
not freely available for modification or distribution by anyone but the
rightsholder. Microsoft Windows and Adobe Photoshop are examples of
proprietary software.
Unlike proprietary software applications, the software included with
Ubuntu is specifically licensed to promote sharing and collaboration. The
legal rules governing Ubuntu’s production and distribution ensure that
anyone can obtain, run, or share it for any purpose. Users can modify open
source software to suit their individual needs, to share it, to improve it, or to
translate it into other languages—provided they release the source code for
these modifications so others can do the same. In fact, the terms of many
open source licensing agreements actually make it illegal not to do so. This
understanding helps explain why Ubuntu is called open source software.
For more information regarding Ubuntu’s software licensing standards, see
http://www.ubuntu.com/project/about-ubuntu/licensing.
Because OSS is developed by large communities of programmers located
throughout the world, it benefits from both rapid development cycles and
speedy security releases when bugs are identified in the software. In other
words, OSS is updated, enhanced, and made more secure every day as
programmers all over the world continue to improve it.
In addition to these technical advantages, OSS also has economic benefits. While users must adhere to the terms of an OSS licensing agreement
when installing and using Ubuntu, they needn’t pay to obtain this license.
While not all OSS is free of monetary costs, a vast majority of OSS is available for free.
To learn more about open source software, see the Open Source Initiative’s open source definition, available at http://www.opensource.org/docs/
definition.php.
Distribution families

Ubuntu is one of several popular operating systems based on Linux. These
Linux-based operating systems—called Linux “distributions”—may look
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different from Ubuntu at first glance, but they share similar characteristics
because of their common roots.
Linux distributions can be divided into two broad families: the Debian
family and the Red Hat family. Each family is named for a distribution on
which subsequent distributions are based. For example, “Debian” refers to
both the name of a Linux distribution as well as the family of distributions
derived from Debian. Ubuntu is part of this family. When describing relationships between various open source projects, software developers often
use the metaphor of tributaries connecting to a common body of water.
For this reason, you may hear someone say that Ubuntu is located “downstream” from Debian, because alterations to the Debian family ”flow” into
new versions of Ubuntu. Additionally, improvements to Ubuntu usually
trickle “upstream”—back to Debian and its family members as the Debian
family benefits from the work of the Ubuntu community. Other distributions in the Debian family include Linux Mint, Xandros, and CrunchBang
Linux. Distributions in the Red Hat family include Fedora and Mandriva.
The most significant difference between Debian-based and Red Hatbased distributions is the system each uses for installing and updating
software. These systems are called Package management systems. Package
management systems are the means by which users can install, remove,
and organize software installed on computers with open source operating
systems like Ubuntu. Debian software packages are deb files, while Red Hat
software packages are rpm files. The two systems are generally incompatible. For more information about package management, review the chapter
on Chapter 5: Software Management.
You will also find specialized Linux distributions for certain tasks. Next,
we’ll describe these versions of Ubuntu and explain the uses for which each
has been developed.
Choosing amongst Ubuntu and its derivatives

Just as Ubuntu is based on Debian, several distributions are subsequently
based on Ubuntu. Each differs with respect to the software included as part
of the distribution. Some are developed for general use, while others are
designed for accomplishing a more narrow set of tasks.
Alternative interfaces

Ubuntu features a graphical user interface (gui) based on the open source
unity7 desktop. Previous versions of Ubuntu used the gnome desktop.
As we explained in Chapter 2: The Ubuntu Desktop, a “user interface” is
a collection of software elements—icons, colors, windows, themes, and
menus—that determine how someone may interact with a computer. Some
people prefer using alternatives to gnome, so they have created Ubuntu
distributions featuring different user interfaces. These include:
‣ Kubuntu, which uses the kde graphical environment
‣ Lubuntu, which uses the lxde graphical environment
‣ Xubuntu, which uses the xfce graphical environment
Additionally, each of these distributions may contain default applications
different from those featured in Ubuntu. For instance, the default music
player in Ubuntu is Rhythmbox. In Lubuntu, the default music player is
Audacious, and in Kubuntu, the default is Amarok. Be sure to investigate
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these differences if you are considering installing an Ubuntu distribution
with an alternative desktop environment.
For more information about these and other derivative distributions, see
http://www.ubuntu.com/project/derivatives.
Task-specific distributions

Other Ubuntu distributions have been created to accomplish specific tasks
or run in specialized environments and settings.
Ubuntu Server Edition

The Ubuntu Server Edition is an operating system optimized to perform
multi-user tasks. Such tasks may include file sharing, website, or email
hosting. If you are planning to use a computer to perform these types of
tasks, you may wish to use this specialized server distribution in conjunction with server hardware. While it is possible to run a server-type environment using only the desktop version of Ubuntu, it is not advised as the
Server Edition is better optimized for the multi-user environment.
This manual does not explain the process of running a secure web server
or performing other tasks with Ubuntu Server Edition. For details on using
Ubuntu Server Edition, refer to the manual at http://www.ubuntu.com/
business/server/overview.
Edubuntu

Edubuntu is an Ubuntu derivative customized for use in schools and other
educational institutions. Edubuntu contains software similar to that offered
in Ubuntu but also features additional applications like a collaborative text
editor and educational games.
For additional information regarding Edubuntu, visit http://www.
edubuntu.org/
Ubuntu Studio

The derivative of Ubuntu called Ubuntu Studio is designed specifically for
people who use computers to create and edit multimedia projects. Ubuntu
Studio features applications to help users manipulate images, compose
music, and edit video. While users can install these applications on computers running the desktop version of Ubuntu, Ubuntu Studio makes them all
available immediately upon installation.
If you would like to learn more about Ubuntu Studio (or obtain a copy
for yourself), visit http://ubuntustudio.org/.
Mythbuntu

Mythbuntu allows users to turn their computers into entertainment systems. Mythbuntu helps users organize and view various types of multimedia content such as movies, television shows, and video podcasts. Users
with tv tuners in their computers can also use Mythbuntu to record live
video and television shows.
To learn more about Mythbuntu, visit http://www.mythbuntu.org/.
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Finding additional help and support

This guide cannot possibly contain everything you’ll ever need to know
about Ubuntu. We encourage you to take advantage of Ubuntu’s vast community when seeking further information, troubleshooting technical issues,
or asking questions about your computer.
It’s important to note that the Internet is full of third-party resources
as well as individuals who post information on blogs and forums. While
these resources can often seem like great resources, some could be misleading or outdated. It’s always best to verify information from third-party
sources before taking their advice. When possible, rely on official Ubuntu
documentation for assistance with Ubuntu.
Now, let’s discuss a few of the available resources to learn more about
Ubuntu and other Linux distributions.
Live chat

If you are familiar with Internet Relay Chat (irc), you can use chat clients
such as XChat or Pidgin to join the channel #ubuntu on irc.freenode.net. In
this channel, hundreds of volunteer users can answer your questions or offer technical support in real time. To learn more about using Internet Relay
Chat to seek help with Ubuntu, visit https://help.ubuntu.com/community/
InternetRelayChat.
LoCo teams

The Ubuntu community contains dozens of local user groups called “LoCo
teams.” Distributed throughout the world, these teams offer support and
advice, answer questions, and promote Ubuntu in their communities by
hosting regular events. To locate or contact the LoCo team nearest you,
visit http://loco.ubuntu.com/.
Books and Magazines

Many books have been written about Ubuntu, and professional magazines
often feature news and information related to Ubuntu. You will frequently
find these resources at your local bookstore or newsstand. If you know the
name of a book or magazine, e.g. this manual or Full Circle Magazine, you
can search for it on the Internet.
Official Ubuntu Documentation

The Ubuntu Documentation Team maintains a series of official wiki pages
designed to assist both new and experienced users wishing to learn more
about Ubuntu. The Ubuntu community endorses these documents, which
serve as a reliable first point of reference for users seeking online help. You
can access these resources at http://help.ubuntu.com. To get to the built-in
Ubuntu Desktop Guide, type help in the Dash.
The Ubuntu Forums

The Ubuntu Forums are the official forums of the Ubuntu community. Millions of Ubuntu users use them daily to seek help and support from one
another. You can create an Ubuntu Forums account in minutes. To create
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an account and learn more about Ubuntu from community members, visit
http://ubuntuforums.org.
Launchpad Answers

Launchpad, an open source code repository and user community, provides a
question and answer service that allows anyone to ask questions about any
Ubuntu-related topic. Signing up for a Launchpad account takes just a few
seconds. You can ask a question by visiting Launchpad at https://answers.
launchpad.net/ubuntu.
Ask Ubuntu

Ask Ubuntu is a free, community-driven website for Ubuntu users and
developers. Like the Ubuntu Forums, it allows users to post questions for
other members of the Ubuntu community to answer. But Ask Ubuntu also
allows visitors to “vote” on the answers users provide, so the most useful or
helpful responses get featured more prominently on the site. Ask Ubuntu is
part of the Stack Exchange network of websites and is one of the best free
Ubuntu support resources available. Visit http://www.askubuntu.com to get
started.
Search Engines

Because Ubuntu is a popular open source operating system, many users
have written about it online. Therefore, using search engines to locate
answers to your questions about Ubuntu is often an effective means of
acquiring help. When using search engines to answer questions about
Ubuntu, ensure that your search queries are as specific as possible. In other
words, a search for “Unity interface” will return results that are less useful
than those associated with the query “how to use Ubuntu Unity interface”
or “how to customize Ubuntu Unity interface.”
Community support

If you’ve exhausted all these resources and still can’t find answers to your
questions, visit Community Support at http://www.ubuntu.com/support/
community.
The Ubuntu community

Ubuntu is the flagship product created by a global community of passionate
users who want to help others adopt, use, understand, and even modify or
enhance Ubuntu. By choosing to install and run Ubuntu, you’ve become
part of this community. As you learn more about Ubuntu, you may wish
to collaborate with others as you promote Ubuntu to new users, to share
Ubuntu advice, or to answer other users’ questions. In this section, we’ll
discuss a few community projects that can connect you to other Ubuntu
users.
Full Circle Magazine

Full Circle Magazine is “the independent magazine for the Ubuntu Linux
community.” Released every month, Full Circle Magazine contains reviews
of new software (including games) for Ubuntu, step-by-step tutorials for
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projects you can accomplish with Ubuntu, editorials discussing important
issues in the Ubuntu community, and Ubuntu tips from other users. Full
Circle Magazine is released in many different formats and is always free.
You can download current and back issues of Full Circle Magazine at http://
fullcirclemagazine.org/.
The Ubuntu UK Podcast

Produced by members of the UK’s Ubuntu LoCo team, this bi-weekly online
audio broadcast (or “podcast”) features lively discussion about Ubuntu and
often includes interviews with Ubuntu community members who work to
improve Ubuntu. Episodes are available at http://ubuntupodcast.org/.
OMG! Ubuntu!

OMG! Ubuntu! is a weblog that aims to inform the Ubuntu community
about Ubuntu news, events, announcements, and updates in a timely fashion. It also allows Ubuntu users to discuss ways they can promote or share
Ubuntu. You can read this blog or subscribe to it at http://www.omgubuntu.
co.uk/.
Contributing
Contributing to Ubuntu

As we mentioned earlier in this chapter, Ubuntu is a community-maintained
operating system. You can help make Ubuntu better in a number of ways.
The community consists of thousands of individuals and teams. If you
would like to contribute to Ubuntu, please visit https://wiki.ubuntu.com/
ContributeToUbuntu.
You can also participate in the Ubuntu community by contributing to
this manual. You might choose to write new content for it, edit its chapters
so they are easier for new Ubuntu users to understand and use, or translate
it in your own language. Or maybe taking screenshots is your passion!
Regardless of your talent or ability, if you have a passion to contribute to
the Ubuntu community in a meaningful way, then the Ubuntu Manual
Project invites you to join! To get involved in the Ubuntu Manual Project,
visit http://ubuntu-manual.org/getinvolved.
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License

Creative Commons Attribution–ShareAlike 3.0 Legal Code

the work (as defined below) is provided under the terms of this
creative commons public license (“ccpl” or “license”). the work is
protected by copyright and/or other applicable law. any use of the
work other than as authorized under this license or copyright law
is prohibited.
by exercising any rights to the work provided here, you accept
and agree to be bound by the terms of this license. to the extent
this license may be considered to be a contract, the licensor grants
you the rights contained here in consideration of your acceptance
of such terms and conditions.
1. Definitions
(a) “Adaptation” means a work based upon the Work, or upon the Work
and other pre-existing works, such as a translation, adaptation,
derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes
cinematographic adaptations or any other form in which the Work
may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes
a Collection will not be considered an Adaptation for the purpose of
this License. For the avoidance of doubt, where the Work is a musical
work, performance or phonogram, the synchronization of the Work in
timed-relation with a moving image (“synching”) will be considered
an Adaptation for the purpose of this License.
(b) “Collection” means a collection of literary or artistic works, such
as encyclopedias and anthologies, or performances, phonograms
or broadcasts, or other works or subject matter other than works
listed in Section 1(f) below, which, by reason of the selection and
arrangement of their contents, constitute intellectual creations, in
which the Work is included in its entirety in unmodified form along
with one or more other contributions, each constituting separate and
independent works in themselves, which together are assembled into
a collective whole. A work that constitutes a Collection will not be
considered an Adaptation (as defined below) for the purposes of this
License.
(c) “Creative Commons Compatible License” means a license that is
listed at http://creativecommons.org/compatiblelicenses that has been
approved by Creative Commons as being essentially equivalent to this
License, including, at a minimum, because that license: (i) contains
terms that have the same purpose, meaning and effect as the License
Elements of this License; and, (ii) explicitly permits the relicensing
of adaptations of works made available under that license under this
License or a Creative Commons jurisdiction license with the same
License Elements as this License.
(d) “Distribute” means to make available to the public the original and
copies of the Work or Adaptation, as appropriate, through sale or
other transfer of ownership.
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(e) “License Elements” means the following high-level license attributes
as selected by Licensor and indicated in the title of this License: Attribution, ShareAlike.
(f) “Licensor” means the individual, individuals, entity or entities that
offer(s) the Work under the terms of this License.
(g) “Original Author” means, in the case of a literary or artistic work, the
individual, individuals, entity or entities who created the Work or if
no individual or entity can be identified, the publisher; and in addition
(i) in the case of a performance the actors, singers, musicians, dancers,
and other persons who act, sing, deliver, declaim, play in, interpret or
otherwise perform literary or artistic works or expressions of folklore;
(ii) in the case of a phonogram the producer being the person or legal
entity who first fixes the sounds of a performance or other sounds;
and, (iii) in the case of broadcasts, the organization that transmits the
broadcast.
(h) “Work” means the literary and/or artistic work offered under the
terms of this License including without limitation any production
in the literary, scientific and artistic domain, whatever may be the
mode or form of its expression including digital form, such as a book,
pamphlet and other writing; a lecture, address, sermon or other work
of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition
with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography;
a work of drawing, painting, architecture, sculpture, engraving or
lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art;
an illustration, map, plan, sketch or three-dimensional work relative
to geography, topography, architecture or science; a performance; a
broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or
circus performer to the extent it is not otherwise considered a literary
or artistic work.
(i) “You” means an individual or entity exercising rights under this License who has not previously violated the terms of this License with
respect to the Work, or who has received express permission from
the Licensor to exercise rights under this License despite a previous
violation.
(j) “Publicly Perform” means to perform public recitations of the Work
and to communicate to the public those public recitations, by any
means or process, including by wire or wireless means or public
digital performances; to make available to the public Works in such a
way that members of the public may access these Works from a place
and at a place individually chosen by them; to perform the Work to
the public by any means or process and the communication to the
public of the performances of the Work, including by public digital
performance; to broadcast and rebroadcast the Work by any means
including signs, sounds or images.
(k) “Reproduce” means to make copies of the Work by any means including without limitation by sound or visual recordings and the right
of fixation and reproducing fixations of the Work, including storage
of a protected performance or phonogram in digital form or other
electronic medium.
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2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit,
or restrict any uses free from copyright or rights arising from limitations
or exceptions that are provided for in connection with the copyright
protection under copyright law or other applicable laws.
3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the
rights in the Work as stated below:
(a) to Reproduce the Work, to incorporate the Work into one or more
Collections, and to Reproduce the Work as incorporated in the Collections;
(b) to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable
steps to clearly label, demarcate or otherwise identify that changes
were made to the original Work. For example, a translation could be
marked “The original work was translated from English to Spanish,”
or a modification could indicate “The original work has been modified.”;
(c) to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
(d) to Distribute and Publicly Perform Adaptations.
(e) For the avoidance of doubt:
i. Non-waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise
by You of the rights granted under this License;
ii. Waivable Compulsory License Schemes. In those jurisdictions
in which the right to collect royalties through any statutory or
compulsory licensing scheme can be waived, the Licensor waives
the exclusive right to collect such royalties for any exercise by You
of the rights granted under this License; and,
iii. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary
licensing schemes, via that society, from any exercise by You of the
rights granted under this License.
The above rights may be exercised in all media and formats whether
now known or hereafter devised. The above rights include the right to
make such modifications as are technically necessary to exercise the
rights in other media and formats. Subject to Section 8(f), all rights
not expressly granted by Licensor are hereby reserved.
4. Restrictions. The license granted in Section 3 above is expressly made
subject to and limited by the following restrictions:
(a) You may Distribute or Publicly Perform the Work only under the
terms of this License. You must include a copy of, or the Uniform
Resource Identifier (URI) for, this License with every copy of the Work
You Distribute or Publicly Perform. You may not offer or impose
any terms on the Work that restrict the terms of this License or the
ability of the recipient of the Work to exercise the rights granted to
that recipient under the terms of the License. You may not sublicense
the Work. You must keep intact all notices that refer to this License
and to the disclaimer of warranties with every copy of the Work
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You Distribute or Publicly Perform. When You Distribute or Publicly
Perform the Work, You may not impose any effective technological
measures on the Work that restrict the ability of a recipient of the
Work from You to exercise the rights granted to that recipient under
the terms of the License. This Section 4(a) applies to the Work as
incorporated in a Collection, but this does not require the Collection
apart from the Work itself to be made subject to the terms of this
License. If You create a Collection, upon notice from any Licensor You
must, to the extent practicable, remove from the Collection any credit
as required by Section 4(c), as requested. If You create an Adaptation,
upon notice from any Licensor You must, to the extent practicable,
remove from the Adaptation any credit as required by Section 4(c), as
requested.
(b) You may Distribute or Publicly Perform an Adaptation only under the
terms of: (i) this License; (ii) a later version of this License with the
same License Elements as this License; (iii) a Creative Commons jurisdiction license (either this or a later license version) that contains the
same License Elements as this License (e.g., Attribution-ShareAlike
3.0 US)); (iv) a Creative Commons Compatible License. If you license
the Adaptation under one of the licenses mentioned in (iv), you must
comply with the terms of that license. If you license the Adaptation
under the terms of any of the licenses mentioned in (i), (ii) or (iii) (the
“Applicable License”), you must comply with the terms of the Applicable License generally and the following provisions: (I) You must
include a copy of, or the URI for, the Applicable License with every
copy of each Adaptation You Distribute or Publicly Perform; (II) You
may not offer or impose any terms on the Adaptation that restrict
the terms of the Applicable License or the ability of the recipient of
the Adaptation to exercise the rights granted to that recipient under the terms of the Applicable License; (III) You must keep intact all
notices that refer to the Applicable License and to the disclaimer of
warranties with every copy of the Work as included in the Adaptation You Distribute or Publicly Perform; (IV) when You Distribute or
Publicly Perform the Adaptation, You may not impose any effective
technological measures on the Adaptation that restrict the ability of a
recipient of the Adaptation from You to exercise the rights granted to
that recipient under the terms of the Applicable License. This Section
4(b) applies to the Adaptation as incorporated in a Collection, but this
does not require the Collection apart from the Adaptation itself to be
made subject to the terms of the Applicable License.
(c) If You Distribute, or Publicly Perform the Work or any Adaptations
or Collections, You must, unless a request has been made pursuant
to Section 4(a), keep intact all copyright notices for the Work and
provide, reasonable to the medium or means You are utilizing: (i) the
name of the Original Author (or pseudonym, if applicable) if supplied,
and/or if the Original Author and/or Licensor designate another party
or parties (e.g., a sponsor institute, publishing entity, journal) for attribution (“Attribution Parties”) in Licensor’s copyright notice, terms of
service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably
practicable, the URI, if any, that Licensor specifies to be associated
with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with
Ssection 3(b), in the case of an Adaptation, a credit identifying the
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use of the Work in the Adaptation (e.g., “French translation of the
Work by Original Author,” or “Screenplay based on original Work
by Original Author”). The credit required by this Section 4(c) may be
implemented in any reasonable manner; provided, however, that in
the case of a Adaptation or Collection, at a minimum such credit will
appear, if a credit for all contributing authors of the Adaptation or
Collection appears, then as part of these credits and in a manner at
least as prominent as the credits for the other contributing authors.
For the avoidance of doubt, You may only use the credit required by
this Section for the purpose of attribution in the manner set out above
and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship
or endorsement by the Original Author, Licensor and/or Attribution
Parties, as appropriate, of You or Your use of the Work, without the
separate, express prior written permission of the Original Author,
Licensor and/or Attribution Parties.
(d) Except as otherwise agreed in writing by the Licensor or as may be
otherwise permitted by applicable law, if You Reproduce, Distribute
or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take
other derogatory action in relation to the Work which would be prejudicial to the Original Author’s honor or reputation. Licensor agrees
that in those jurisdictions (e.g. Japan), in which any exercise of the
right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification
or other derogatory action prejudicial to the Original Author’s honor
and reputation, the Licensor will waive or not assert, as appropriate,
this Section, to the fullest extent permitted by the applicable national
law, to enable You to reasonably exercise Your right under Section
3(b) of this License (right to make Adaptations) but not otherwise.
5. Representations, Warranties and Disclaimer
unless otherwise mutually agreed to by the parties in writing,
licensor offers the work as-is and makes no representations
or warranties of any kind concerning the work, express, implied, statutory or otherwise, including, without limitation,
warranties of title, merchantibility, fitness for a particular
purpose, noninfringement, or the absence of latent or other defects, accuracy, or the presence of absence of errors, whether or
not discoverable. some jurisdictions do not allow the exclusion
of implied warranties, so such exclusion may not apply to you.
6. Limitation on Liability. except to the extent reqired by applicable law, in no event will licensor be liable to you on any legal
theory for any special, incidental, conseqential, punitive or
exemplary damages arising out of this license or the use of the
work, even if licensor has been advised of the possibility of such
damages.
7. Termination
(a) This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals
or entities who have received Adaptations or Collections from You
under this License, however, will not have their licenses terminated
provided such individuals or entities remain in full compliance with
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those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination
of this License.
(b) Subject to the above terms and conditions, the license granted here is
perpetual (for the duration of the applicable copyright in the Work).
Notwithstanding the above, Licensor reserves the right to release
the Work under different license terms or to stop distributing the
Work at any time; provided, however that any such election will not
serve to withdraw this License (or any other license that has been, or
is required to be, granted under the terms of this License), and this
License will continue in full force and effect unless terminated as
stated above.
8. Miscellaneous
(a) Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the
same terms and conditions as the license granted to You under this
License.
(b) Each time You Distribute or Publicly Perform an Adaptation, Licensor
offers to the recipient a license to the original Work on the same
terms and conditions as the license granted to You under this License.
(c) If any provision of this License is invalid or unenforceable under
applicable law, it shall not affect the validity or enforceability of the
remainder of the terms of this License, and without further action
by the parties to this agreement, such provision shall be reformed
to the minimum extent necessary to make such provision valid and
enforceable.
(d) No term or provision of this License shall be deemed waived and no
breach consented to unless such waiver or consent shall be in writing
and signed by the party to be charged with such waiver or consent.
(e) This License constitutes the entire agreement between the parties
with respect to the Work licensed here. There are no understandings,
agreements or representations with respect to the Work not specified
here. Licensor shall not be bound by any additional provisions that
may appear in any communication from You. This License may not be
modified without the mutual written agreement of the Licensor and
You.
(f) The rights granted under, and the subject matter referenced, in this
License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on
September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty
of 1996 and the Universal Copyright Convention (as revised on July
24, 1971). These rights and subject matter take effect in the relevant
jurisdiction in which the License terms are sought to be enforced
according to the corresponding provisions of the implementation of
those treaty provisions in the applicable national law. If the standard
suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are
deemed to be included in the License; this License is not intended to
restrict the license of any rights under applicable law.
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Creative Commons Notice

Creative Commons is not a party to this License, and makes no warranty
whatsoever in connection with the Work. Creative Commons will not be
liable to You or any party on any legal theory for any damages whatsoever,
including without limitation any general, special, incidental or consequential damages arising in connection to this license. Notwithstanding the
foregoing two (2) sentences, if Creative Commons has expressly identified
itself as the Licensor hereunder, it shall have all rights and obligations of
Licensor.
Except for the limited purpose of indicating to the public that the Work
is licensed under the CCPL, Creative Commons does not authorize the use
by either party of the trademark “Creative Commons” or any related trademark or logo of Creative Commons without the prior written consent of
Creative Commons. Any permitted use will be in compliance with Creative
Commons’ then-current trademark usage guidelines, as may be published
on its website or otherwise made available upon request from time to time.
For the avoidance of doubt, this trademark restriction does not form part of
the License.
Creative Commons may be contacted at http://creativecommons.org/.

Glossary
Access Point A device that allows for a wireless connection to a local network using Wi-Fi, Bluetooth, etc.
applet A small program that runs in a panel. Applets provide useful functions such as starting a program, viewing the time, or accessing the main
menu of an application.
Canonical Canonical, the financial backer of Ubuntu, provides support for
the core Ubuntu system. It has over 500 staff members worldwide who
ensure that the foundation of the operating system is stable, as well as
checking all the work submitted by volunteer contributors. To learn
more about Canonical, go to http://www.canonical.com.
cli cli or command-line interface is another name for the terminal.
desktop environment A generic term to describe a gui interface for humans
to interact with computers. There are many desktop environments such
as Unity, gnome, kde, xfce and lxde, to name a few.
dhcp dhcp stands for Dynamic Host Configuration Protocol, it is used by a
dhcp server to assign computers on a network an ip address automatically.
dialup connection A dialup connection is when your computer uses a modem to connect to an isp through your telephone line.
distribution A distribution is a collection of software that is already compiled and configured ready to be installed. Ubuntu is an example of a
distribution.
dual-booting Dual-booting is the process of being able to choose one of
two different operating systems currently installed on a computer from
the boot menu. Once selected, your computer will boot into whichever
operating system you chose at the boot menu. The term dual-booting is
often used generically, and may refer to booting among more than two
operating systems.
encryption Encryption is a security measure, it prevents others from accessing and viewing the contents of your files and/or hard drives, the files
must first be decrypted with your password.
Ethernet port An Ethernet port is what an Ethernet cable is plugged into
when you are using a wired connection.
gui The gui (which stands for Graphical User Interface) is a type of user interface that allows humans to interact with the computer using graphics
and images rather than just text.
isp isp stands for Internet Service Provider, an isp is a company that provides
you with your Internet connection.
Live dvd A Live dvd allows you to try out an operating system before you
actually install it, this is useful for testing your hardware, diagnosing
problems and recovering your system.
lts lts stands for long-term support and is a type of Ubuntu release that is
officially supported for far longer than the standard releases.
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maximize When you maximize an application in Ubuntu it will fill the
whole desktop, excluding the panels.
minimize When you minimize an open application, the window will no
longer be shown. If you click on a minimized application’s icon in the
Launcher, it will be restored to its normal state and allow you to interact
with it.
notification area The notification area is an applet on the panel that provides you with all sorts of information such as volume control, the current song playing in Rhythmbox, your Internet connection status and
email status.
output The output of a command is any text it displays on the next line
after typing a command and pressing enter, e.g., if you type pwd into a
terminal and press Enter, the directory name it displays on the next line
is the output.
package Packages contain software in a ready-to-install format. Most of
the time you can use Ubuntu Software instead of manually installing
packages. Packages have a .deb extension in Ubuntu.
panel A panel is a bar that sits on the edge of your screen. It contains applets which provide useful functions such as running programs, viewing
the time, or accessing the main menu.
parameter Parameters are special options that you can use with other
commands in the terminal to make that command behave differently, this
can make a lot of commands far more useful.
ppa A personal package archive (ppa) is a custom software repository that
typically contains either packages that aren’t available in the primary
Ubuntu repositories or newer versions of packages that are available in
the primary repositories.
prompt The prompt displays some useful information about your computer.
It can be customized to display in different colors, display the time, date,
and current directory or almost anything else you like.
proprietary Software made by companies that don’t release their source
code under an open source license.
router A router is a specially designed computer that, using its software
and hardware, routes information from the Internet to a network. It is
also sometimes called a gateway.
server A server is a computer that runs a specialized operating system and
provides services to computers that connect to it and make a request.
shell The terminal gives access to the shell, when you type a command into
the terminal and press enter the shell takes that command and performs
the relevant action.
Synaptic Package Manager Synaptic Package Manager is a tool that, instead
of listing applications (like Ubuntu Software) lists individual packages
that can then be installed, removed and fixed.
terminal The terminal is Ubuntu’s text-based interface. It is a method of
controlling the operating system using only commands entered via the
keyboard as opposed to using a gui like Unity.
Ubuntu Software Ubuntu Software is where you can easily manage soft-
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ware installation and removal as well as the ability to manage software
installed via Personal Package Archives.
usb Universal Serial Bus is a standard interface specification for connecting
peripheral hardware devices to computers. usb devices range from
external hard drives to scanners and printers.
wired connection A wired connection is when your computer is physically
connected to a router or Ethernet port with a cable. This is the most
common method of connecting to the Internet and local network for
desktop computers.
wireless connection A network connection that uses a wireless signal to
communicate with either a router, access point, or computer.
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audio, playing, see Rhythmbox
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troubleshooting, 111
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Canonical, 6
cds and dvds
blanking, 75
burning, 73–77
codecs, 68
copying, 76
playing, 69, 70
ripping, 71
Choqok, 64–65
codecs
audio, 73
video, 68
command line, see terminal
Corebird, 64
Dash, 21
Debian, 6, see also Linux
derivatives, 118
desktop
background, 20
customization, 30
appearance, 30
background, 31
theme, 30
menu bar, 20
sharing, 62
disk, see cds and dvds
display
adding secondary, 80–81
changing resolution, 80
troubleshooting, 114
drivers, 79–80

DRM, 68
dual-booting, 13
dvds and cds, see cds and dvds
Edubuntu, 119
EeePC
troubleshooting, 115
email, see Thunderbird
Empathy, 59–63
add accounts, 59
chatting, 61–62
desktop sharing, 62
setup, 59
encryption, see security
file system structure, 99–100
Files, 27
multiple tabs, 29
multiple windows, 29
window, 27
files
browsing, 26
opening files, 28
recovering, 113
files and folders
copying, 28
creating, 28
displaying hidden, 28
moving, 28
searching, 29–30
Firefox, 46–55
firewall
installing, 104
using, 104
FireWire, see ieee 1394
gestures, 85
groups, see also users
adding, 103
deleting, 103
files and folders, 104
managing, 103
modifying, 103
hardware
troubleshooting, 116
help
Ask Ubuntu, 121
documentation, 120
forums, 120
Full Circle Magazine, 121
general help, 34
heads-up display (hud), 35

Launchpad Answers, 121
live chat, 120
online, 34
home folder, 26
ieee 1394, 86
instant messaging, see Empathy
Internet
browsing, 46–55
connecting, 39–46
wireless, 42
Internet radio, 71
kernel, 6
keyboard, 85
Launcher, 21
running applications, 21
LibreOffice, 77
Linux, 6–7
Linux distributions, 117–118
Live dvd, see Ubuntu Live dvd
locking the screen, 33
logging out, 33
login options, 15–16
Mac OS X, see MacBook
MacBook
troubleshooting, 115
microblogging, see Choqok, see Corebird
monitor, see display
mounting devices, 100
mouse, 85
Movie Player, 68
multitouch, 85
music, see Rhythmbox
Mythbuntu, 119
NetworkManager, 39
open-source software, 117
OS X, see MacBook
password, see security
photos, see also Shotwell
editing, 66
importing, 65
viewing, 65
podcasts, 72
presentation application, 77
printer, 81, 82
add via usb, 81
adding via network, 81
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rebooting, 33
ReplayGain, 72
Rhythmbox, 69–73
Internet radio, 71
playing music, 69
podcasts, 72
scanner, 84
troubleshooting, 84
screen, see display
security
encryption, 105
introduction, 100–101
passwords, 101
permissions, 101
resetting passwords, 112
screen locking, 101
system updates, 104
Shotwell, 65–68
shutting down, 33
Shuttleworth, Mark, 6
slide show, see LibreOffice
software
adding repository, 93–94
email, 37
finding applications, 88–89
installing, 89
managing, 91
manual installation, 94
movie players, 38
multimedia players, 38
music players, 38
office suites, 37
pdf reader, 37
podcast readers, 38
presentation, 37
recommendations, 91
removing, 89–91

repositories, 91
servers, 92–93
spreadsheet, 37
video players, 38
web browser, 37
word processor, 37
Software Center, 88
sound
input, 83
output, 83
recording, 83
troubleshooting, 114
volume, 82
sound effects, 83
spreadsheet, 77
start up, see boot
suspending the computer, 33
system requirements, 9
terminal
about, 97
using, 98
Thunderbird, 55–59
setup, 55
torrent
Ubuntu image, 10
touchpad, 85
Twitter, see Choqok, see Corebird
Ubuntu
bootable usb drive, 10
definition of, 5
downloading, 9
history of, 6
installing, 11–16
philosophy of, 5–6
Ubuntu Live dvd, 10–11
Ubuntu Promise, 6

Ubuntu Server Edition, 119
Ubuntu Studio, 119
Unity, 19
Unix, 6, 7
unmounting devices, 100
updates
about, 95–96
automatic, 96
release updates, 96
usb, 85
users, see also groups
adding, 102
creating during installation, 15–16
deleting, 103
managing, 102
modifying, 103
video
troubleshooting, 114
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